[tarako][fugu][hamachi]can join hidden wifi network without ssid name

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
6 months ago

People

(Reporter: xinhe.yan, Assigned: jingmei.zhang)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(7 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/11.04 Chromium/18.0.1025.151 Chrome/18.0.1025.151 Safari/535.19

Steps to reproduce:

1. Tap on Settings Icon, Tap on WiFi settings
2. Go Manage networks under Advance settings 
3. Tap on "Join Hidden Network" under Hidden networks.
4. Just Enter 12345678 in password, not enter SSID name
5. Press OK button on a upper right corner.


Actual results:

Network without SSID name is shown in known networks list


Expected results:

Can not press OK in step 5
(Reporter)

Updated

5 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Reporter)

Comment 1

5 years ago
Created attachment 825240 [details]
hiddenssid_withouname.jpg
(Reporter)

Updated

5 years ago
Summary: [unagi]can join hidden wifi network without ssid name → [unagi][fugu]can join hidden wifi network without ssid name
(Reporter)

Updated

5 years ago
Summary: [unagi][fugu]can join hidden wifi network without ssid name → [hamachi][fugu]can join hidden wifi network without ssid name
hamachi also has this issue, take it easy.
Vincent, is it a known issue?
Flags: needinfo?(vchang)

Updated

5 years ago
Flags: needinfo?(vchang)

Comment 4

5 years ago
Vincent, please provide your comments.
Flags: needinfo?(vchang)
This is a kind of error handling and should be done in Gaia.
Flags: needinfo?(vchang)

Updated

5 years ago
Assignee: nobody → ehung

Updated

5 years ago
blocking-b2g: --- → fugu+
After discussed with our partner, it will not block fugu.
blocking-b2g: fugu+ → ---

Updated

5 years ago
blocking-b2g: --- → 1.3?
Not a regression, so this is not a blocker.
blocking-b2g: 1.3? → -

Comment 8

5 years ago
will it be fixed in v1.3t?
blocking-b2g: - → 1.3T?
Hi Evelyn, are you still working this issue? thanks
Flags: needinfo?(ehung)
i don't feel this should be a blocker. can you confirm if this is a blocker for your testing? and will your team be able to contribute a fix on this? thanks
Flags: needinfo?(sam.hua)
not a regression so not a blocker, using the same justification we made for 1.3.
blocking-b2g: 1.3T? → -

Comment 12

5 years ago
okay. we will work out a patch about it.
Flags: needinfo?(sam.hua)

Comment 13

5 years ago
don't know why this bug is on me. de-assign meself.
Assignee: ehung → nobody
Flags: needinfo?(ehung)
Summary: [hamachi][fugu]can join hidden wifi network without ssid name → [tarako][fugu][hamachi]can join hidden wifi network without ssid name
(Assignee)

Comment 14

4 years ago
Created attachment 8428955 [details] [diff] [review]
bug933192.patch

Dear all:
A patch to solve the bug is in the attachment.
1.the rootcause about this bug is:
the origin code only use the password to disable or enable the submit button.
2.solution:
use '&&' to add the name of the ssid as another factor to enable the submit button.
(Assignee)

Comment 15

4 years ago
Pls help assigning to the module owner to review
Flags: needinfo?(ehung)

Updated

4 years ago
Attachment #8428955 - Flags: review?(ejchen)
Flags: needinfo?(ehung)
Comment on attachment 8428955 [details] [diff] [review]
bug933192.patch

Review of attachment 8428955 [details] [diff] [review]:
-----------------------------------------------------------------

Just left some comments about nits on the patch and please help to make sure it passes linter and functionalities all work well.

Thanks :]

::: apps/settings/js/wifi.js
@@ +830,4 @@
>                  .length > 32) {
>              ssid.value = ssidStr.substring(0, ssidStr.length - 1);
>            }
> +        //disable the "OK" button if the password is too short or the name is null

make this line less than 80 characters.

@@ +834,5 @@
> +        dialog.querySelector('button[type=submit]').disabled =
> +            !(WifiHelper.isValidInput(key,
> +                                     password.value,
> +                                     identity.value,
> +                                     eap.value) && ssidStr);

please help to fix indentations here !

And also, can you put `ssidStr` on the front so that we can pass the check quicker based on `short-circuit evaluation` ? thanks !

@@ +839,5 @@
>          };
>        }
> +      //disable the "OK" button if the password is too short or the name is null
> +      //it is the same with the code above to make sure that 'ok' is abled no matter we 
> +      //input the password or the name first. 

remove empty space and please break these lines to make each line less than 80 characters. Otherwise you can't pass linter.

@@ +848,3 @@
>                                       password.value,
>                                       identity.value,
> +                                     eap.value) && ssidStr);

please help to fix indentations here ! And plz move ssidStr to the front to pass `short-circuit evaluation`
Attachment #8428955 - Flags: review?(ejchen)
Fernando,

I just noticed that we can also join hidden network from FTU. After considerations, I think we can add one more parameter (the last one) inside `WifiHelper.isValidInput` to make sure this check would be encapsulated inside the function and we just have to call the function to show the ok button or not.

What do you think ?
Flags: needinfo?(fernando.campo)
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #17)
> Fernando,
> 
> I just noticed that we can also join hidden network from FTU. After
> considerations, I think we can add one more parameter (the last one) inside
> `WifiHelper.isValidInput` to make sure this check would be encapsulated
> inside the function and we just have to call the function to show the ok
> button or not.
> 
> What do you think ?
Good idea. whatever we can share for both modules, should be shared to keep everything sync.
Flags: needinfo?(fernando.campo)
(In reply to Fernando Campo (:fcampo) from comment #18)
> Good idea. whatever we can share for both modules, should be shared to keep
> everything sync.

Ok ! Thanks for your quick response, Fernando. Let's just do this !
Comment on attachment 8428955 [details] [diff] [review]
bug933192.patch

Review of attachment 8428955 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Jingmei,

after discussing with Fernando, it would be better to pass ssidStr as the last parameter into WifiHelper.isValidInput().

In this way, FTU can also get advantages from this change. So please help to patch wifi_helper & ftu, thanks ! :]

::: apps/settings/js/wifi.js
@@ +834,5 @@
> +        dialog.querySelector('button[type=submit]').disabled =
> +            !(WifiHelper.isValidInput(key,
> +                                     password.value,
> +                                     identity.value,
> +                                     eap.value) && ssidStr);

please ignore this line and put ssidStr as the last parameter into WifiHelper and plz patch the same logic in wifi_helper & FTU.

We can encapsulate all logics into WifiHelper.isValidInput().

@@ +848,3 @@
>                                       password.value,
>                                       identity.value,
> +                                     eap.value) && ssidStr);

please ignore this line and put ssidStr as the last parameter into WifiHelper and plz patch the same logic in wifi_helper & FTU.

We can encapsulate all logics into WifiHelper.isValidInput().
(Assignee)

Comment 21

4 years ago
Created attachment 8436291 [details] [diff] [review]
new-patch-for-933192.patch

hi ejchen:

  thank you for your advices.

  and I have made a new patch as you said above.

  The main changes in the new patch are:

  1.one more parameter ssidStr inside `WifiHelper.isValidInput` is addded.
  2.while the wifi-security changes,the join button's statu will change according to the return of function isValidInput.
  3.the event listener both for the ssidname text and the wifi identity text are made in ui.js(communication/ftu/js) and wifi.js(setting/js/wifi.js).

  please help to review and if there are anything to modify,let me know.

  thanks a lot!
Flags: needinfo?(ejchen)
Comment on attachment 8436291 [details] [diff] [review]
new-patch-for-933192.patch

Review of attachment 8436291 [details] [diff] [review]:
-----------------------------------------------------------------

Just left some comments on the patch.

By the way, plz rebase your codebase to our latest master because your patch looks like a little bit outdated and I can't apply it on my side here.

::: apps/settings/js/wifi.js
@@ +813,3 @@
>          loadImportedCertificateOptions(certificate);
>          description = dialog.querySelector('li.server-certificate-description');
>        }

nit: put one more empty line here.

@@ +834,5 @@
> +          dialog.querySelector('button[type=submit]').disabled =
> +            !WifiHelper.isValidInput(key,
> +                                     password.value,
> +                                     identity.value,
> +                                     ssidStr,

`ssidStr` is the last parameter.

@@ +847,5 @@
>            dialog.querySelector('button[type=submit]').disabled =
>              !WifiHelper.isValidInput(key,
>                                       password.value,
>                                       identity.value,
> +                                     ssidStr,

`ssidStr` is the last parameter.

::: shared/js/wifi_helper.js
@@ +98,4 @@
>      return key === curkey;
>    },
>  
> +  isValidInput: function(key, password, identity, ssidStr, eap) {

nit: change `ssidStr` to `ssid` because they are all String type.

and also change this as the `last` parameter please.
Hi Jingmei,

for me, I think this patch is almost ready, please rebase first and file a PR to Github by following our working flow. After these stuffs got done, please set r? to :eragonj (me) and :fcampo (Fernando, FTU guru). 

Thanks :)
Flags: needinfo?(ejchen)
(Assignee)

Comment 24

4 years ago
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #22)
> Comment on attachment 8436291 [details] [diff] [review]
> new-patch-for-933192.patch
> 
> Review of attachment 8436291 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Just left some comments on the patch.
> 
> By the way, plz rebase your codebase to our latest master because your patch
> looks like a little bit outdated and I can't apply it on my side here.
> 
> ::: apps/settings/js/wifi.js
> @@ +813,3 @@
> >          loadImportedCertificateOptions(certificate);
> >          description = dialog.querySelector('li.server-certificate-description');
> >        }
> 
> nit: put one more empty line here.
> 
> @@ +834,5 @@
> > +          dialog.querySelector('button[type=submit]').disabled =
> > +            !WifiHelper.isValidInput(key,
> > +                                     password.value,
> > +                                     identity.value,
> > +                                     ssidStr,
> 
> `ssidStr` is the last parameter.
> 
> @@ +847,5 @@
> >            dialog.querySelector('button[type=submit]').disabled =
> >              !WifiHelper.isValidInput(key,
> >                                       password.value,
> >                                       identity.value,
> > +                                     ssidStr,
> 
> `ssidStr` is the last parameter.
> 
> ::: shared/js/wifi_helper.js
> @@ +98,4 @@
> >      return key === curkey;
> >    },
> >  
> > +  isValidInput: function(key, password, identity, ssidStr, eap) {
> 
> nit: change `ssidStr` to `ssid` because they are all String type.
> 
> and also change this as the `last` parameter please.

  I don't think it is better to change the parameter 'ssidStr' as the `last` parameter in function isValidInput,for 'eap' is not always required,such as in the following codes
@@ -423,6 +445,12 @@ var UIManager = {

>+        this.wifiJoinButton.disabled = !WifiHelper.isValidInput(
>+          this.hiddenWifiSecurity.value,
>+          this.hiddenWifiPassword.value,
>+          this.hiddenWifiIdentity.value,
>+          this.hiddenWifiSsid.value
>+        );

 then we can just input four parameters witout 'eap'.

 if we change 'ssidStr' as the `last` parametert,we have to place the 'eap' as 'undefined' in the code above?
(In reply to jingmei.zhang from comment #24)

Thanks Jingmei, I just missed that and thanks for clarifications. Please ignore my comments about `move ssidStr to the last parameter` and follow the others.

In my undergoing refactoring works, I already changed them with one parameter (objects) to make sure we don't have to rely on the numbers of arguments and I think it would be better for such case.

THanks again ;)
(Assignee)

Comment 26

4 years ago
Created attachment 8437607 [details] [diff] [review]
lastest-patch-for-bug933192.patch

hi ejchen:

   the latest patch is in attachment list,and you can see the pull request in 
  
https://github.com/mozilla-b2g/gaia/pull/20284.

  Pls help to review.

  thanks!
Attachment #8437607 - Flags: review?(fernando.campo)
Attachment #8437607 - Flags: review?(ejchen)
Comment on attachment 8437607 [details] [diff] [review]
lastest-patch-for-bug933192.patch

Review of attachment 8437607 [details] [diff] [review]:
-----------------------------------------------------------------

code looks good!
few nits on github, mostly for code style. r? again when fixed

thanks!
Attachment #8437607 - Flags: review?(fernando.campo)
Comment on attachment 8437607 [details] [diff] [review]
lastest-patch-for-bug933192.patch

Review of attachment 8437607 [details] [diff] [review]:
-----------------------------------------------------------------

Left two nits on Github, basically they are good to me.

Please r? again when nits got fixed, thanks for your efforts, Jingmei.
Attachment #8437607 - Flags: review?(ejchen)
(Assignee)

Comment 29

4 years ago
Created attachment 8439158 [details] [diff] [review]
github.patch

hi ejchen & fernando:

   See the pull request in:

   https://github.com/mozilla-b2g/gaia/pull/20434

   the new patch named github.patch is listed in the attachment.

   Thanks!
Attachment #8439158 - Flags: review?(fernando.campo)
Attachment #8439158 - Flags: review?(ejchen)
(Assignee)

Comment 30

4 years ago
    Thank you for your great advices @ejchen,@fernando,and I have learned a lot.
Comment on attachment 8439158 [details] [diff] [review]
github.patch

Review of attachment 8439158 [details] [diff] [review]:
-----------------------------------------------------------------

Nice job jingmei, FTU part looks good, no need of more changes.
Just a little concern for the shared/wifi_helper, I left a comment on github about a corner case.

And also, following the current policy, before merging anything we need unit tests for it.
Please ask for r? once comment is answered and new tests passing :) Thank you!
Attachment #8439158 - Flags: review?(fernando.campo)
Comment on attachment 8439158 [details] [diff] [review]
github.patch

Review of attachment 8439158 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM for settings part and please follow :fcampo's comments to add unit tests. 

You can add tests under "apps/sharedtest/test/unit/*" for shared js.

After finishing tests, plz don't hesitate to ask for review again, thanks for your efforts :)
Attachment #8439158 - Flags: review?(ejchen)
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #32)
> Comment on attachment 8439158 [details] [diff] [review]
> github.patch
> 
> Review of attachment 8439158 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> LGTM for settings part and please follow :fcampo's comments to add unit
> tests. 
> 
> You can add tests under "apps/sharedtest/test/unit/*" for shared js.
Sorry for jumping in here, but I think it's better to add specific tests for each app, not for the shared utility file, as I'm not sure that tests in shared folder are launched at all, and we need to test the app user story, not the utility per se.
At least for FTU, you should set the tests under ftu/test/wifi_test.js. Unsure about settings.
(In reply to Fernando Campo (:fcampo) from comment #33)
> (In reply to EJ Chen [:eragonj][:小龍哥] from comment #32)
> > Comment on attachment 8439158 [details] [diff] [review]
> > github.patch
> > 
> > Review of attachment 8439158 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > LGTM for settings part and please follow :fcampo's comments to add unit
> > tests. 
> > 
> > You can add tests under "apps/sharedtest/test/unit/*" for shared js.
> Sorry for jumping in here, but I think it's better to add specific tests for
> each app, not for the shared utility file, as I'm not sure that tests in
> shared folder are launched at all, and we need to test the app user story,
> not the utility per se.
> At least for FTU, you should set the tests under ftu/test/wifi_test.js.
> Unsure about settings.

@Fernando,

I am ok with adding test in FTU app but I also think it is necessary to add them in sharedtest app. Because for FTU/settings app, we would focus more on UI (something is disabled or not blah), but for sharedtest app, we would focus more on the core functionalities of these helpers. So, I think it is still necessary to add them on sharedtest app.

@Jingmei,

for FTU app, please address Fernando's comments.

While for Settings app, because currently there is no unit test for wifi module at all. At this moment, it is acceptable for me to update the code in Settings without test especially this is a minor change. So for me, because this is a shared utils, I still think it is necessary to have unit tests under "apps/sharedtest/test/unit/*". (There is a wifi_helper_test.js already, so it is not so tough for you to add one more test case :P)

Right now, We are intensively working on refactoring & add unit tests on wifi panel in Bug 973466. Later, I would add the missing test in that bug based on the change you made here.

Thanks all :)
(Assignee)

Comment 35

4 years ago
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #34)
> @Jingmei,
> 
> for FTU app, please address Fernando's comments.
> 
> While for Settings app, because currently there is no unit test for wifi
> module at all. At this moment, it is acceptable for me to update the code in
> Settings without test especially this is a minor change. So for me, because
> this is a shared utils, I still think it is necessary to have unit tests
> under "apps/sharedtest/test/unit/*". (There is a wifi_helper_test.js
> already, so it is not so tough for you to add one more test case :P)
> 
> Right now, We are intensively working on refactoring & add unit tests on
> wifi panel in Bug 973466. Later, I would add the missing test in that bug
> based on the change you made here.
> 
> Thanks all :)
hi ejchen:
   About the test file,I have a little confusion:as there are as many as four inputs in the isValidInput function,to make the test wide coverage,should I list all the cases in the test file or just enumerate several typicale ones?
(Assignee)

Updated

4 years ago
Flags: needinfo?(ejchen)
It would be *thankful* if you can cover all cases there !

If not, you have to add test cases to cover your changes in your patch at least !

Thanks Jingmei !! :)
Flags: needinfo?(ejchen)
(Assignee)

Comment 37

4 years ago
Created attachment 8454861 [details] [diff] [review]
patchWithTest.patch

hi ejchen:

  I have put the new patch in the attachment.the relevant test file is added in the new patch too.

  as this is my first time to write the test file,there might be something inappropriate,please help to check.if there are something needed to modify,let me know.

  thank you very much!
Flags: needinfo?(ejchen)
Assignee: nobody → jingmei.zhang
Jingmei, please file a PR for this patch because CI will help you test your code there.

I did check your tests and they all can't run on our local, please make sure they did workable before setting review. 

BTW, please set r? on the attachment which points to the github link and I will do the review there.

Thanks for the help.
Flags: needinfo?(ejchen)
(Assignee)

Comment 39

4 years ago
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #38)
> Jingmei, please file a PR for this patch because CI will help you test your
> code there.
> 
> I did check your tests and they all can't run on our local, please make sure
> they did workable before setting review. 
> 
> BTW, please set r? on the attachment which points to the github link and I
> will do the review there.
> 
> Thanks for the help.

hi ejchen:

  I have tested the test file in my local,it says the return of 'document.getElementById('hidden-wifi-ssid')' is null.

  should I have to include some relevant files before use the id 'hidden-wifi-ssid'??

  I really knows little about the test file,and I am so sorry to trouble you……
Flags: needinfo?(ejchen)
Comment on attachment 8454861 [details] [diff] [review]
patchWithTest.patch

Review of attachment 8454861 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Jingmei,

I already left all my thoughts about your patch and please go to check them.

For me, I have only one criteria for reviewing, your code must work at first and I will try to help you find out the flaws you didn't notice to make sure the patch is robust enough for the whole FxOS.

Hope these comments and information helps you a lot. 

Thanks !!

::: apps/ftu/test/unit/wifi_test.js
@@ +169,3 @@
>        });
>      });
>  

Ok in wifi_test.js, based on another reviewer's comment, you have to make sure DOM would do the right thing as what you wish. In this test, you don't have to test the same thing as what you did in apps/ftu/test/unit/wifi_test.js. 

Here, you have to create a new suite to host your test and make sure to call `createDOM()` in `setup()` function to make sure you append needed doms into the body and make sure to remove them in `teardown()` function so that you won't pollute the other tests in this file.

After setting up the DOM, you can try to call WifiManager.chooseNetwork() from apps/ftu/js/wifi.js to check whether its inner function - isValidInput() will do the right thing as what you thought. And also, you have to change related DOM's value to test different situations.

If you have any problem about unit tests like this, please check the other test cases and you can find the right way to write it. It's not that tough but takes time at first to jump in the testing world.

::: apps/settings/js/wifi.js
@@ +816,3 @@
>          description = dialog.querySelector('li.server-certificate-description');
>        }
>  

Well, few days ago, we made a huge refactor on Wifi panel. Right now this file (wifi.js) has been totally removed from our codebase and please make sure rebase your codebase and fix at the right place with our new code.

Please check apps/settings/js/panels/wifi_join_hidden/panel.js and apps/settings/js/modules/wifi_utils.js

::: apps/sharedtest/test/unit/wifi_helper_test.js
@@ +152,4 @@
>        triggerCallback('getNetworks', 'onsuccess');
>        triggerCallback('getKnownNetworks', 'onsuccess');
>      });
> +

You can see that this is an unit test, so all you have to do is check whether `WifiHelper.isValidInput` works like a charm as what you expected. 

So you don't have to manipulate any DOM here, you just have to pass different values like WifiHelper.isValidInput(xx, xx, xx, xx), WifiHelper.isValidInput(yy, yy, yy) ... etc to check different situations and make sure you will get the right result as what you expected.

::: shared/js/wifi_helper.js
@@ +113,5 @@
>        }
>      }
>  
> +    // first to see if the ssid is null,if so,return false
> +    if (!ssid ) {

if (!ssid) {
  // ...
}

instead, please remove the whitespace !
By the way, if this patch is only for 1.3t and 1.4, just forget the comment about rebasing because our refactor change is only made in version >= 2.0.

thanks man ! :)
(Assignee)

Comment 42

4 years ago
Created attachment 8470634 [details] [diff] [review]
testinFTU-newmaster.patch

hi ejchen:

> in this test, you don't have to test the same thing as what you did in apps/ftu/test/unit/wifi_test.js

 Is that to say one test file is enough for the changes in ftu and settings? Because the changes in both modules are almost the same.

 If so,I have made a new test file which includes the test of ftu.In my locale,the test file works well,but I don't have the master code,so can you help to check the patch??
Flags: needinfo?(ejchen)
(In reply to jingmei.zhang from comment #42)
> Created attachment 8470634 [details] [diff] [review]
> testinFTU-newmaster.patch
> 
> hi ejchen:
> 
> > in this test, you don't have to test the same thing as what you did in apps/ftu/test/unit/wifi_test.js
> 
>  Is that to say one test file is enough for the changes in ftu and settings?
> Because the changes in both modules are almost the same.
> 
>  If so,I have made a new test file which includes the test of ftu.In my
> locale,the test file works well,but I don't have the master code,so can you
> help to check the patch??
I think he refers to that FTU and Setting doesn't share the same DOM, so the tests must check for different things in each app, but both must have their own specific tests (sometimes checking for the same behaviour, but with different outcomes).

I'm also a little worried that we have many patches in here, and I'm not sure which one is functional, or still needs to be reviewed. If all of them are valid, could you please rename them per function? e.g.
> patch1 - ftu
> patch2 - settings
> patch3 - tests, etc
Or in case that we should only take into account the latest one (if includes everything), could you please make the rest of them obsolete.

Also, we should rely on github PR as we have the TBPL there for checking all the tests are working.

Thanks.
Thanks Fernando ! You did help me answer all questions already !
Flags: needinfo?(ejchen)
(Assignee)

Comment 45

4 years ago
(In reply to Fernando Campo (:fcampo) from comment #43)
>::: apps/sharedtest/test/unit/wifi_helper_test.js
>@@ +152,4 @@
>>        triggerCallback('getNetworks', 'onsuccess');
>>        triggerCallback('getKnownNetworks', 'onsuccess');
>>      });
>> +
>
>You can see that this is an unit test, so all you have to do is check whether >`WifiHelper.isValidInput` works like a charm as what you expected. 
>
>So you don't have to manipulate any DOM here, you just have to pass different values like >WifiHelper.isValidInput(xx, xx, xx, xx), WifiHelper.isValidInput(yy, yy, yy) ... etc to check >different situations and make sure you will get the right result as what you expected.

Is that to say I just need to test if function WifiHelper.isValidInput() is worked well ??

Comment 46

6 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.