Prevent loading AddonManager in webbrowser actor when not explicitely needed

RESOLVED FIXED in Firefox 26

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: ochameau, Assigned: ochameau)

Tracking

unspecified
Firefox 28
Dependency tree / graph

Firefox Tracking Flags

(firefox26 fixed, firefox27 fixed, firefox28 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Per bug 899052 comment 32, we can see that the AddonManager is loaded everytime we load the webbrowser actor. That is totally unexpected on b2g as the addon manager isn't supposed to be instaciated on device and it will use a bunch of memory for nothing.
Is this patch ready for review?  Would be good to get this fixed soon.
Flags: needinfo?(poirot.alex)
Attachment #825314 - Flags: review?(nfitzgerald)
Assignee: nobody → poirot.alex
Flags: needinfo?(poirot.alex)
Attachment #825314 - Flags: review?(nfitzgerald) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c800ad2e84d2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 28
Comment on attachment 825314 [details] [diff] [review]
Prevent loading AddonManager in webbrowser actor when not explicitely needed r=nfitzgerald

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 899052
User impact if declined: Can't debug apps with the remote protocol (console, inspector, debugger) because of this unexpected exception being thrown.
Testing completed (on m-c, etc.): locally, confirmed to fix the reported issue on multiple different phones.
Risk to taking this patch (and alternatives if risky): limited due to small/conservative patch.
String or IDL/UUID changes made by this patch: none

This patch actually needs to be uplifted to b2g 26/1.2 but I haven't seen any approval flag for this branch?
Attachment #825314 - Flags: approval-mozilla-beta?
Comment on attachment 825314 [details] [diff] [review]
Prevent loading AddonManager in webbrowser actor when not explicitely needed r=nfitzgerald

[Triage Comment]
also approving for aurora (27) uplift since we'll want to cover the bases there, assuming you can land this there as-is.
Attachment #825314 - Flags: approval-mozilla-beta?
Attachment #825314 - Flags: approval-mozilla-beta+
Attachment #825314 - Flags: approval-mozilla-aurora+
Blocks: 933905
Whiteboard: [qa-]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.