Talos SVG-ASAP (tsvg) regression from bug 923193 (transform-origin in SVG)

RESOLVED FIXED in Firefox 27

Status

()

Core
SVG
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mbrubeck, Assigned: roc)

Tracking

({perf, regression})

27 Branch
mozilla28
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27+ fixed, firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Bug 923193 caused a regression in the Talos tsvg benchmark on all platforms:
https://groups.google.com/d/topic/mozilla.dev.tree-management/9KnYIRIZEnQ/discussion

Regression: Mozilla-Inbound-Non-PGO - SVG-ASAP - WINNT 6.1 (ix) - 25% increase
------------------------------------------------------------------------------
    Previous: avg 312.057 stddev 7.814 of 12 runs up to revision 9c8ab7e9ae41
    New     : avg 389.992 stddev 3.334 of 12 runs since revision 45d9e6cd3473
    Change  : +77.936 (25% / z=9.974)
    Graph   : http://mzl.la/1bCTFyV 

This was partially fixed by bug 929021:
https://groups.google.com/d/topic/mozilla.dev.tree-management/1t2NtGGMNqQ/discussion

Improvement: Mozilla-Inbound-Non-PGO - SVG-ASAP - WINNT 6.1 (ix) - 7.7% decrease
--------------------------------------------------------------------------------
    Previous: avg 393.485 stddev 2.711 of 12 runs up to revision c79088ab4e0c
    New     : avg 363.197 stddev 3.229 of 12 runs since revision c1578a4fc86d
    Change  : -30.288 (7.7% / z=11.171)
    Graph   : http://mzl.la/1acLZGt 

Filing this bug to track the remaining regression.  See bug 929021 comment 11 and 12 for some relevant discussion.

Comment 1

4 years ago
Roc, should we backout bug 923193 or track and try to fix in FF27? Any reason to believe this isn't an important perf regression?
Flags: needinfo?(roc)
Created attachment 827130 [details] [diff] [review]
fix

This should fix the rest of the regression.
Assignee: nobody → roc
Attachment #827130 - Flags: review?(cam)
Flags: needinfo?(roc)
Attachment #827130 - Flags: review?(cam) → review+

Updated

4 years ago
tracking-firefox27: ? → +
https://hg.mozilla.org/integration/mozilla-inbound/rev/37f9a5424227
https://hg.mozilla.org/mozilla-central/rev/37f9a5424227
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Comment on attachment 827130 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 923193
User impact if declined: slight performance regression for SVG elements with transforms
Testing completed (on m-c, etc.): just landed
Risk to taking this patch (and alternatives if risky): seems low risk
String or IDL/UUID changes made by this patch: none
Attachment #827130 - Flags: approval-mozilla-aurora?

Updated

4 years ago
Attachment #827130 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/eef59d3645d3
status-firefox27: affected → fixed
status-firefox28: affected → fixed
It's hard to tell whether this regression is fixed or not since bug 922942 regressed Tsvg more in the meantime.

I think I will back out bug 923193, this fix, and the fix in bug 929021. Then I will fold those patches together and reland them to see if there is still a regression.
Fixed via backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3fb151446ec5
https://hg.mozilla.org/mozilla-central/rev/3fb151446ec5

Updated

4 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.