Must scroll to see entire list of new messages

RESOLVED DUPLICATE of bug 93856

Status

SeaMonkey
MailNews: Message Display
P1
normal
RESOLVED DUPLICATE of bug 93856
17 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.2alpha
x86
Other
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Trunk build 2001-08-02-03: WinMe
Haven't tried mac or linux but suspect that the same behavior occurs.

Overview: After getting messages I often have to scroll to see the entire list
of new messages in the thread pane.

Steps to reproduce:
1. Login to Mail
2. Sort messages in Ascending order (I just happend to be sorted in Ascending
order).
3. Get Messages
4. Scroll down to the bottom of the list so the newest message appears in the
thread pane.
5. Create/Send 3 messages and send them back to the same account
6. Receive the messages

Actual Results: The message that was originally highighted remains highlighted,
as expected. The thread pane appears to scroll a little to show the next newest
message. I have to use the scroll bar to see all of the newest messages.

Expected Results: I'm not sure how this should work but most of the time I find
myself using the scrollbar to view all of the newest messages.
(Reporter)

Comment 1

17 years ago
Created attachment 44485 [details]
Initial thread pane
(Reporter)

Comment 2

17 years ago
Created attachment 44486 [details]
After Get Msg
(Reporter)

Comment 3

17 years ago
Created attachment 44487 [details]
3pane Afterwards
(Reporter)

Comment 4

17 years ago
The above screen shots try to demonstrate the problem. 

Expected Results, another idea: 
- If there is room to display all the newest messages then it should scroll to
the end of the list. 
- If there are too many new messages then it should just keep the current
message highlighted and display as many new messages as possible.
QA Contact: esther → nbaca

Comment 5

17 years ago
I think we do the right thing if you're in threaded mode - it's when you're not
in threaded, it seems that you have to take action (scroll) to see all your new
messages, even when there is enough room in the thread pane to display them.
(Reporter)

Updated

17 years ago
Keywords: nsBranch

Updated

17 years ago
Blocks: 99230

Comment 6

17 years ago
I don't believe we'd hold eMojo for this and we haven't started work on a fix
yet so this is going to have to wait for the next release.
Target Milestone: --- → mozilla0.9.6

Comment 7

17 years ago
Moving to nsbranch- based on mscott's comment.
Keywords: nsbranch → nsbranch-

Comment 8

17 years ago
moving to 1.0
Target Milestone: mozilla0.9.6 → mozilla1.0

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Comment 9

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

17 years ago
Keywords: nsbeta1

Comment 10

17 years ago
It looks like I can reproduce this when I restart the mail app, but this doesn't
seem to happen after a "Get Msgs" operation. Is that consistent with everyone else?

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P1

Updated

17 years ago
Target Milestone: mozilla1.0.1 → mozilla0.9.9

Updated

17 years ago
No longer blocks: 107067

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 11

17 years ago
nsbeta1- per ADT triage team
Keywords: nsbeta1+ → nsbeta1-

Comment 12

17 years ago
moving out since the ADT nsbeta1-'d it yesterday.
Blocks: 122274
Target Milestone: mozilla1.0 → mozilla1.2

Comment 13

16 years ago
Verified on Linux and WindowsXP (1.1b on XP, 2002091704 on Linux).
Never see new mails at the bottom (or top) of my threads pane when new mails
arrive, using 'auto-check', not 'get all messages'.

IMO expected behaviour is that Mozilla scrolls up/down when mail arrives and the
mail window doesn't have focus.

Comment 14

15 years ago
*** Bug 173198 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
Hi.. this was P1 targeted for 1.2, but obviously that never happened.  I 
haven't done any Mozilla coding yet, but I'd be happy to try my hand at fixing 
it if it's likely to be an isolated patch; anyone have any pointers on where 
to start looking?  This is the one bug keeping me from replacing OE with 
Tbird, as OE does automatically scroll to show new messages.

Comment 16

14 years ago

*** This bug has been marked as a duplicate of 93856 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.