Connection to server time-out in sending reply msg

VERIFIED WORKSFORME

Status

MailNews Core
Composition
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: tao, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
2001-07-26-0.9.2 build.

I constantly run into this problem in replying message. This problem tends
to happen when 

  1. the reply message contains 20+ lines of quoted message. 
  2. the original message has attachments. In quoted message, the
     attachment appears as tables containing filename, e.g., "foo.zip"

When this happens, the progress window stays open and running forever
until the connection time-out.

I am on nsmail-1. Server setting is IMAP4 with SSL turned on and ask
me for whcih certificate to use.
(Reporter)

Comment 1

17 years ago
I am seeing this problem every 1 or 2 hours. It is almost consistently
reproducable if there quoted message contains HTML table.

If I kill the progress window via "X" icon on the upper right, and then click
on "OK" to quit the Composition window, Mozilla takes up 99% of the CPU time.

I needed to restart N6.1 to get the CPU usage down to normal.
Summary: Connection to server time-out in sending reply msg → Connection to server time-out in sending reply msg

Comment 2

17 years ago
I don't think this matter for IMAP SSL.
If problem is occurring for sending, then it could be SMTP server problem or 
composition problem.....
(Reporter)

Comment 3

17 years ago
more findings:

1. This might not have to do with ssl connection since I see this problem even
    w/o ssl.
2. Adding text to the bottom of the message seems to work around this problem.
   It appears that if the table is not at the bottom of the reply message, then
   the problem will not surface.

Comment 4

17 years ago
Tao, can you configure your system to do SMTP logging? Then the next time it
happens, send us a log? 

Directions for that are here if you need them:
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 5

17 years ago
The PR log is too big to attach. Here is a page that can be used to reproduce the
problem: http://news.cnet.com/news/0-1003-200-6996393.html?tag=dd.ne.dht.nl-sty.0.

Steps:
1. load the page in the browser.
2. Send "Page" to yourself.

You should see n6 takes up all the CPU cycle and the progress bar keeps running
forever.

Comment 6

16 years ago
Commercial build: 2001-12-14-06 on win98 not seeing this problem anymore.
I was able to send page with the above link and also used that message to reply. 
Sending and reply did go through and complete.  I used SSL with my imap account.
Worksforme.  
Tao, 
Is this still a problem for you? If not please comment so this can be resolved. 
 

Comment 7

16 years ago
Marking this as worksforme. Reopen if this is problem still exists. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
verified as w4me. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.