Keyboard appears when trying to select from a selection list after flashing gaia v1.2 from git repo

RESOLVED DUPLICATE of bug 912033

Status

RESOLVED DUPLICATE of bug 912033
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: GaryChen)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

Attachments

(1 attachment)

Gaia   cce2ba1312b9a1fa534f446a46981d7ce6ee38fe
SourceStamp 93eafd042c1c
BuildID 20131031004003
Version 26.0
Buri (custom build)

1. flash device with this gaia version
2. go through FTU until country selection
3. try to select a city

Expected: the city is selected
Actual: the keyboard pops up; since you can't dismiss the keyboard by hitting the home key, you can't exit out of it, you have to reboot the phone.

Note:
Does not occur on gaia : df049e3177ced0ca493ff0d192c65f18392bb462
build id : 20131031004003

Noming for koi as it's a FTE bug.

Updated

5 years ago
Keywords: regression
Interesting: it only seems to happen when flashing from making a build; doesn't occur after reseting the phone nor rerunning FTU.  It might be a glitch in the Makefile...

We'll want to verify that this bug doesn't occur tomorrow after flashing the device.
Can someone find out if this reproduces today with a pvtbuild for 1.2?
Keywords: qawanted

Updated

5 years ago
QA Contact: mvaughan

Comment 3

5 years ago
This bug did not reproduce for me on the 11/01/13 1.2 build.

Environmental Variables:
Device: Buri v1.2 comRIL
BuildID: 20131101004000
Gaia: e717aec947571f5daf923c040a82f9f0719bb526
Gecko: 54de309e18a9
Version: 26.0
RIL Version: 01.01.00.019.276
Keywords: qawanted
Created attachment 826024 [details]
2013-11-01-14-18-00.png

still occurs after making gaia v1.2:

make reset-gaia

Might not happen after Bug 915570 lands on v1.2...
regardless it's not a keyboard issue but something with the build config?
Just double checking, I recreated my v1.2 gaia repo and it still occurs.
Summary: Keyboard appears when trying to select from a selection list → Keyboard appears when trying to select from a selection list after flashing gaia v1.2 from git repo
happening on customizable builds. Why is this happening on customizable builds only?
Flags: needinfo?(dflanagan)
Preeti: I don't know much about build customization or about the system code that makes the keyboard pop up, so I don't really have much info to provide here.

Jan and Yuan: Are either of you the right person to investigate this? 

Naoki: some questions for you that might help to diagnose this.

0) Have you tried reproducing this on 1.3?

1) does this only happen in the FTU app, or does it also happen after first boot when using other value selectors? (Like if you change the language in the settings app?)

2) Does it happen if you re-run the FTU app (from settings)?

3) What exactly are you doing to put Gaia on your phone?  Is this just a "make install-gaia" from the Gaia repo?  Or "make reset-gaia"?  

4) Do you have the "Gaia test keyboard" app installed on your phone?  (You'd see it listed under Settings->Keyboards->Gear icon)
Flags: needinfo?(xyuan)
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(janjongboom)
Flags: needinfo?(dflanagan)
Definitely a koi+ if this is a valid bug.
blocking-b2g: koi? → koi+
I can not reproduce on v1.3.
Gaia:     85c929f602b6791fcc53c96e30b77145adef3dd9
Gecko:    57c88ce89f84aa2b743536dcfbe43bd0af7e3931
BuildID   20131107061537
Version   28.0a1
(In reply to GaryChen [:GaryChen][:PYChen] from comment #9)
> I can not reproduce on v1.3.
> Gaia:     85c929f602b6791fcc53c96e30b77145adef3dd9
> Gecko:    57c88ce89f84aa2b743536dcfbe43bd0af7e3931
> BuildID   20131107061537
> Version   28.0a1

How did you reproduce this bug? I was able to reproduce this a few days ago when I was testing customizations.
(In reply to Jason Smith [:jsmith] from comment #10)
> (In reply to GaryChen [:GaryChen][:PYChen] from comment #9)
> > I can not reproduce on v1.3.
> > Gaia:     85c929f602b6791fcc53c96e30b77145adef3dd9
> > Gecko:    57c88ce89f84aa2b743536dcfbe43bd0af7e3931
> > BuildID   20131107061537
> > Version   28.0a1
> 
> How did you reproduce this bug? I was able to reproduce this a few days ago
> when I was testing customizations.

1. flash device with PVT build.
2. go through FTU until country selection
3. try to select a city

Here is my video.
https://www.youtube.com/watch?v=jxCd5MdtfCc
I can produce this bug on non-pvt build too. However it only happens to <select> on FTU....
Whiteboard: [3rd-party-keyboard]
It is probable a gaia bug that can be reproduced for gaia 1.2, but not gaia 1.3 with the latest mozilla-central b2g-desktop build.
Flags: needinfo?(xyuan)
|Keyboard_manager.js| received 'mozbrowserresize' event so keyboard was shown up when user click selection list in FTU.

But it is wired if we launch FTU again(from settings or restart device), |Keyboard_manager.js| will not  receive 'mozbrowserresize' event any more.

I'll investigate this issue.
Assignee: nobody → gchen
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(janjongboom)
Whiteboard: [3rd-party-keyboard]
Summary: Keyboard appears when trying to select from a selection list after flashing gaia v1.2 from git repo → [1.2 Gaia only] Keyboard appears when trying to select from a selection list
We fixed the issue that the keyboard would pop up when a mozbrowserresize came in, because we should not rely on that in https://github.com/mozilla-b2g/gaia/commit/f59c4096af81ecad92cff3afcb27bf31596c066c#diff-869edc18f465b7f5cdda81d81cd58a71L388

The thing is that it's not uplifted yet to 1.2 :-)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Summary: [1.2 Gaia only] Keyboard appears when trying to select from a selection list → Keyboard appears when trying to select from a selection list after flashing gaia v1.2 from git repo
Duplicate of bug: 912033
The fact keyboard is being trigger is a underline issue. I will submit a patch on that.
On gecko level it already is OK, we should always rely on the focus/blur events and then only handle the ones that keyboard_manager.js can handle (which is what we already do). So I don't think there is another issue.
You need to log in before you can comment on or make changes to this bug.