Closed Bug 933523 Opened 8 years ago Closed 8 years ago

mapi is broken after installing 2.22

Categories

(SeaMonkey :: MailNews: Composition, defect)

SeaMonkey 2.22 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 913493

People

(Reporter: blehrhof, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 SeaMonkey/2.20 (Beta/Release)
Build ID: 20130803200314

Steps to reproduce:

installed 2.22


Actual results:

send of pdf from pdffactory to mail failed with mapi error message.  duplicated with simple send of file to mail via sendto from desktop.  browser opened instead of mail composition window.


Expected results:

mail composition window should have opened and attached file.

** I reverted by re-installing 2.20 and problem magically went away. **
doesn't anyone test mapi????  it seems like a very common usage.  this was a bug three years ago, it almost looks as if someone forgot to include the fix in this build???
I'll confirm this & let others decide which of the few recent related bugs to go with or to DUP to.

Bug 933254 - Since update to V2.22 no longer default application for send e-mails
Bug 933221 - after SM upgrade the mailto procedure does not work, although the sea monkey is default email client

Perhaps related?
Bug 594239 - All LPTSTR arguments of Simple MAPI functions should be LPSTR
Status: UNCONFIRMED → NEW
Ever confirmed: true
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 SeaMonkey/2.21
Build-Identifikator: 20130916112225

I can confirm this bug for Windows 8.1 64-bit!

Updated to 2.22

"send to" out of windows explorer opens seamonkey browser window without opening mail composition window: no files can be attached

downgrading to 2.21 solves this problem.
"send to" out of windows explorer opens seamonkey browser window and mail composition window: files are attached
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 913493
You need to log in before you can comment on or make changes to this bug.