Closed Bug 933546 Opened 6 years ago Closed 6 years ago

[B2G][Keyboard] Slovak keyboard is missing the special character "í"

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g18 wontfix, b2g-v1.2 wontfix, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

VERIFIED FIXED
1.3 C3/1.4 S3(31jan)
Tracking Status
b2g18 --- wontfix
b2g-v1.2 --- wontfix
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: nkhristoforov, Assigned: luigitedone)

Details

(Whiteboard: LocRun1.2)

Attachments

(3 files)

Attached image Screenshot
Description:
The Slovak keyboard is missing the special character "í" which is part of the Slovak language according to www.branah.com.

Repro Steps:
1) Updated Buri to Build ID: 20131030004003
2) Choose Slovak as the language.
3) Select the Settings app.
4) Select Keyboards.
5) Select Selected Keyboards.
6) Select Add more keyboards and add the Slovak keyboard.
7) Open the Messages app.
8) Compose a new message and select the Message field.
9) Hold the "I" keyboard button to make special characters appear.

Actual:
The "í" character is missing.

Expected:
The characters would be listed.

Environmental Variables
Device: Buri v 1.2 COM RIL
Build ID: 20131030004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/4fbe1b01ed63
Gaia: a788ea1a3e04716938bd41a559c36a831cf1190b
Platform Version: 26.0a2
RIL Version: 01.01.00.019.264 
Firmware Version: 20131015

Repro frequency: 100%
See attached: Screenshot of the only "I" character
This issue does not reproduce on Leo v 1.1 because the Slovak keyboard has the missing "í" as well as other special "I" characters.

Build ID: 20131029041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/41c15ddb7216
Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
Platform Version: 18.1
RIL Version: 01.01.00.019.264
(In reply to Nikolai Khristoforov from comment #1)
> This issue does not reproduce on Leo v 1.1 because the Slovak keyboard has
> the missing "í" as well as other special "I" characters.
> 
> Build ID: 20131029041202
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/41c15ddb7216
> Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
> Platform Version: 18.1
> RIL Version: 01.01.00.019.264

That would imply that was reproducing on 1.1 actually because 1.1 doesn't have the ability to do this.
Slovak localizers: please confirm this is needed. Thanks!
Flags: needinfo?(wladow)
Flags: needinfo?(rozbora)
The "í" is a commonly used character in Slovak and needs to be available in the gaia keyboard layout for us. When testing latest v1.2 build by Geeksphone on Keon device, I can see both uppercase and lowercase versions of "í" character are available, see the attached sshot. It seems like the bug's not repro to me.
Flags: needinfo?(wladow)
Flags: needinfo?(rozbora)
Closing based on Vlado's feedback. Please reopen if needed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
The character "í" is not available on the Slovak keyboard on the current 1.2 version

Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131202004001 (Dev build with keyboards)
Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
Gecko: 14868788d50e
Version: 26.0
Firmware Version: V1.2_20131115
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Assignee: nobody → luigitedone
Hi, I cannot find the letter "í" on my Keon keyboard and in the 1.2 branch. The bug is confirmed.
Attached file Proposed patch v1.2
Attachment #8365564 - Flags: review?(janjongboom)
Attachment #8365564 - Flags: approval-gaia-v1.2?
According to https://github.com/mozilla-b2g/gaia/blob/v1-train/apps/keyboard/js/layout.js#L895 there is no í in Slovakian layout in v1.1 either.

Anyway, I landed the patch in master (https://github.com/mozilla-b2g/gaia/commit/137dfd1a1310ea08da11251d9b25a8ab1a4acabc) until uplift approval is given (I don't think Slovenia is one of the countries that'll get 1.2 so I doubt it will be given).
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 8365564 [details] [review]
Proposed patch v1.2

Oh and thanks Luigi, sorry it took me so long to review.
Attachment #8365564 - Flags: review?(janjongboom) → review+
Thank you all. Can anyone please look at bug 933542 - there are more characters to be added and the list needs some polishing too. Thanks again.
Comment on attachment 8365564 [details] [review]
Proposed patch v1.2



Moving the approval to 1.3 as this was hitting conflicts when landing https://bugzilla.mozilla.org/show_bug.cgi?id=933542 . Spoke offline with janjongboom on risk being low and the patch in this bug applies cleanly on 1.3
Attachment #8365564 - Flags: approval-gaia-v1.2? → approval-gaia-v1.3+
v1.3: a6aec80717fcbf73ee0c8c0519026dbf64eb0e8f
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
verified on latest 1.3 Moz RIL 
thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.