If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

synchronous XHR is breaking setTimeout/setInterval functions when new window is created by tearing a tab off (moving)

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Sergey Rashitov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20131106])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 825731 [details]
test_sync_xhr.xpi

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.172 YaBrowser/1.7.1364.22194 Safari/537.22

Steps to reproduce:

1. Create an extensions wich overlays browser.xul
2. Add script to your overlay.xul:
window.addEventListener('load', function()
{
	var req = new XMLHttpRequest();
	req.open('GET', some_url, false);
	req.send();
}, false);
3. Install extension
4. Open window with two tabs
5. Move one tab away to create a new window
6. Open console in that tab and enter something like:
window.setTimeout(function(){console.log("123")}, 0);


Actual results:

You will see timeout id and nothing more


Expected results:

You should also see "123"

Comment 1

4 years ago
Works for me with
2013-08-04-03-02-07-mozilla-central-firefox-25.0a1.en-US.linux-x86_64
2013-11-06-03-02-00-mozilla-central-firefox-28.0a1.en-US.linux-x86_64
Summary: synchronous XHR is breaking setTimeout/setInterval functions when new window is created by moving a tab → synchronous XHR is breaking setTimeout/setInterval functions when new window is created by tearing a tab off (moving)
Whiteboard: [bugday-20131106]
(Reporter)

Comment 2

3 years ago
Reproduced in 32.0.1 and 32.0.2 but not in 33.0. Weird.

Comment 3

3 years ago
Feel free to reopen if the issue resurfaces, but if you're talking about your own extension, please note that sync XHR is not recommended to use, since it's likely to cause issues like this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.