Downloaded files are not marked as Internet downloads

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
2 months ago

People

(Reporter: davian818+1, Unassigned)

Tracking

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox50-, firefox51- wontfix, firefox52 unaffected, firefox53 unaffected)

Details

(Whiteboard: [bugday-20131106])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Download a file from the Internet.


Actual results:

The file looks clean.


Expected results:

The file should have an Internet zone datastream attached, which marks it as downloaded from the Internet.

Comment 1

5 years ago
Hi, unfortunately this report is not very useful because it does not describe the problem well. If you have time and can still reproduce the problem, please read https://developer.mozilla.org/en/Bug_writing_guidelines and add a more useful description to this report.
Flags: needinfo?(davian818+1)
(Reporter)

Comment 2

5 years ago
Zone.Identifier datastream is not created for downloaded files.
IE and Chrome behave correctly.

Comment 3

5 years ago
How would I myself find out that Zone.Identifier datastream is not created for downloaded files? The steps to reproduce are still completely unclear. Did you read the link that I pasted?
(Reporter)

Comment 4

5 years ago
You must be cyberstalking me.

First, to reproduce it, you need (I quote myself) to download a file from the Internet. I have no idea what can be 'unclear' here.

Second, to check it, you need to open a Properties window in Windows Explorer and you'll see that it doesn't tell you that the file was downloaded from the Internet.
Flags: needinfo?(davian818+1)

Comment 5

5 years ago
Ah, finally good steps to reproduce. You didn't mention Windows Explorer's properties window before, and you didn't mention that this is MS Windows-specific either. Not everybody runs or knows MS Windows like you do.

Comment 6

5 years ago
I tried with IE9 on Win 7, it's not different from FF25, in both cases I read *.exe:Zone.Identifier

I used this freeware to read the Alternate Data Stream (Zone.Identifier):
http://www.nirsoft.net/utils/alternate_data_streams.html

Did you set some policy rules on Windows to define the ADS?
Flags: needinfo?(davian818+1)
(Reporter)

Comment 7

5 years ago
I don't think so. What exact policy setting should I check?
Flags: needinfo?(davian818+1)

Comment 8

5 years ago
bug 665531 says Firefox did let Windows know the file is a download.
Component: Untriaged → Download Manager
Product: Firefox → Toolkit
Whiteboard: [bugday-20131106]

Comment 9

5 years ago
Are you still seeing this in the latest version of Firefox? It should no longer be an issue since bug 952961.

(In reply to Urmas from comment #7)
> What exact policy setting should I check?

1. Press the Windows logo orb on the taskbar to bring up the Start Menu.
2. In the search box, type gpedit.msc
3. In the search results, right-click gpedit.msc and choose Run As Administrator.
4. On the left, expand the User Configuration section, then Administrative Templates, then Windows Components, and lastly Attachment Manager.
5. On the right, double-click "Do not preserve zone information in file attachments"
6. In the window that opens, click Not Configured, then OK. Firefox must be restarted for the change to take effect.
Flags: needinfo?(davian818+1)
(Reporter)

Comment 10

4 years ago
Cannot reproduce with FF30 so far.
Flags: needinfo?(davian818+1)

Comment 11

4 years ago
I think it has been fixed by bug 916126 in FF26.
Closed as worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 12

2 years ago
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

I Tried in win 8.1 using Firebox and chrome.

In the Chrome the File Download are mark as Internet Download.

Suggested refer Blog post
tracking-firefox50: --- → ?
tracking-firefox51: --- → ?
tracking-firefox52: --- → ?
Andrei, can you ask someone to check this out? It should probably be filed as a new bug if it's a problem again. I don't have a Windows machine around or I would test.... :)   Maybe a good one for the next bug day?
status-firefox51: --- → wontfix
status-firefox52: --- → ?
status-firefox53: --- → ?
tracking-firefox50: ? → -
tracking-firefox51: ? → -
tracking-firefox52: ? → ---
Flags: needinfo?(andrei.vaida)
Kavipriya, I'm not sure what you mean.  
Is this still a problem? Or are you trying to say that it is fixed?  
Where are you finding bugs to work on?
Flags: needinfo?(kavianandhakrishnan)
I verified the STR form comment 9, now at step 6 it is on "Not Configured" by default. I used Windows 10 x64 and Windows 7 x64. I think this is why it is no longer reproducible.
Flags: needinfo?(andrei.vaida)
status-firefox52: ? → unaffected
status-firefox53: ? → unaffected
Flags: needinfo?(kavianandhakrishnan)
You need to log in before you can comment on or make changes to this bug.