Incorrect font in the left frame. Probably problem with style sheets.

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: petr.synek, Assigned: shanjian)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Correct font is Serif but displayed is Sans-serif. This occured first time in
Mozilla 0.9.2.
1)  Font is serif in NS 4.x

2)  Nothing in the stylesheet specifies a sans-serif font for that content... in
fact, the only applicable style rules look like:

.FrameTitleFont   { font-size: normal; font-family: normal }

"normal" is not a valid value for font-family per css2.  I see no reason for
that content to be sans-serif based on the HTML and css present....

What makes you think the font should be sans-serif?
Summary: Incorrect font in the left frame. Probably problem with style sheets. → Incorrect font in the left frame. Probably problem with style sheets.

Comment 2

18 years ago
Just in case, please check in the preferences whether the Proportional font is 
set to Serif or Sans Serif.
(Reporter)

Comment 3

18 years ago
I have checked that I have Proportional font set to Serif in my preferences. 

This problem only occures in the left frame however. The right frame is OK,
there is correctly displayed Serif... 
Petr, do you have any font called "normal" installed on your system?

I'm seeing mozilla display all the frames as serif with a solaris build from
2001-08-02
Petr, what do you see as far as serif and sans-serif go in the testcase I just
attached?
(Reporter)

Comment 7

18 years ago
Hi Boris,

I see 
"serif" as serif,
"sans-serif" as sans-serif
"normal" as sans-serif bold
"qwertyuiop" as sans-serif bold

In sans-serif bold I also see the Sun's page... 

I have just asked my colegue to verify this and he has the same experience (on
0.9.3). Strange is that in Mozilla 0.9.1 (I installed as my first mozilla
browser) all was OK. 
(Reporter)

Comment 8

18 years ago
I have just found that this bug appears if Proportional font (is "Serif" and)
sizes are 16 or 18. If other sizes are set, the testcase works
correctly. 

I have verified this for both, Western & Central European encoding. 
(Reporter)

Comment 9

18 years ago
P.S. I'm using WinNT & I don't have font called "normal" on my system. 
Okay.... I bet the problem is that we see "font-family: normal" with no
fallback, try to get a font in that font-family, fail, and fall back to
something random.... 

This is technically something that should be evangelized to the page author, but
this still seems like a problem with the font-fetching code.

Setting status to NEW and ccing hyatt based on the fact that this behavior
appeared after 0.9.1.  Petr, thanks for your patience.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

18 years ago
Reassigned to rbs.  It may be fixed already by his work on bug 74186.
Assignee: pierre → rbs
(Reporter)

Comment 12

17 years ago
This bug can be experienced also in ALL articles on http://www.theregister.co.uk/
For example in article http://www.theregister.co.uk/content/53/23866.html 
all letters in article's text are displayed in BOLD font. 

I'm using currently build 2002012406, 
Mozilla 0.9.7+ (WinNT4.0; en-US) Gecko/20020124

Comment 13

17 years ago
> "normal" as sans-serif bold
> "qwertyuiop" as sans-serif bold

Maybe the font that happens to be picked in the global list is bold in itself. 
Since I cannot reproduce, I am of little help here.
->Passing the bug on to shanjian.
Assignee: rbs → shanjian
Component: Style System → Internationalization
QA Contact: ian

Updated

17 years ago
QA Contact: teruko
(Reporter)

Comment 14

17 years ago
I tried mozilla (2002012406) on fresh installation of W2K and the font on 
TheRegister was OK now. Also the 
http://java.sun.com/j2se/1.3/docs/api/index.html page was OK. 

I will look closely at font settings on the NT system. 
(Reporter)

Comment 15

17 years ago
I have still the same problem with incorrect font on NT. The font settings are
exactly the same as on W2K. Do you anybody have also NT so that it can be tested
on another NT machine? 
(Assignee)

Comment 16

17 years ago
I tried this on my NT4.0J and NT4.0En, I do not see any problem in either case. 
Reporter, please post a screen shot of the testcase. Please also make sure that
"preference->appearance->fonts, fonts for "western", proportional is set to "serif".

(Reporter)

Comment 17

17 years ago
Created attachment 67296 [details]
The screenshot of preferences
(Reporter)

Comment 18

17 years ago
Created attachment 67297 [details]
TheRegister screenshot.
(Reporter)

Comment 19

17 years ago
As you see the TheRegister page still does not work. 

But I tried also the testcase (http://java.sun.com/j2se/1.3/docs/api/index.html)
and it works now on my NT machine correctly. 

I also tried to rename whole "C:\WINNT\Profiles\petrsy\Application Data\Mozilla"
folder so that mozilla initialized from its defaults and it again did not work :-(
(Reporter)

Comment 20

17 years ago
May be it's only something wrong with my machine (NT - US version, SP5). 

It's good at least the Sun's page works now. Previously I had to set the
"Proportional" font to 15 points to make it work. With 16 points it was bold and
with 15 it was correct. Now it works also with 16 points. 

The TheRegister page did not work with any font-size settings and still does not
work. But if it is really only on my machine, I suggest to let it be... 
(Assignee)

Comment 21

17 years ago
In regiester page, the font specified for story body is " font-family: Geneva, 
Arial, Helvetica, sans-serif".  The font you saw looks like "ms sans serif", 
which is bitmap font. That explained what it is only visible in certain font 
size. "ms sans serif" does look like a little bold, but they are not.

resolve this bug as WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 22

17 years ago
Why is that neither of the fonts listed is picked? Don't the reporter have
Geneva, or Arial, or Helvetica?
(Reporter)

Comment 23

17 years ago
I have only Arial from the 3 above fonts. 

Comment 24

17 years ago
There are (hidden) prefs that could allow you to tune the default fonts to
be used when you don't have the fonts listed by an author. You might find 
bug 120494 relevant.

Comment 25

17 years ago
Verified as workforme in 2002-02-26-03 trunk build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.