bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Keep a marketplace load smoke test in the main repo

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: zac, Assigned: Karan Singh)

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.2 affected)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
There was a regression last week in loading the Marketplace app. It crashed as soon as it was loaded.

We want to remove the marketplace tests into their own repo but we should retain a basic Marketplace smoketest so that the app loading does not regress again.

Test case:
1. Load firefox os
2. Switch into Homescreen
3. Navigate to homescreen panel that contains the Marketplace icon
4. tap the icon
5. Wait for self.apps.displayed_app.name == 'Marketplace'
6. Assert that the marketplace splash screen/loading screen clears and that Marketplace is loaded.

Add the test into the manifest.ini file and enable it for desktopb2g and device.
(Reporter)

Updated

5 years ago
Blocks: 933817
(Assignee)

Comment 1

5 years ago
Created attachment 826527 [details] [diff] [review]
0001-Bug-933815-933817-removed-marketplace-tests-added-ma.patch

Hey,

I've removed the existing marketplace tests, added a smoke test, and updated the manifest file. Check it out and let me know if you need anything changed.

Cheers,
Attachment #826527 - Flags: review?(zcampbell)
(Reporter)

Comment 2

5 years ago
Can you do this in two separate patches (pull requests?)

First do marketplace_launch, then removal of everything else.

When we do it as a Git pull we run it through Travis on the CI, too which is important for it being approved.
(Assignee)

Comment 3

5 years ago
Created attachment 826906 [details]
Pull Request

Added the smoke test and updated the manifest file.
Attachment #826527 - Attachment is obsolete: true
Attachment #826527 - Flags: review?(zcampbell)
Attachment #826906 - Flags: review?(zcampbell)
Duplicate of this bug: 933817
(Reporter)

Comment 5

5 years ago
Comment on attachment 826906 [details]
Pull Request

Comments are in the pull request!
Attachment #826906 - Flags: review?(zcampbell) → review-
(Reporter)

Comment 6

5 years ago
Karan, are you still able to work on this?

Otherwise I'll re-assign it.
(Assignee)

Updated

5 years ago
Attachment #826906 - Flags: review- → review?(zcampbell)
(Reporter)

Comment 7

5 years ago
Comment on attachment 826906 [details]
Pull Request

I know this works OK because I ran it yesterday :P 
One tiny little nit-pick on the order of the include. In addition to that, all of the commits need to be squashed into 1 so that we can move it across branches.

After that we are ready to go! r? me again when it's done :)
Attachment #826906 - Flags: review?(zcampbell) → review-
(Reporter)

Comment 8

5 years ago
PS for anyone else reviewing this: we thought it would be easier to leave the few locators inline so as to not need a Marketplace app object at all, considering that the scope of this test is so small and it will be the only Marketplace test in the main repo.
(Assignee)

Comment 9

5 years ago
Comment on attachment 826906 [details]
Pull Request

Hey,

I squashed all my commits and ordered the manifest correctly.
The second last commit was the squash, I'm not sure whats up with the last merge, let me know if it looks alright. 

https://github.com/mozilla-b2g/gaia/pull/13357/commits

Thanks!
Attachment #826906 - Flags: review- → review?(zcampbell)
(Reporter)

Comment 10

5 years ago
That doesn't look right - they should all be squashed into just one commit. Not sure what you've done there!
(Assignee)

Comment 11

5 years ago
Created attachment 8334098 [details] [review]
Pull Request

I closed my previous Pull Request and made a new one since it seemed simpler. Sorry I'm still getting used to the the git workflow.

Thanks for your time,
Attachment #826906 - Attachment is obsolete: true
Attachment #826906 - Flags: review?(zcampbell)
Attachment #8334098 - Flags: review?(zcampbell)
(Reporter)

Comment 12

5 years ago
Comment on attachment 8334098 [details] [review]
Pull Request

r+ thanks Karan!
Attachment #8334098 - Flags: review?(zcampbell) → review+
(Reporter)

Comment 14

5 years ago
This would fit in on v1.2, but with a little bit of duplication between marketplace-tests-gaia.
status-b2g-v1.2: --- → affected

Comment 15

5 years ago
Created attachment 8335996 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13901

Pointer to Github pull-request

Comment 16

5 years ago
Comment on attachment 8335996 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13901

Uplifted to v1.2
Attachment #8335996 - Flags: review?(trifandreialin)
Attachment #8335996 - Flags: review?(moz.teodosia)
Attachment #8335996 - Flags: review?(florin.strugariu)
Attachment #8335996 - Flags: review?(bob.silverberg)
Attachment #8335996 - Flags: review?(florin.strugariu) → review+

Updated

5 years ago
Attachment #8335996 - Flags: review?(moz.teodosia) → review+
Attachment #8335996 - Flags: review?(trifandreialin) → review+
Merged in v1.2:
https://github.com/mozilla-b2g/gaia/commit/34022d1bab6984ec258de7cfed6b8fe716570d78
marking this as resolved fixed
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment #8335996 - Flags: review?(bob.silverberg)
You need to log in before you can comment on or make changes to this bug.