Closed Bug 933843 Opened 8 years ago Closed 8 years ago

Google Analytics doesn't track FxOS devices correctly

Categories

(Web Compatibility :: Mobile, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: Harald, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [mobile-compat-form])

Attachments

(1 file)

Site: https://www.google.com/analytics/web/
Google Analytics doesn't track FxOS devices correctly

:: Steps To Reproduce

1. Go to an Devices report for any site that has FxOS visitors (like Marketplace)
2. Check the devices list

:: Expected Result

See Firefox OS, split into the various available devices and versions

:: Actual Result

"(not set)" has thelarge percentage, then FxOS, then LG D300. All those entries probably represent FxOS devices.

:: Additional Information

Software Version: 1.1+
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:28.0) Gecko/20100101 Firefox/28.0
Harald,

* Is there a section of Google Analytics which reports the OSes? 
  - If yes, does it see Firefox OS?
* In terms of the device section, where would you like FxOS to be reported? As it's not a device, it is indeed many type of devices. So it sounds logical you find it a bit everywhere.

You put in "Expected Result", 

"See Firefox OS, split into the various available devices and versions"

Not possible and by choice, because we recommend to not have device identification in the User Agent string. Only device makers which are forcing the inclusion of the Device ID could be possibly identified. :)


Or did I misunderstand what you were asking? :)
Top 3:
(not set)
Mozilla Firefox OS
LG D300
All the latest 1.1 devices add their identifier to the UA, so Google should have no problem showing more details if available.

1.0.1 and 1.1 can also be differed from the UA.

Adding Browser Version this list makes even less sense https://cloudup.com/cER8CA293Jo . Keep in mind that this already excludes internal traffic from our offices.
(In reply to Harald Kirschner :digitarald from comment #3)
> All the latest 1.1 devices add their identifier to the UA, so Google should
> have no problem showing more details if available.

That's true but fixing device specific identification is out of the scope of Web compatibility. We can share the generic device UA string and advice on how to read it but don't want to be in the business of tracking third party site updates for every Firefox OS device.

> 1.0.1 and 1.1 can also be differed from the UA.
> 
> Adding Browser Version this list makes even less sense
> https://cloudup.com/cER8CA293Jo . Keep in mind that this already excludes
> internal traffic from our offices.

I think this makes sense as long as we're not excluding the traffic from our dev's home connections.
Harald,

I understand that. But you are asking what we don't want people to do. :) Why do you need that?

"All the latest 1.1 devices". Mine doesn't: ZTE Open. Did we completely give up on pushing for not having the deviceID?
The main issue here is that FxOS devices are showing up as "(not set)". I didn't want to focus on the device details.

If Lawrence confirms that all those are developers working from home and that those make up a higher percentage than actual FxOS users; please close this bug. Otherwise we might want to check with Google on what they are looking for to determine "Mozilla Firefox OS".
I'm not sure how to confirm that "not set" is devs but the version 24 is telling as that is not a release version of Gecko. See https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference#Firefox_OS_version_number
(In reply to Harald Kirschner :digitarald from comment #6)
> The main issue here is that FxOS devices are showing up as "(not set)". I
> didn't want to focus on the device details.

Bear with me, because I'm not a specialist of Google Analytics. I have been told that Firefox OS was seen in the browser section. Here we are talking of devices. So for devices, it sounds logical that there's an important number of (not set).


Then your stats are about the Marketplace if I understood. 
If you restrict your data set to the countries where Firefox OS has been launched and you use that and only that. What is now the device list? Still not set? Something else different depending on the countries?
More data: https://cloudup.com/cgFjPMPMHFH

It turns out that (not set) might be Android Nightlies. So we just have a lot of Marketplace users from Android. But also good news that we can actually differentiate see 1.0.1 vs 1.1 trends.

Did we expect that Firefox Nightly or Beta on Android is unknown to GA?
(In reply to Harald Kirschner :digitarald from comment #9)
> Did we expect that Firefox Nightly or Beta on Android is unknown to GA?

I did not expect this but that doesn't mean that it's incorrect.
What are the User Agent strings for Firefox Nightly/Beta Android?

These are the patterns I see 

Mozilla/ (Android; Mobile;) Gecko/* Firefox/*
Mozilla/5.0 (Android 2.3.6; WOW64; rv:*) Gecko/* Firefox/*
Mozilla/5.0 (Android; Linux armv7l; rv:*) Gecko/* Firefox/*
Mozilla/5.0 (Android; Mobile: LG-P769; rv:*) Gecko/* Firefox/*
Mozilla/5.0 (Android; Mobile: XT907; rv:*) Gecko/* Firefox/*
Mozilla/5.0 (Android; Mobile; rv:*) Gecko/* Firefox/*
Mozilla/5.0 (Android; Tablet; rv:*) Gecko/* Firefox/*
Mozilla/5.0 (Linux; U; Android 2.3.3) Gecko/* Firefox/*

and some with
Mozilla/5.0 (Android; Linux armv7l; rv:*) Gecko/* Firefox/* Fennec/*
I'm closing it. Feel free to reopen if there's something that should be done about it.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.