Closed Bug 933847 Opened 9 years ago Closed 9 years ago

create two pairs of funnelcake builds (total 4)

Categories

(Release Engineering :: Release Requests, defect)

x86
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aphadke, Assigned: nthomas)

References

Details

Attachments

(8 files, 2 obsolete files)

1. Funnelcake build n and n+1
Firefox version: 25
Bitstuffing: NO
Platform: Windows
config changes: Firstrun page and channel name should be unique
Build n - offered for download on download.mozilla.org via www.mozilla.org
Build (n+1) - offered for download on the fallback page of www.mozilla.org


2. Funnelcake build n+2 and n+3
Firefox version: 25
Bitstuffing: Yes (3mb)
Platform: Windows
config changes: Firstrun page and channel name should be unique
Build (n+2) - offered for download on download.mozilla.org via www.mozilla.org
Build (n+3) - offered for download on the fallback page of www.mozilla.org

When user presses "cancel" (or download is interrupted) via the stub installer, the stub installer should add a parameter to the fall back page that corresponds to the build for eg: (http://www.mozilla.org/en-US/firefox/installer-help/?funnelcake=n)
Also,
build (n) and build (n+2) - should be offered by stub installer.
build (n+1) and build (n+3) - will be offered as full download from the installer-help page.
Blocks: 933852
Component: Release Automation → Releases
QA Contact: bhearsum → rail
Do you have a timeline/deadline in mind?
Flags: needinfo?(aphadke)
:bhearsum - we plan to launch this sometime on 11/14 (if possible) or 12/1, preferably before the holidays to get a decent sample.
Flags: needinfo?(aphadke)
I will again recommend: if we want a richer understanding of the marginal cost of growing the installer, a single bit-stuffing size (3MB) will be good, but if we perform the experiment at a few sizes we should be able to build a much richer understanding of what is going on. A two-level experiment will let us measure the "elasticity of installation success with respect to installer size" at a *single point* (the size of the current installer), but we won't be able to measure the shape of the elasticity curve.

(For those who have forgotten Econ 101, "elasticity" refers to the effect of a % change in one variable (installer size) on the % change in another (installation success). Typically the effect size is different depending on the starting value of the causative variable (installer size))

The curve may be important if in a few months we have another couple MB to add to the installer--if we have moved to a different part of the elasticity curve where the effect is bigger (or smaller) we'll have no way of knowing. Of course, we may be in a relatively inelastic part of the curve, so it may not matter, but it's hard to say without running the experiment.

Also: I have been busy with a work week and other projects, so I may have missed this part of the conversation, but: how was 3MB chosen?
brendan - your points are perfectly valid. christina, cmore and aphadke met @ 11:30 to discuss the same. 
Main Highlight:
We are testing the waters with bit-stuffing + funnelcake builds. All learnings will be applied back to future funnelcake studies. The 3MB size was chosen as it has immediate impact wrt ICU being launched in next version of Firefox and how it affects ADIs.

Once the study is complete and we are confident that other pieces of infrastructure are automated, we will be embarking on path to do regular testing with requirements coming from the analysts team (brendan, christina, joy, dzeber)
Anurag, what set of locales would we like to use ?
Flags: needinfo?(aphadke)
christina - in addition to en-US, what other locale do we need?
Flags: needinfo?(christina)
:aphadke I thought we decided to go for countries with slow internet connection but has a large % of en-US downloads... If I recall correctly from our discussion on Friday, India and Indonesia? But please verify with cmore.
Flags: needinfo?(christina)
Thx for the confirmation Christina. 
Nick - we are only going with en-US locale.
Flags: needinfo?(aphadke)
anurag, cmore - please cross-check this translation to implementation, specifically the mozilla.org touchpoints:

* the next funnelcake # is 26, so we'll use 26-29 here
* we're doing win32 en-US only, for all four cases
* (bug 933853, WebOps) download.m.o is going to redirect some requests for
          /?product=firefox-stub&os=win&lang=en-US
  to 
     15%  /?product=firefox-stub-f26&os=win&lang=en-US   (ie append -f26 to product)
     15%  /?product=firefox-stub-f28&os=win&lang=en-US   (ie append -f28 to product)
     70%  <unchanged>
  ie no change to d/l boxes on mozilla.org
* we don't need to serve mac/linux requests, or non en-US request for windows, because the redirection is happening within in bouncer

* funnelcake 26
 * full installer
   * 'tagged' as funnelcake26 (channel=release-cck-mozilla26); no increase in installer size
   * first run request: http://www.mozilla.com/en-US/firefox/25.0/firstrun/?f=26  
     (ends up on s/.com/.org/. Locale and version get evaluated at run time!)
   * available at download.m.o/?product=firefox-25.0-f26&os=win&lang=en-US
 * stub 
   * available at download.m.o/?product=firefox-stub-f26&os=win&lang=en-US
   * full installer request: download.m.o/?product=firefox-25.0-f26&os=win&lang=en-US
     (I've dropped firefox-latest-f26 usage here)
   * stub fallback page   !!! NB I've already incremented the f value !!!
      https://www.mozilla.org/en-US/firefox/installer-help/?channel=release&installer_lang=en-US&f=27
   * the fallback page uses download.m.o/?product=firefox-stub-f27&os=win&lang=en-US  (already in place)

* funnelcake 27 
 * full installer - as funnelcake 26 except s/f26/f27/ and s/f=26/f=27/
   * 'tagged' as funnelcake27 (channel=release-cck-mozilla27); no increase in installer size
   * first run request: http://www.mozilla.com/en-US/firefox/25.0/firstrun/?f=27  (ends up on s/.com/.org/)
   * available at download.m.o/?product=firefox-25.0-f27&os=win&lang=en-US
 * stub not required

* funnelcake 28
 * as per 26, except installer has 3MB of junk added to increase size; s/f26/f28/ and s/f=26/f=28/
* funnelcake 29
 * as per 27, except installer has 3MB of junk added to increase size; s/f27/f29/ and s/f=27/f=29/
Flags: needinfo?(chrismore.bugzilla)
Flags: needinfo?(aphadke)
Assignee: nobody → nthomas
Status: NEW → ASSIGNED
OS: Mac OS X → Windows 8.1
Duplicate of this bug: 928017
Depends on: 935808
nick,
my replies inlined, question is marked as "QUESTION" (sorry for the caps):

* the next funnelcake # is 26, so we'll use 26-29 here
->yep.
* we're doing win32 en-US only, for all four cases
->yep.
* (bug 933853, WebOps) download.m.o is going to redirect some requests for
          /?product=firefox-stub&os=win&lang=en-US
  to 
     15%  /?product=firefox-stub-f26&os=win&lang=en-US   (ie append -f26 to product)
     15%  /?product=firefox-stub-f28&os=win&lang=en-US   (ie append -f28 to product)
     70%  <unchanged>
  ie no change to d/l boxes on mozilla.org
->yep.
* we don't need to serve mac/linux requests, or non en-US request for windows, because the redirection is happening within in bouncer
->yep.

* funnelcake 26
 * full installer
   * 'tagged' as funnelcake26 (channel=release-cck-mozilla26); no increase in installer size
   * first run request: http://www.mozilla.com/en-US/firefox/25.0/firstrun/?f=26  
     (ends up on s/.com/.org/. Locale and version get evaluated at run time!)
   * available at download.m.o/?product=firefox-25.0-f26&os=win&lang=en-US
->yep.
 * stub 
   * available at download.m.o/?product=firefox-stub-f26&os=win&lang=en-US
   * full installer request: download.m.o/?product=firefox-25.0-f26&os=win&lang=en-US
     (I've dropped firefox-latest-f26 usage here)
   * stub fallback page   !!! NB I've already incremented the f value !!!
      https://www.mozilla.org/en-US/firefox/installer-help/?channel=release&installer_lang=en-US&f=27
   * the fallback page uses download.m.o/?product=firefox-stub-f27&os=win&lang=en-US  (already in place)
QUESTION: Shouldn't the fallback page link to "full installer for f27" instead of stub?


* funnelcake 27 
 * full installer - as funnelcake 26 except s/f26/f27/ and s/f=26/f=27/
   * 'tagged' as funnelcake27 (channel=release-cck-mozilla27); no increase in installer size
   * first run request: http://www.mozilla.com/en-US/firefox/25.0/firstrun/?f=27  (ends up on s/.com/.org/)
   * available at download.m.o/?product=firefox-25.0-f27&os=win&lang=en-US
 * stub not required
->yep.

* funnelcake 28
 * as per 26, except installer has 3MB of junk added to increase size; s/f26/f28/ and s/f=26/f=28/
->yep.
* funnelcake 29
 * as per 27, except installer has 3MB of junk added to increase size; s/f27/f29/ and s/f=27/f=29/
->yep.

thx a lot nick for helping with this bug!
Flags: needinfo?(nthomas)
Flags: needinfo?(chrismore.bugzilla)
Flags: needinfo?(aphadke)
(In reply to Anurag Phadke[:aphadke@mozilla.com] from comment #12)
>  * stub 
>    * available at download.m.o/?product=firefox-stub-f26&os=win&lang=en-US
>    * full installer request:
> download.m.o/?product=firefox-25.0-f26&os=win&lang=en-US
>      (I've dropped firefox-latest-f26 usage here)
>    * stub fallback page   !!! NB I've already incremented the f value !!!
>      
> https://www.mozilla.org/en-US/firefox/installer-help/
> ?channel=release&installer_lang=en-US&f=27
>    * the fallback page uses
> download.m.o/?product=firefox-stub-f27&os=win&lang=en-US  (already in place)
> QUESTION: Shouldn't the fallback page link to "full installer for f27"
> instead of stub?

Yes, you're absolutely right, I hadn't checked carefully enough. Visiting that fallback page, it has a d/l box with url
  https://download.mozilla.org/?product=firefox-latest-f27&os=win&lang=en-US
a full installer style of link. This means I will use firefox-latest-fNN style for products instead of firefox-25.0-fNN, for all the full installers.

Apparently you have to take care to do that check on Windows, because you get a different result on mac (product=firefox-25.0-f27).
Flags: needinfo?(nthomas)
Looks good to me with adjustments already noted above. Thanks!
Blocks: 936182
Anurag: When is your recommended go-live data for this so that we don't run into Firefox 26?
:cmore - 12/2 - 12/16.
No longer blocks: 933852, 936182
Blocks: 936624
Might as well get the full installers from the release automation. The two stubs will still need to be manual.
Attachment #829951 - Flags: review?(coop)
Attachment #829951 - Flags: review?(coop) → review?(aki)
I forgot to explain why the padding isn't exactly 3MB. The installer grows by ~8600 bytes if you repack with just the funnelcake config. Adding a 3*1024*1024 byte padding file ends up overshooting by about 43000B after 7-zip. There's a bit of variation if you rerun, presumably because of the compressibility of urandom()'s output. If this is a pain then 7-zip supports a Copy mode which doesn't compress at all.
Attachment #829951 - Flags: review?(aki) → review+
Comment on attachment 829951 [details] [diff] [review]
[partner-repacks] Generate 25.0.1 funnelcake26-29 in automation

https://hg.mozilla.org/build/partner-repacks/rev/acef82ee0305

Will back out again after we have builds, no need to generate these long term.
Attachment #829951 - Flags: checked-in+
nick - will we be able to close this bug by 11/15 for 11/18 launch? Do we need to do something specific to push it to CDN mirrors?

-anurag
(In reply to Anurag Phadke[:aphadke@mozilla.com] from comment #22)
> nick - will we be able to close this bug by 11/15 for 11/18 launch? 

I'm aiming for that but we might need to slip to 11/19. The full installers were produced by release automation when it ran for 25.0.1, and I'll create the two stub installers today. Then I'll try to get everything set up in bouncer so that QA can take a look. I imagine they are pretty busy with the releases going on this week (CC ashughes, I'd be looking for a quick check of the builds, and of the process from mozilla.org d/l to make sure we didn't miss anything).

The complication is that I'll be off your Thur/Fri due to a public holiday and timezones, then travel for a work week in Boston over the weekend, so we might slip to Tue/Wed if there are issues.

> Do we need to do something specific to push it to CDN mirrors?

We normally put the files in firefox/releases/ on the ftp server, and they're visible to the CDNs there, so it'll get taken care as part of my work. Please note that the initial bouncer setup for QA will use the firefox/candidates directory on the ftp server, and will get changed once I put the files into firefox/releases/.
(In reply to Nick Thomas [:nthomas] from comment #10)
>    * stub fallback page   !!! NB I've already incremented the f value !!!
> https://www.mozilla.org/en-US/firefox/installer-help/
> ?channel=release&installer_lang=en-US&f=27

The '!!! NB' part got missed in the signoff, and mozilla.org is already incrementing, so we get offered 28 when the 26 fails. This patch sends 26, so we get offered 27 by mozilla.org.
Attachment #829960 - Attachment is obsolete: true
Attachment #829963 - Attachment is obsolete: true
Attached file Testing notes
* f26 stub leads to f26 first run, release-cck-mozilla26 update channel
* cancelled f26 stub leads to f27 full installer, f27 first run, release-cck-mozilla27
* f28 stub leads to f28 first run, release-cck-mozilla28
* cancelled f28 stub leads to f29 full installer, f29 first run, release-cck-mozilla29
* f26/27 are 
* padding files don't end up in install dir for f28/f29, but installers are 3MB larger
Status: RelEng ready for any testing we're going to do (another pair of eyes would be good). Once we're good, and 25.0.1 has shipped, we do ....

### publish files to final locations
# rsync the files into the 25.0.1 release directory 
# I'm using releases/25.0.1/win32-funnelcakeNN instead of releases/25.0.1-funnelcakeNN to
# keep releases/ cleaner.
cd /pub/mozilla.org/firefox/
# remove v2 files, which are just duplicates to defeat CDN caching during testing
rm -v candidates/25.0.1-candidates/build1/partner-repacks/funnelcake{26,28}/win32/en-US/*v2.exe
rsync -av candidates/25.0.1-candidates/build1/partner-repacks/funnelcake26/win32/ \
          releases/25.0.1/win32-funnelcake26/
rsync -av candidates/25.0.1-candidates/build1/partner-repacks/funnelcake27/win32/ \
          releases/25.0.1/win32-funnelcake27/
rsync -av candidates/25.0.1-candidates/build1/partner-repacks/funnelcake28/win32/ \
          releases/25.0.1/win32-funnelcake28/
rsync -av candidates/25.0.1-candidates/build1/partner-repacks/funnelcake29/win32/ \
          releases/25.0.1/win32-funnelcake29/

# update bouncer locations
* https://bounceradmin.mozilla.com/admin/mirror/location/14701/ becomes 
    /firefox/releases/25.0.1/win32-funnelcake26/en-US/Firefox Setup Stub 25.0.1.exe

* https://bounceradmin.mozilla.com/admin/mirror/location/14702/ becomes
    /firefox/releases/25.0.1/win32-funnelcake28/en-US/Firefox Setup Stub 25.0.1.exe

* https://bounceradmin.mozilla.com/admin/mirror/location/14703/ becomes
    /firefox/releases/25.0.1/win32-funnelcake26/en-US/Firefox Setup 25.0.1.exe

* https://bounceradmin.mozilla.com/admin/mirror/location/14704/ becomes
    /firefox/releases/25.0.1/win32-funnelcake27/en-US/Firefox Setup 25.0.1.exe

* https://bounceradmin.mozilla.com/admin/mirror/location/14705/ becomes
    /firefox/releases/25.0.1/win32-funnelcake28/en-US/Firefox Setup 25.0.1.exe

* https://bounceradmin.mozilla.com/admin/mirror/location/14706/ becomes
    /firefox/releases/25.0.1/win32-funnelcake29/en-US/Firefox Setup 25.0.1.exe

Test urls (should not 404, but wait 5 minutes after bouncer changes first):
 curl -IL "https://download.mozilla.org/?product=firefox-stub-f26&os=win&lang=en-US"
 curl -IL "https://download.mozilla.org/?product=firefox-stub-f28&os=win&lang=en-US"
 curl -IL "https://download.mozilla.org/?product=firefox-latest-f26&os=win&lang=en-US"
 curl -IL "https://download.mozilla.org/?product=firefox-latest-f27&os=win&lang=en-US"
 curl -IL "https://download.mozilla.org/?product=firefox-latest-f28&os=win&lang=en-US"
 curl -IL "https://download.mozilla.org/?product=firefox-latest-f29&os=win&lang=en-US"
(In reply to Nick Thomas [:nthomas] from comment #28)
> Status: RelEng ready for any testing we're going to do (another pair of eyes
> would be good). Once we're good, and 25.0.1 has shipped, we do ....

Actually, we just need to have pushed 25.0.1 (vanilla) to the mirrors, rather than have fully shipped.
(In reply to Nick Thomas [:nthomas] from comment #23)
> I'm aiming for that but we might need to slip to 11/19. The full installers
> were produced by release automation when it ran for 25.0.1, and I'll create
> the two stub installers today. Then I'll try to get everything set up in
> bouncer so that QA can take a look. 

I suspect QA will have no time this week to look at this given the release/beta testing load. Be advised that I am on PTO starting tomorrow until December 3rd. I suggest you ask Marc Schifer to find someone to test this once ready.
I've tested this on production with the following tests:

http://www.mozilla.org/en-US/firefox/new/?f=26

I get this dmo product: firefox-stub-f26 (200ok 277k stub)

http://www.mozilla.org/en-US/firefox/new/?f=28

I get this dmo product: firefox-stub-f28 (200k 277k stub)

http://www.mozilla.org/en-US/firefox/installer-help/?f=26

I get this dmo product: firefox-latest-27 (200ok, 22,789kb)

http://www.mozilla.org/en-US/firefox/installer-help/?f=28

I get this dmo product: firefox-latest-29 (200ok, 25,869kb)

It looks like all of the products are 25.0.1. -f26 and -f27 builds are the smaller ones and -f28 and -f29 are the larger builds. What is difficult to test to see if -f26 and -f28 stubs serve up their respective full installer in the background. 

Any idea how we can verify the stubs are serving up the smaller/larger full installers in the background?
Anyone have any concerns about launching this test on Monday (2013-11-18)? GA is going to be doing the A/B testing and everything we have on bedrock is dynamic and doesn't require bouncer to serve up variations. As long as the products are right in bouncer, we've got the rest. Thanks everyone for the teamwork on this!

Edit: in comment 31 for the dmo product for firefox-stub-f28, I meant 200ok status, not 200k.
:cmore - all good on my end!
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
We still need to do comment #28, because RelEng provide no guarantees of longevity for files living in firefox/candidates/, while we do about firefox/releases/. I'd appreciate it if bugs assigned to me aren't closed like this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Nick Thomas [:nthomas] from comment #34)
> We still need to do comment #28, because RelEng provide no guarantees of
> longevity for files living in firefox/candidates/, while we do about
> firefox/releases/. I'd appreciate it if bugs assigned to me aren't closed
> like this.

Ok, it wasn't clear comment 28 was a status or a blocker. Will this be ready to release on Monday the 18th? Everything else is ready to go. Thanks
Yes, it will be. I'll take care of it on Sunday.
I've done the actions noted in comment #28, and repeated the testing in comment #27. We needed bug 939597 to get the files synced to the origin server for the CDN (which moved to S3 due to the network work in SCL3 on Saturday).

We're good to go from my point of view.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Depends on: 939597
Resolution: --- → FIXED
(In reply to Nick Thomas [:nthomas] from comment #37)
> I've done the actions noted in comment #28, and repeated the testing in
> comment #27. We needed bug 939597 to get the files synced to the origin
> server for the CDN (which moved to S3 due to the network work in SCL3 on
> Saturday).
> 
> We're good to go from my point of view.

Thanks, Nick!
Hey Nick, the stub is unable to pick up the funnelcake id since the stub doesn't contain the funnelcake bits and with the percentage of installs set to 10% this isn't showing any difference in the stub data. Would it be possible to update the stubs being served to include the following?

For the funnelcake 26 stub:
diff --git a/browser/installer/windows/nsis/stub.nsi b/browser/installer/windows/nsis/stub.nsi
--- a/browser/installer/windows/nsis/stub.nsi
+++ b/browser/installer/windows/nsis/stub.nsi
@@ -103,17 +103,17 @@ Var DownloadServerIP
 
 Var ControlHeightPX
 Var ControlRightPX
 
 ; Uncomment the following to prevent pinging the metrics server when testing
 ; the stub installer
 ;!define STUB_DEBUG
 
-!define StubURLVersion "v5"
+!define StubURLVersion "v5-26"
 
 ; Successful install exit code
 !define ERR_SUCCESS 0
 
 /**
  * The following errors prefixed with ERR_DOWNLOAD apply to the download phase.
  */
 ; The download was cancelled by the user

For the funnelcake 28 stub:
diff --git a/browser/installer/windows/nsis/stub.nsi b/browser/installer/windows/nsis/stub.nsi
--- a/browser/installer/windows/nsis/stub.nsi
+++ b/browser/installer/windows/nsis/stub.nsi
@@ -103,17 +103,17 @@ Var DownloadServerIP
 
 Var ControlHeightPX
 Var ControlRightPX
 
 ; Uncomment the following to prevent pinging the metrics server when testing
 ; the stub installer
 ;!define STUB_DEBUG
 
-!define StubURLVersion "v5"
+!define StubURLVersion "v5-28"
 
 ; Successful install exit code
 !define ERR_SUCCESS 0
 
 /**
  * The following errors prefixed with ERR_DOWNLOAD apply to the download phase.
  */
 ; The download was cancelled by the user
Flags: needinfo?(nthomas)
Yes, we can do that I think. Can't promise anything on timing yet due to work week and return travel.
Status: RESOLVED → REOPENED
Flags: needinfo?(nthomas)
Resolution: FIXED → ---
Thanks Nick! I really appreciate whatever you can do here and understand that it is last minute.
I filed bug 941291 to simplify this process. There is another bug for making funnelcake stub installers a repackage that is much more complicated but will make this even simpler.
Nick, if there is anything I can do to help please let me know. Thanks!
I have a question about the stub installer for this test. Is the stub install the same between funnelcake 26 and 28? How does firefox-stub-f26 stub know to get the funnelcake 26 and firefox-stub-f28 know to download the full funnelcake 28? How can we test to verify that firefox-stub-f26 and firefox-stub-f28 stubs are downloading the normal-sized and larger-sized Firefox builds?
Flags: needinfo?(mozbugs.retornam)
(In reply to Chris More [:cmore] from comment #46)
> I have a question about the stub installer for this test. Is the stub
> install the same between funnelcake 26 and 28? 

No. They were generated with attachment 832011 [details] [diff] [review] and attachment 832012 [details] [diff] [review] respectively.

> How does firefox-stub-f26
> stub know to get the funnelcake 26 and firefox-stub-f28 know to download the
> full funnelcake 28? 

The definition of URLStubDownload in those patches

> How can we test to verify that firefox-stub-f26 and
> firefox-stub-f28 stubs are downloading the normal-sized and larger-sized
> Firefox builds?

I'm trying to verify that with wireshark now.
In Chrome, request:
  Full request URI: http://www.mozilla.org/en-US/firefox/new/?f=26

Click d/l link, request:
  Full request URI: http://download.mozilla.org/?product=firefox-latest-f26&os=win&lang=en-US
Returns a 302 to:
  Full request URI: http://download-installer.cdn.mozilla.net/pub/firefox/releases/25.0.1/win32-funnelcake26/en-US/Firefox%20Setup%2025.0.1.exe

Running the stub results in a request for
  Full request URI: http://download-installer.cdn.mozilla.net/pub/firefox/releases/25.0.1/win32-funnelcake26/en-US/Firefox%20Setup%2025.0.1.exe
I have to make a separate request to verify the response has:
  Content-Length: 23344608

After install, a new profile has this page opened:
  http://www.mozilla.org/en-US/firefox/25.0.1/firstrun/?f=26


Repeating that with ?f=28 on the initial request gives the same except 
* replace 26 with 28 everywhere
* Content-Length: 26489616 on the full installer

What problem are you seeing ?
(In reply to Nick Thomas [:nthomas] from comment #48)

Ok, cool. I see the code in the patches and they are the right sizes for the full-download. It was just one part that I didn't test before and I wanted to be positive we weren't serving up the same size URLStubDownload to both. All good. Thanks!
Flags: needinfo?(mozbugs.retornam)
Nick, will you be able to create new stubs with the additional change? Thanks!
Flags: needinfo?(nthomas)
I'll get those generated today.
Flags: needinfo?(nthomas)
The first link makes a request to download-stats like this after a successful install:
GET /stub/v5-26/release/release/en-US/0/0/5/1/2600/0/2/0/23344608/2/8/15/14/0/0/6/6/1/1/0/0/1/0/0/25.0.1/20131112160018/0/1/23.5.180.61 HTTP/1.1

And after a user cancel before the d/l starts:
GET /stub/v5-26/release/release/en-US/0/0/5/1/2600/10/0/0/0/1/10/3/2/0/0/0/0/1/1/0/1/1/0/0/0/0/0/1/23.5.180.61 HTTP/1.1

Similarly for funnelcake28:
GET /stub/v5-28/release/release/en-US/0/0/5/1/2600/0/2/0/26489616/1/10/20/20/0/0/4/6/1/1/0/0/1/0/0/25.0.1/20131112160018/0/1/23.5.180.61 HTTP/1.1
GET /stub/v5-28/release/release/en-US/0/0/5/1/2600/10/0/0/262144/2/7/3/3/0/0/0/0/1/1/0/1/1/0/0/0/0/0/1/23.5.180.61 HTTP/1.1

First run, falling back from 26 to 27/28 to 29 look fine too. OK to proceed with putting this live for downloads on mozilla.org ?
Flags: needinfo?(robert.bugzilla)
Yes and thanks!
Flags: needinfo?(robert.bugzilla)
The new stubs are now live. I moved them into firefox/releases/25.0.1/win32/funnelcake{26,28}/ on the ftp server, and made adjustments in bouncer. Through a little trickery I ensured that the stub d/l links continued to work without interruption.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Thanks Nick! It really is appreciated!
Just to verify. With the experiment that is running with the -f26 through -f29 products that will end in December, I shouldn't have to denote the data about the new stubs, right? From a Google Analytics and ADI perspective, I want to make sure these new stubs won't affect the data I am already pulled from GA. I believe this will have no impact on the reports I am pulling.

Thanks, Nick!
It definitely shouldn't affect it. The change that was made was only to the stub data ping so it is possible to differentiate between funnelcake and non-funnelcake stub ping and everything else should be the same.
Comment on attachment 829951 [details] [diff] [review]
[partner-repacks] Generate 25.0.1 funnelcake26-29 in automation

Backed this out so we don't generate full installers for 26.0. A slight gamble that we won't need a 25.0.2 in the next week. Jinx!
Attachment #829951 - Flags: checked-in+ → checked-in-
You need to log in before you can comment on or make changes to this bug.