If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Version ordering for Firefox 24 incorrectly places beta versions

RESOLVED WONTFIX

Status

Socorro
Webapp
RESOLVED WONTFIX
4 years ago
2 months ago

People

(Reporter: stephend, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation][qa+])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 826071 [details]
version-order.png

Right now on staging, we have the following order in the "Versions" dropdown for Firefox:

24.0b
24.0
24.0b10

According to our tests + Kairo, they should be:

24.0
24.0b
24.0b10

Our automation caught it:

http://qa-selenium.mv.mozilla.com:8080/view/Socorro/job/socorro.stage.saucelabs/401/HTML_Report/?

https://github.com/mozilla/Socorro-Tests/blob/master/tests/test_layout.py#L33
(Reporter)

Comment 1

4 years ago
BTW, this last passed our automation, http://qa-selenium.mv.mozilla.com:8080/job/socorro.stage.saucelabs/400/, on Oct 31, 2013 4:10:06 PM.

Started failing with this build:

http://qa-selenium.mv.mozilla.com:8080/job/socorro.stage.saucelabs/401/ - just 24 minutes later:  (Oct 31, 2013 4:34:45 PM)
(Reporter)

Comment 2

4 years ago
:rhelmer, would you be up for taking a look, given that you've fixed this in the past?
Flags: needinfo?(rhelmer)
(In reply to Stephen Donner [:stephend] from comment #2)
> :rhelmer, would you be up for taking a look, given that you've fixed this in
> the past?

sure
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
Flags: needinfo?(rhelmer)
(Reporter)

Comment 4

4 years ago
BTW, this hit prod too.
(Reporter)

Comment 5

4 years ago
Apologies for putting in milestone 65, but I'd hate to see us defer/xfail a "simple" fix like this, further.
Target Milestone: --- → 65
Duplicate of this bug: 934910

Updated

4 years ago
Keywords: regression
Target Milestone: 65 → 66
Target Milestone: 66 → 67

Updated

4 years ago
Whiteboard: [fromAutomation] → [fromAutomation][qa+]

Comment 7

4 years ago
I guess there's not need for this, since 24.0b is not in the Current Versions list anymore and the test passes
(Reporter)

Comment 8

4 years ago
(In reply to AndreiH from comment #7)
> I guess there's not need for this, since 24.0b is not in the Current
> Versions list anymore and the test passes

No; this will undoubtedly crop up again, so we should fix it.  We can mock the conditions/data from before to fix and re-test.

Comment 9

4 years ago
Yes, right now it's 26.0b and starting this week it will be 27.0b
Removing [previous & old] target milestone since this is still awaiting a fix
Target Milestone: 67 → ---
I am not currently working on this, stephend still happening?
Assignee: rhelmer → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(stephen.donner)
(Reporter)

Comment 12

2 years ago
(In reply to Robert Helmer [:rhelmer] from comment #11)
> I am not currently working on this, stephend still happening?

Yes, this still happens; attaching a screenshot from staging, where it's currently:

40.0b
40.0
40.0b99
40.0b9
...

where it probably should be:

40.0
40.0b
40.0b9
40.0b99
...
Flags: needinfo?(stephen.donner)
(Reporter)

Comment 13

2 years ago
Created attachment 8649571 [details]
socorro-versions.png
(Reporter)

Comment 14

2 years ago
(Also, our automation doesn't bother testing for this any longer - the test was removed in https://github.com/mozilla/Socorro-Tests/issues/309 and https://github.com/tccharles/Socorro-Tests/commit/2756c1158d27c47a0b2690864338ddfa1c957dd8.)
Just a note: we discussed removing order based tests from the functional UI test cases in favor of coding the test cases into a lower level unit/integration test.

Comment 16

2 months ago
The lone and level sands stretch far away.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.