Intermittent gfx/tests/crashtests/408754-1.html | Exited with code 11 during test run | application crashed [@ free]

RESOLVED DUPLICATE of bug 932851

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 932851
5 years ago
5 years ago

People

(Reporter: RyanVM, Assigned: sfink)

Tracking

({crash, intermittent-failure})

Trunk
x86_64
Linux
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=29972973&tree=Mozilla-Aurora

Ubuntu VM 12.04 mozilla-aurora pgo test crashtest-ipc on 2013-11-01 07:38:23 PDT for push 58108b9b3152
slave: tst-linux32-ec2-148

07:53:03     INFO -  REFTEST TEST-START | file:///builds/slave/test/build/tests/reftest/tests/gfx/tests/crashtests/408754-1.html
07:53:03     INFO -  REFTEST TEST-LOAD | file:///builds/slave/test/build/tests/reftest/tests/gfx/tests/crashtests/408754-1.html | 2372 / 2534 (93%)
07:53:04  WARNING -  TEST-UNEXPECTED-FAIL | file:///builds/slave/test/build/tests/reftest/tests/gfx/tests/crashtests/408754-1.html | Exited with code 11 during test run
07:53:04     INFO -  INFO | automation.py | Application ran for: 0:07:06.785461
07:53:04     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpJXetrCpidlog
07:53:04     INFO -  ==> process 2200 launched child process 2231
07:53:04     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2231
07:53:04     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-linux/1383308083/firefox-27.0a2.en-US.linux-i686.crashreporter-symbols.zip
07:54:01  WARNING -  PROCESS-CRASH | file:///builds/slave/test/build/tests/reftest/tests/gfx/tests/crashtests/408754-1.html | application crashed [@ free]
07:54:01     INFO -  Crash dump filename: /tmp/tmpLUfIDr.mozrunner/minidumps/3fad1f86-cb09-1122-2a61f4fa-0eb27a8d.dmp
07:54:01     INFO -  Operating system: Linux
07:54:01     INFO -                    0.0.0 Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
07:54:01     INFO -  CPU: x86
07:54:01     INFO -       GenuineIntel family 6 model 45 stepping 7
07:54:01     INFO -       1 CPU
07:54:01     INFO -  Crash reason:  SIGSEGV
07:54:01     INFO -  Crash address: 0x0
07:54:01     INFO -  Thread 0 (crashed)
07:54:01     INFO -   0  firefox!free [jemalloc.c:58108b9b3152 : 4636 + 0x0]
07:54:01     INFO -      eip = 0x080609d4   esp = 0xbfc3cc00   ebp = 0xbfc3cd08   ebx = 0x0806c9f0
07:54:01     INFO -      esi = 0xbfc3cccb   edi = 0x00000014   eax = 0x00000014   ecx = 0x00000014
07:54:01     INFO -      edx = 0x00000000   efl = 0x00210246
07:54:01     INFO -      Found by: given as instruction pointer in context
07:54:01     INFO -   1  libxul.so!js::Discard [Utility.h:58108b9b3152 : 165 + 0x4]
07:54:01     INFO -      eip = 0xb5f24414   esp = 0xbfc3cc50   ebp = 0xbfc3cd08   ebx = 0xb6ddd440
07:54:01     INFO -      esi = 0xbfc3cccb   edi = 0xbfc3dbf0
07:54:01     INFO -      Found by: call frame info
07:54:01     INFO -   2  libxul.so!js::SCOutput::~SCOutput() [StructuredClone.cpp:58108b9b3152 : 550 + 0x7]
07:54:01     INFO -      eip = 0xb5f2469c   esp = 0xbfc3cc80   ebp = 0xbfc3cdb0   ebx = 0xb6ddd440
07:54:01     INFO -      esi = 0xbfc3cccc   edi = 0xbfc3cccc
07:54:01     INFO -      Found by: call frame info
07:54:01     INFO -   3  libxul.so!js::WriteStructuredClone(JSContext*, JS::Handle<JS::Value>, unsigned long long**, unsigned int*, JSStructuredCloneCallbacks const*, void*, JS::Value) [StructuredClone.cpp:58108b9b3152 : 322 + 0x13]
07:54:01     INFO -      eip = 0xb5f274e6   esp = 0xbfc3cca0   ebp = 0xbfc3cdb0   ebx = 0xb6ddd440
07:54:01     INFO -      esi = 0xbfc3cce8   edi = 0xbfc3cccc
07:54:01     INFO -      Found by: call frame info
07:54:01     INFO -   4  libxul.so!JS_WriteStructuredClone(JSContext*, JS::Handle<JS::Value>, unsigned long long**, unsigned int*, JSStructuredCloneCallbacks const*, void*, JS::Handle<JS::Value>) [StructuredClone.cpp:58108b9b3152 : 1585 + 0x38]
07:54:01     INFO -      eip = 0xb5f2757f   esp = 0xbfc3ce30   ebp = 0xbfc3d044   ebx = 0xb6ddd440
07:54:01     INFO -      esi = 0xbfc3cf38   edi = 0xaf0980c0
07:54:01     INFO -      Found by: call frame info
07:54:01     INFO -   5  libxul.so!JSAutoStructuredCloneBuffer::write(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JSStructuredCloneCallbacks const*, void*) [StructuredClone.cpp:58108b9b3152 : 1729 + 0x36]
07:54:01     INFO -      eip = 0xb5f275d7   esp = 0xbfc3ce70   ebp = 0xbfc3d044   ebx = 0xb6ddd440
07:54:01     INFO -      esi = 0xbfc3d044   edi = 0xbfc3cf38
07:54:01     INFO -      Found by: call frame info
07:54:01     INFO -   6  libxul.so!JSAutoStructuredCloneBuffer::write(JSContext*, JS::Handle<JS::Value>, JSStructuredCloneCallbacks const*, void*) [StructuredClone.cpp:58108b9b3152 : 1717 + 0x35]
07:54:01     INFO -      eip = 0xb5f27645   esp = 0xbfc3cea0   ebp = 0xbfc3d044   ebx = 0xb6ddd440
07:54:01     INFO -      esi = 0xaf0980c0   edi = 0xbfc3cf38
07:54:01     INFO -      Found by: call frame info
(Reporter)

Updated

5 years ago
See Also: → bug 936183, bug 937346
(Reporter)

Updated

5 years ago
See Also: → bug 938729
(Reporter)

Comment 1

5 years ago
Naveed, can you please suggest an owner for this? We now have 4 bugs on file with this same signature and it seems to strike randomly in the Linux crashtests.
Flags: needinfo?(nihsanullah)
Steve can you take a look? Possibly loop it under valgrind. Apparently it crashes quickly. Thanks
Assignee: nobody → sphink
Flags: needinfo?(nihsanullah) → needinfo?(sphink)
(Assignee)

Comment 3

5 years ago
Probably bug 932851.
Flags: needinfo?(sphink)
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 932851
You need to log in before you can comment on or make changes to this bug.