Webpage able to lock up browser with neverending "Stay on page/Leave Page" popups

RESOLVED DUPLICATE of bug 636374

Status

()

RESOLVED DUPLICATE of bug 636374
5 years ago
4 years ago

People

(Reporter: register, Unassigned)

Tracking

25 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Landed on this very spammy page here. http://fbi.gov.id831941135-6697228447.h9615.com/?flow_id=3728&773430=11794/case_id=77244


Actual results:

When trying to navigate away or close browser, you will be forced into an unending loop of confirming whether to "Stay on page" or "Leave Page" popup dialogs. The only option is to force quit your browser to escape the cycle.


Expected results:

Webpages should not be allowed to create unending confirmations that lock up the UI.
Confirmed, Had to force-close Win7 x64 with task manager.  

Setting to new..  

That looks like a malicious page but I'm sure any harm was done visiting it other than having to kill the browser.

Tested using latest Nightly m-c build on win7 64
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All

Comment 2

5 years ago
Probably related to Bug 391834 or Bug 856977.
Blocks: 432687
Duplicate of this bug: 943323

Comment 4

5 years ago
Same issue with this address:
polizei.de.id982380162-5824263999.d2178.com/?flow_id=2554&274112=77811/case_id=96401

Comment 5

5 years ago
The issue comes from multiple iframes which all have the following in the iframe[srcdoc] attribute (message removed): 

    <script> window.onbeforeunload=function(env){ return '…';} </script>

Quick workaround: When on the page, open the developer toolbar (Shift + F2), and type the following:

    pagemod remove element iframe

That at least allows to navigate away from the page and/or report it as abusive (from the help menu).

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636374
You need to log in before you can comment on or make changes to this bug.