The default bug view has changed. See this FAQ.

alarm doesn't trigger when the Peak smartphone is turned off

RESOLVED DUPLICATE of bug 889009

Status

Firefox OS
Gaia::Clock
RESOLVED DUPLICATE of bug 889009
3 years ago
3 years ago

People

(Reporter: Alexander van Loon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130917102605

Steps to reproduce:

I've got a Geeksphone Peak. In the Clock application I set an alarm to wake myself up at 7:00 (AM) in the morning and then turned off the phone. I used to do this all the time with my super cheap LG "dumb" phone, which still has a timer active to trigger an alarm if the phone is powered off.


Actual results:

No alarm was triggered on the Peak. When I woke up at 9:00 (AM) in the morning or so and turned on the Peak, the alarm was triggered two hours late. 


Expected results:

My guess is that this is some kind of hardware limitation because the Peak simply shuts down completely if it's powered off, unlike my LG. However, it would prefer it if the Peak would also be capable of triggering an alarm from a powered-off state. This would facilitate saving the phone's battery life. Of course flight mode can also be used to so, but it's not as good as a complete shutdown.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 889009
You need to log in before you can comment on or make changes to this bug.