Closed Bug 934113 Opened 6 years ago Closed 6 years ago

Menu bar shouldn't be movable

Categories

(Firefox :: Toolbars and Customization, defect)

28 Branch
x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: Robert.Zenz, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:M9][Australis:P2])

Attachments

(2 files)

Attached image FFUX28_Menu.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131028112903

Steps to reproduce:

When the menu is dragged into the navigation bar then it uses the wrong font color. This is only an issue if you use a Gtk theme that uses a light color for the toolbars and a dark one for the menus.

 * Grab a Gtk theme which uses different colors for toolbars and menus (like NewWave)
 * Enter customization mode
 * Drag the menu into the navigation bar


Actual results:

The font color of the menu items stays in the light color, making it invisible against the toolbar.


Expected results:

It should use the same color as the toolbar items.
Component: Untriaged → Toolbars and Customization
The menu bar shouldn't be movable in the first place.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: Menu has the wrong font color when dragged into the navigation bar in Australis 28.0a1 → Menu bar shouldn't be movable
Whiteboard: [Australis:M?][Australis:P2]
Duplicate of this bug: 934095
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 826684 [details] [diff] [review]
correctly mark items as removable when in customize mode,

Review of attachment 826684 [details] [diff] [review]:
-----------------------------------------------------------------

Please add a test for this when you check it in.
Attachment #826684 - Flags: review?(jaws) → review+
(In reply to Jared Wein [:jaws] from comment #4)
> Comment on attachment 826684 [details] [diff] [review]
> correctly mark items as removable when in customize mode,
> 
> Review of attachment 826684 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Please add a test for this when you check it in.

Done. Also fixed the redeclaration of parent in my original patch (ie should have reassigned to parent without the 'let') which was actually busting this logic completely.

https://hg.mozilla.org/projects/ux/rev/853a39fedb08
Whiteboard: [Australis:M?][Australis:P2] → [Australis:M9][Australis:P2][fixed-in-ux]
I saw that and thought it was intentional, but I should have complained about the masking of the outerscoped |parent|. Thanks for fixing it.
https://hg.mozilla.org/mozilla-central/rev/853a39fedb08
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M9][Australis:P2][fixed-in-ux] → [Australis:M9][Australis:P2]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.