IMAP download is broken in 24.1.0

RESOLVED DUPLICATE of bug 926467

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED DUPLICATE of bug 926467
4 years ago
4 years ago

People

(Reporter: jimmy, Unassigned)

Tracking

({imap-interop})

x86_64
Windows 7
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

27.37 KB, text/x-log
Details
(Reporter)

Description

4 years ago
Created attachment 826367 [details]
imap.log

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131101030205

Steps to reproduce:

Upgraded to 24.1.0 through About -> Thunderbird
After that, IMAP stopped working


Actual results:

"The current operation on "Inbox" did not succeed. The mail server for account XXXXXX responded: Error in IMAP command UID FETCH: 8bit data in atom."

The log is attached.  The problem is probably due to the «AnyRecipient» field sent from Thunderbird which confuses Dovecot due to the signs «» being UTF-8.

6480[ceea290]: 9208800:192.168.0.5:S-INBOX:SendData: 9 UID fetch 14400:14481 (UID RFC822.SIZE FLAGS BODY.PEEK[HEADER.FIELDS (From To Cc Bcc Subject Date Message-ID Priority X-Priority References Newsgroups In-Reply-To Content-Type Reply-To «AnyRecipient»)])

6480[ceea290]: ReadNextLine [stream=c89ec48 nb=58 needmore=0]
6480[ceea290]: 9208800:192.168.0.5:S-INBOX:CreateNewLineFromSocket: 9 BAD Error in IMAP command UID FETCH: 8bit data in atom
(Reporter)

Updated

4 years ago
Severity: normal → major
Keywords: imap-interop

Updated

4 years ago
Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926467
You need to log in before you can comment on or make changes to this bug.