|make bootstrap| doesn't install libpulse on Ubuntu 13.10

RESOLVED FIXED in mozilla28

Status

Firefox Build System
Mach Core
RESOLVED FIXED
5 years ago
4 months ago

People

(Reporter: njn, Assigned: kinetik)

Tracking

unspecified
mozilla28
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I'm on 64-bit Ubuntu 13.10.  I just updated mozilla-inbound and got this during the configure step of a clobber build:

 0:04.83 No package 'libpulse' found
 0:04.83 configure: error: pulseaudio audio backend requires libpulse development package

I ran |mach bootstrap| but it didn't install anything extra.

I think libpulse-dev might be the required package, but I can't verify as I'm having trouble installing it due to some kind of connection troubles with the Ubuntu servers.
Observed same problem on 64-bit Ubuntu 12:04 after pulling today.  My previous pull was October 31 and it built without any trouble.
Until this is backed out or fixed, I have worked around the problem
by disabling MOZ_PULSEAUDIO.  I simply changed MOZ_PULSEAUDIO=1
to MOZ_PULSEAUDIO=
in configure.in around line 5609. (probably could have used
--disable-pulseaudio instead).
Probably caused by checkin of bug #837563

Updated

5 years ago
See Also: → bug 837563
(Reporter)

Comment 4

5 years ago
> I think libpulse-dev might be the required package, but I can't verify as
> I'm having trouble installing it due to some kind of connection troubles
> with the Ubuntu servers.

The connection troubles resolved themselves and I can confirm that libpulse-dev is the required package -- I've installed it and can now build again.
Blocks: 837563
(Assignee)

Comment 5

5 years ago
Created attachment 826540 [details] [diff] [review]
bug934290_v0.patch
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
Attachment #826540 - Flags: review?(gps)
Applying the v0 patch, then ./mach bootstrap and ./mach build seems to work for me.  Thanks.
Attachment #826540 - Flags: review?(gps) → review+

Updated

5 years ago
Keywords: checkin-needed

Updated

5 years ago
Duplicate of this bug: 935201
https://hg.mozilla.org/mozilla-central/rev/2441f52f0252
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.