Don't install tests under js/src in --with-libxul-sdk builds

RESOLVED FIXED in Firefox 27

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla28
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27 fixed, firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Assignee

Description

6 years ago
No description provided.
Assignee

Updated

6 years ago
Blocks: 862770
Attachment #826585 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/a356d5b03317
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Assignee

Comment 4

6 years ago
Comment on attachment 826585 [details] [diff] [review]
Don't install tests under js/src in --with-libxul-sdk builds

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 862770
User impact if declined: Breaks building with --with-libxul-sdk (option used by at least fedora and debian).
Testing completed (on m-c, etc.): Landed on m-c a few days ago.
Risk to taking this patch (and alternatives if risky): Doesn't change anything for mozilla.org builds. I've been using this patch for a while on debian.
String or IDL/UUID changes made by this patch: None
Attachment #826585 - Flags: approval-mozilla-aurora?
(In reply to Mike Hommey [:glandium] from comment #4)
> Comment on attachment 826585 [details] [diff] [review]
> Don't install tests under js/src in --with-libxul-sdk builds
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): bug 862770

https://bugzilla.mozilla.org/show_bug.cgi?id=862770 seems to have landed on Fx28 so unclear how Fx27 is affected by that bug, can you help ?
> User impact if declined: Breaks building with --with-libxul-sdk (option used
> by at least fedora and debian).
> Testing completed (on m-c, etc.): Landed on m-c a few days ago.
> Risk to taking this patch (and alternatives if risky): Doesn't change
> anything for mozilla.org builds. I've been using this patch for a while on
> debian.
> String or IDL/UUID changes made by this patch: None
Assignee

Comment 6

6 years ago
(In reply to bhavana bajaj [:bajaj] from comment #5)
> (In reply to Mike Hommey [:glandium] from comment #4)
> > Comment on attachment 826585 [details] [diff] [review]
> > Don't install tests under js/src in --with-libxul-sdk builds
> > 
> > [Approval Request Comment]
> > Bug caused by (feature/regressing bug #): bug 862770
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=862770 seems to have landed on
> Fx28 so unclear how Fx27 is affected by that bug, can you help ?

Err, that was the wrong bug number. The right one is bug 911375. Sorry for the confusion.
Attachment #826585 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Mike Hommey [:glandium] from comment #6)
> (In reply to bhavana bajaj [:bajaj] from comment #5)
> > (In reply to Mike Hommey [:glandium] from comment #4)
> > > Comment on attachment 826585 [details] [diff] [review]
> > > Don't install tests under js/src in --with-libxul-sdk builds
> > > 
> > > [Approval Request Comment]
> > > Bug caused by (feature/regressing bug #): bug 862770
> > 
> > https://bugzilla.mozilla.org/show_bug.cgi?id=862770 seems to have landed on
> > Fx28 so unclear how Fx27 is affected by that bug, can you help ?
> 
> Err, that was the wrong bug number. The right one is bug 911375. Sorry for
> the confusion.

Thanks for the clarification, looks good to land.
Whiteboard: [qa-]

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.