Closed Bug 934334 Opened 6 years ago Closed 6 years ago

[packager] Jar chrome formatter doesn't handle resource:// urls properly

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox26 unaffected, firefox27 fixed, firefox28 fixed)

RESOLVED FIXED
mozilla28
Tracking Status
firefox26 --- unaffected
firefox27 --- fixed
firefox28 --- fixed

People

(Reporter: glandium, Assigned: glandium)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

The chrome manifest entry for the line added to webapprt/locales/jar.mn in bug 851217 is broken with the jar chrome formatting.
Attachment #826586 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/ef8689cf657a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Comment on attachment 826586 [details] [diff] [review]
Fix packager's jar chrome formatter to handle resource:// urls

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 851217
User impact if declined: Building with --with-chrome-format=jar is broken
Testing completed (on m-c, etc.): Landed on m-c a few days ago.
Risk to taking this patch (and alternatives if risky): It doesn't change anything on mozilla.org builds. I've used this patch for a few weeks on debian, where I'm building with --with-chrome-format=jar.
String or IDL/UUID changes made by this patch: None.
Attachment #826586 - Flags: approval-mozilla-aurora?
Attachment #826586 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.