standalone js's make install broken again

RESOLVED FIXED in Firefox 27

Status

RESOLVED FIXED
5 years ago
8 months ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla28

Firefox Tracking Flags

(firefox26 unaffected, firefox27 fixed, firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(2 attachments)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 826587 [details] [diff] [review]
Fix standalone js's make install again, for aurora
Attachment #826587 - Flags: review?(mshal)
I'm a bit confused by this - where does EXPORTS_mozilla_FILES get defined?

I tried to do a standalone js build so I could print out the value, but 'make install' is failing with:

/home/marf/mozilla-central-git/js/src/mybuild/config/nsinstall -t mozjs-None.pc /home/marf/install-js/lib/pkgconfig
/home/marf/mozilla-central-git/js/src/mybuild/_virtualenv/bin/python -m mozbuild.action.process_install_manifest --no-remove /home/marf/install-js/include/mozjs-None _build_manifests/install/dist_include
From /home/marf/install-js/include/mozjs-None: Kept 86 existing; Added/updated 0; Removed 0 files and 0 directories.
/home/marf/mozilla-central-git/js/src/mybuild/config/nsinstall -t  /home/marf/install-js/include/mozjs-None/mozilla
usage: /home/marf/mozilla-central-git/js/src/mybuild/config/nsinstall [-C cwd] [-L linkprefix] [-m mode] [-o owner] [-g group]
                                                                      [-DdltR] file [file ...] directory
make: *** [install] Error 2

This is failing because EXPORTS_mozilla_FILES is still empty.
Flags: needinfo?(mh+mozilla)
(Assignee)

Comment 3

5 years ago
There might have been a change since aurora, then :( The patch was tested on aurora (where this needs fixing anyways).
Flags: needinfo?(mh+mozilla)
(Assignee)

Comment 4

5 years ago
Created attachment 827026 [details] [diff] [review]
Fix standalone js's make install again

So, indeed, bug 870401 changed things and the mfbt headers are now in the install manifest, so the custom rule to install them is now pointless (and broken, since EXPORT_mozilla is empty). The other patch is the variant necessary to fix the same bug on aurora. Please review both.
Attachment #827026 - Flags: review?(mshal)
Comment on attachment 826587 [details] [diff] [review]
Fix standalone js's make install again, for aurora

Makes sense - thanks for the details!
Attachment #826587 - Flags: review?(mshal) → review+

Updated

5 years ago
Attachment #827026 - Flags: review?(mshal) → review+
(Assignee)

Updated

5 years ago
Attachment #826587 - Attachment description: Fix standalone js's make install again → Fix standalone js's make install again, for aurora
(Assignee)

Updated

5 years ago
status-firefox26: --- → unaffected
status-firefox27: --- → affected
(Assignee)

Comment 7

5 years ago
Comment on attachment 826587 [details] [diff] [review]
Fix standalone js's make install again, for aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 919832
User impact if declined: make install doesn't work for standalone js.
Testing completed (on m-c, etc.): Tested on Debian packaging.
Risk to taking this patch (and alternatives if risky): NPOTB for Firefox. Note the patch is not the same as the one landed on m-c because further changes since aurora merge have made the fix different. It's trivial enough, though.
String or IDL/UUID changes made by this patch: None
Attachment #826587 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Blocks: 919832
https://hg.mozilla.org/mozilla-central/rev/42e6d140004e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28

Updated

5 years ago
Attachment #826587 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/05e8967817e7
status-firefox27: affected → fixed
status-firefox28: --- → fixed
Whiteboard: [qa-]

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.