Autocomplete should not ignore a protocol I type

RESOLVED FIXED

Status

SeaMonkey
Autocomplete
--
minor
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: Marek Wawoczny, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Autocompletion should use transport protocol (ftp:// http:// https://) in location bar autocomplete, now it uses only domain name/location. See attached screenshoot. It should show only https://www.mbank.com.pl(...) not http://www.mbank.com.pl(...)
(Reporter)

Comment 1

17 years ago
Created attachment 44559 [details]
Autocompletion with http & https

Comment 2

17 years ago
I think the reporter means that the autocomplete drop down list should contain
entries only for the transport protocol you have typed in the location bar.

ie, In the screenshot the first two entries, which begin with http://, shouldn't
be listed since the protocol https:// has been specified in the location bar.

Comment 3

17 years ago
I confirm with build 2001073103 on win2k.

Comment 4

17 years ago
I do not get this problem with ftp:// or file:///
But if I type http:// or https://, locations of all types show up including
ftp:// and file:///

Comment 5

17 years ago
Confirmed on WinNT.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Autocompletion should use transport protocol (ftp:// http:// https://) in location bar autocomplete. → Autocomplete should not ignore a protocol I type

Comment 6

17 years ago
Might this bug depend on bug 87667? It seems to explain the cause of this bugs
behavior.
(Assignee)

Comment 7

17 years ago
fixed with 84809 landing
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.