[B2G][Helix][Camera][shijinde]Camera preview screen shows errors photo

RESOLVED INVALID

Status

Firefox OS
Gaia::Camera
P2
major
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Zune 4.7; Tablet PC 2.0)

Steps to reproduce:

1、quickly press capture button and get more than five photos
2、quickly click filmstrip region


Actual results:

1、the preview screen shows a big photo when you select anyone.
2、double cliclk the preview screen, the screen changes to two or three parts


Expected results:

1、the preview screen shows photo normally.
(Reporter)

Comment 1

4 years ago
Hi, I do 5 times, and found 2 times.

you can see the attachments.

Thanks
Severity: normal → major
Flags: needinfo?(wchang)
Priority: -- → P2
(Reporter)

Comment 2

4 years ago
Created attachment 826652 [details]
934379-camera.zip
Tested 5 times on my device and not seeing any fault. 

With the STR provided and v1.1 stage now, I don't think we'd spend time investigating this on v1.1.

QAWANTED for v1.2 to see if this is valid.
Flags: needinfo?(wchang)
Keywords: qawanted
I cannot reproduce this one, too.
(Reporter)

Comment 5

4 years ago
Hi, this one is not easy to reproduce. But it is really exist.

Maybe you need do more.

Thanks

Comment 6

4 years ago
I was able to reproduce a similar issue found in the screenshots the reporter provided. While I couldn't reproduce the wrong image appearing when tapping on a photo in the film strip, I was however able to get an error to saying "Picture not saved. An error prevented Camera from saving the picture" and then the Capture button became disabled. I got this error by following the STR in comment 0. 

I've attached a screenshot of the error and a logcat of when the issue occurred. I can open a new bug if need be. 

Environmental Variables: 

Gaia   2140c987fdde1c99097018f7e93b0bbd43d2125d
SourceStamp 6a831fcb96f4
BuildID 20131106004004
Version 26.0
Keywords: qawanted

Comment 7

4 years ago
Created attachment 828818 [details]
camera_capture.txt

Comment 8

4 years ago
Created attachment 828819 [details]
2013-11-07-11-31-58.png
As to the error message, see attachment 828819 [details], this message shows at two cases: 1. the device storage cannot write file into storage and 2. the mozCamera cannot take the picture.
(Reporter)

Comment 10

4 years ago
Hi Wayne

    About this bug, what is you plan? Can you help to process?


Thanks
Flags: needinfo?(wchang)
It still hasnt been reproduced yet, since its hard to reproduce we will not investigate further currently on v1.1.
Flags: needinfo?(wchang)
(Reporter)

Comment 12

4 years ago
Hi Beatriz

    Do you argee comment 11?
    this bug maybe differect to reproduce, but it is exist actually.

Thanks
Flags: needinfo?(brg)
See Also: → bug 944452
Agree with comment 11.
Flags: needinfo?(brg)
This bug is obsolete since we removed the filmstrip from camera
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.