Crash at startup in nsWebShell.cpp

VERIFIED FIXED

Status

SeaMonkey
General
P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: jim_nance, Assigned: Jim Dunn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I got this crash with source pulled on 7 July 1999 at 5:00 AM EDT, but I have
gotten it ever since I started building mozilla under HP-UX (about 2 weeks ago).
When I start apprunner I get a crash at:

XPInstall Component created
Initialized app shell component {18c2f989-b09f-11d2-bcde-00805f0e1353},
rv=0x00000000
GFX: dpi=96 t2p=0.0666667 p2t=15 depth=8

Program received signal SIGSEGV, Segmentation fault.
0x7a6cc900 in nsWebShell::Init (this=0x400dc600, aNativeParent=0x400d2200,
    x=0, y=0, w=615, h=500, aScrolling=nsScrollPreference_kNeverScroll,
    aAllowPlugins=1, aIsSunkenBorder=1)
    at /scratch/jnance/mozilla/mozilla/webshell/src/nsWebShell.cpp:985
985       WEB_TRACE(WEB_TRACE_CALLS,
(gdb) p gLogModule
Cannot access memory at address 0xba6b71e4.

which I believe is related to the static initialization of the gLogModule
variable:

#ifdef NS_DEBUG
/**
 * Note: the log module is created during initialization which
 * means that you cannot perform logging before then.
 */
static PRLogModuleInfo* gLogModule = PR_NewLogModule("webshell");
#endif

If I #undef NS_DEBUG in this file then I make it through this part of the
code w/o any problems.
(Reporter)

Comment 1

19 years ago
The problem is still there with a July 15 pull and HP-UX build.

Updated

19 years ago
Assignee: don → chofmann

Comment 2

19 years ago
Chris, who's the HP-UX expert around here?

Comment 3

19 years ago
jdunn and briano will know how to fix or track down.

Comment 4

19 years ago
jdunn and briano will know how to fix or track down.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
I believe that this has been fixed with all of the recent checkins.
If you disagree, please let me know.

Comment 6

19 years ago
Adding verifyme keyword.
Keywords: verifyme
(Assignee)

Comment 7

19 years ago
marking verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.