The POST content is not visible when there is no classic POST data sent.

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Console
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: Marian Kostadinov, Unassigned)

Tracking

28 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 826679 [details]
network_tab_missing_post.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131102080838

Steps to reproduce:

Perform an XMLHttpRequest that sends a POST data in JSON format (or any format that is not like a=b&c=d ....


Actual results:

The only way to see the posted data is by clicking "Edit and resend". There the posted data is displayed correctly in the "Request Body" textarea.


Expected results:

The posted data should have been visible as a separate section in the Headers tab or in the Params tab in a similar way like form data is currently displayed.

Updated

4 years ago
Component: Untriaged → Networking: HTTP
Product: Firefox → Core

Comment 1

4 years ago
Same result with FF25?
Flags: needinfo?(manchokapitancho)
(Reporter)

Comment 2

4 years ago
Yes, the same result.
Flags: needinfo?(manchokapitancho)
Component: Networking: HTTP → Developer Tools
Product: Core → Firefox
Do you see the POST data in the web console's network panel? Click on the POST request.
(Reporter)

Comment 4

4 years ago
Nope, it's not displayed there.
Thanks for checking. Can you please provide us with a test page?
Component: Developer Tools → Developer Tools: Netmonitor
(Reporter)

Comment 6

4 years ago
Yes, there it is:

http://crop-factor.net/ff/

I found out when this happens - when this one is set:
[setRequestHeader ("Content-Type", "application/x-www-form-urlencoded; charset=utf-8");]

I give 4 examples - with and without this header + classic post vs JSON post data.
Only the combination of the header and the JSON post data does not work.
Moving this to the webconsole since it seems to be a problem with the actors (comment 4).
Status: UNCONFIRMED → NEW
Component: Developer Tools: Netmonitor → Developer Tools: Console
Ever confirmed: true
The test page still works (thanks  Marian Kostadinov for a very helpful test page!). The Params tab currently shows the JSON object, so I believe this can be closed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.