Website data remains in Data Manager after Clear Private Data command

RESOLVED FIXED

Status

SeaMonkey
Passwords & Permissions
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: junk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Win64; x64; Trident/5.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

open data manager


Actual results:

all the websites you have ever visited are listed here


Expected results:

as I ask for my history to be erased this list should be blank.

Comment 1

4 years ago
It shouldn't, if you want to empty it - clear cookies, offline data and passwords
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

4 years ago
on OSX even if you clear everything the website preferences don't get cleared in the data manager.
seamonkey version 2.22
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Updated

4 years ago
OS: Windows 7 → Mac OS X
Hardware: x86 → x86_64

Comment 3

4 years ago
It doesn't matter which OS you are using, if history is not cleared -> you have misbehaving add-on, check Safe Mode (Help - Restart with Add-ons Disabled)
Flags: needinfo?(junk)
(Reporter)

Comment 4

4 years ago
history is cleared, websites preferences in the data manager are not.
I don't have any add-on.

I am not the only one noticing the problem, search google with:
"SeaMonkey Site preferences are not cleared"
Flags: needinfo?(junk)

Comment 5

4 years ago
So, did you check Safe Mode?
Flags: needinfo?(junk)
Whiteboard: closeme INCO 2013-12-15
(Reporter)

Comment 6

4 years ago
I did try the safe mode but the websites preferences are still not cleared (and I erase every private data).
Flags: needinfo?(junk)

Comment 7

4 years ago
SeaMonkey 2.23 is out, is problem still present?
Flags: needinfo?(junk)
Whiteboard: closeme INCO 2013-12-15 → closeme INCO 2014-01-01

Comment 8

4 years ago
Confirming problem on trunk, sites Permissions and Preferences are not cleared.
Steps to reproduce:
1) Visit a couple of sites which set preferences (I observe google, github, cnet and even mozilla.org/mozilla.net in data list)
2) Go to Tools - Clear Private Data, check everything, press Clear Private Data Now
Expected result:
Everything in Data Manager must be deleted
Actual result:
All sites Permissions and Preferences are still present
Status: UNCONFIRMED → NEW
Component: General → Passwords & Permissions
Ever confirmed: true
Flags: needinfo?(junk)
OS: Mac OS X → All
Hardware: x86_64 → All
Whiteboard: closeme INCO 2014-01-01
Version: SeaMonkey 2.22 Branch → Trunk

Updated

4 years ago
Duplicate of this bug: 965563

Comment 10

3 years ago
In Seamonkey 2.33 still some website data remains after the Clear Private Data command. 

At least this is:
Permissions - TLS False Start using RSA
Preferences - browser.content-full-zoom

Passwords and Cookies seem to be cleared now.
Summary: website preferences in data manager are not clearable → Website data remains in Data Manager after Clear Private Data command
I fixed some preferences problems in Bug 1269195. There was at least one index which was wrong / undefined. Could you recheck if this problem still is valid when 2.45 becomes available. The latest linux nightlys would also work.
Flags: needinfo?(hb)
No response. I assume its fixed in 2.45+ for now. Please reopen if this is not the case.
Status: NEW → RESOLVED
Last Resolved: 4 years agoa year ago
Flags: needinfo?(hb)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.