Status

()

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jen, Unassigned)

Tracking

26 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The Box Edit Plug-in stopped working in Beta and Aurora.  It used to work for all the Mozilla Box users we started having problems this morning.   Now, when we log into Box in Beta or Aurora, the browser will keep prompting us to install the Box Edit plug-in.    However, in Firefox 25 and Safari it doesn't have that issue.
Do you have a reference to this plug-in?
(Reporter)

Comment 2

5 years ago
https://app.box.com/download-box-edit/

Let me know if you need an account for testing and I can set you up with one on our account.
Component: Extension Compatibility → Plug-ins
Product: Firefox → Core

Comment 3

5 years ago
Can you provide specific steps to reproduce? When you're on a site that wants to use the plugin, is the plugin itself visible on the page? If not, is the plugin icon visible in the location bar?
Flags: needinfo?(jhayashi)
(Reporter)

Comment 4

5 years ago
Here's what we see happening:

1)  Log into Box account
2)  Preview a Word/Excel Document
3)  Click on the "Edit" button
4)  A prompt comes up to install Box Edit (even though we already have it installed)
5)  You download and install Box Edit, restart Firefox Beta or Firefox Aurora
6)  You Preview the doc, click on "edit, and it prompts you again to install Box, over and over.  It doesn't seem to recognize that the plug-in is installed.  If you go to add-ons you will see that the plugin is installed and set to "Ask to Activate"

What should happen:
1)  Log into Box Account
2)  Preview a Word/Excel Document
3)  Click on the "Edit" button
4)  A notification comes up saying that it's opening the file and if you want to lock the file
5)  The corresponding Word or Excel application opens with the document you're attempting to edit
Flags: needinfo?(jhayashi)
(Reporter)

Comment 5

5 years ago
If it helps, I can jump on Vidyo and show you.

Comment 6

5 years ago
The specific answer I need to know is whether the plugin icon is visible in the location bar (grey or blue) at the point that it says that the box plugin is not installed.
Flags: needinfo?(jhayashi)
(Reporter)

Comment 7

5 years ago
There's no plugin visible on the location bar.
Flags: needinfo?(jhayashi)

Comment 8

5 years ago
I installed and tested this on Nightly with the latest patches: the blue icon does show up and you can enable the plugin via the doorhanger.

With bug 932854 this should also show a visible doorhanger to make it more discoverable.
(Reporter)

Comment 9

5 years ago
oh - so the problem is that the box plugin is disabled?

Comment 10

5 years ago
All plugins are click-to-activate by default starting in FF26.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.