[B2G][Gallery] Check box icon is not displayed in the Crop screen when adding Gallery picture to a contact or to MMS

RESOLVED FIXED

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: nkot, Assigned: johnhu)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox26 unaffected)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 826857 [details]
screenshot

Description:
The user is unable to add Gallery picture to a contact or to MMS - check box is not displayed in the header of the Crop screen.

Repro Steps:
1) Updated Buri to BuildID: 20131104044747
2) Open Contacts and select to create new contact
3) Tap to add photo using Gallery option
4) Select an image from Gallery
5) Observe the header of the Crop screen

Actual:
 Check box is not displayed - unable to add a picture 

Expected:
 The user is able to add picture to a contact by tapping check box while in the Crop screen

Environmental Variables:
Device: Buri m-c Mozilla RIL
BuildID: 20131104044747
Gaia: 1aee772a384f1ed1148f08c6c7df45d2fe35506e
Gecko: b4143e04bea1
Version: 28.0a1
Firmware Version: 

Notes:
 - this bug also happening when attempting to add Gallery picture to an MMS
 - Buri 1.2 build is not affected

Repro frequency: 100%
Link to failed test case:
See attached screenshot
(Reporter)

Updated

5 years ago
status-firefox26: --- → unaffected
(Reporter)

Comment 1

5 years ago
looks like it's only the icon that is missing, the user still able to add picture by tapping in the top right corner in the icon supposed location...
Summary: [B2G][Gallery] Unable to add Gallery picture to a contact or to an MMS - check box is not displayed in the Crop screen → [B2G][Gallery] Check box icon is not displayed in the Crop screen when adding Gallery picture to a contact to MMS
(Reporter)

Updated

5 years ago
Summary: [B2G][Gallery] Check box icon is not displayed in the Crop screen when adding Gallery picture to a contact to MMS → [B2G][Gallery] Check box icon is not displayed in the Crop screen when adding Gallery picture to a contact or to MMS
(Reporter)

Comment 2

5 years ago
Created attachment 826942 [details]
logcat

Updated

5 years ago
blocking-b2g: --- → 1.3?
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
Keywords: smoketest
Okay, only missing an icon upon clarification, so not a blocker.
Keywords: smoketest
(In reply to Jason Smith [:jsmith] from comment #3)
> Okay, only missing an icon upon clarification, so not a blocker.

Not a smoketest blocker I mean
Looking at the log...

11-04 15:17:44.980: E/memalloc(140): /dev/pmem: No more pmem available
11-04 15:17:44.980: E/msm7627a.gralloc(140): gralloc failed err=Out of memory

OOM issue?  I think we really need to get the blobs updated and retest these bugs.
(Reporter)

Comment 6

5 years ago
Regression window (if it's still needed here):

-last working-
BuildID: 20131101040203
Gaia: ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
Gecko: abe6790a5dd8
Version: 28.0a1
Firmware: 20131015

-first broken-
BuildID: 20131102040200
Gaia: 50f0c914fa5cb89694c0cdd41b6e10b714787070
Gecko: 396e59370945
Version: 28.0a1
Firmware: 20131015
Keywords: regressionwindow-wanted
Assignee: nobody → johu
Created attachment 827264 [details] [review]
put icon-done class back.

The icon-done is removed by other patch which changes the done icon of editing mode to "Save" text. But there is another place using icon-done class and icon. So, I put the icon-done class back and remove a closing tag without opening.
Attachment #827264 - Flags: review?(dflanagan)
Comment on attachment 827264 [details] [review]
put icon-done class back.

oops! Thanks for fixing it. Is the icon file itself still there? I'm surprised that Tom's patch did not remove it as well.
Attachment #827264 - Flags: review?(dflanagan) → review+
The icon is still there.
merged to master:
https://github.com/mozilla-b2g/gaia/commit/29d16b01fe9bc4c5806ba2f83ec3cb981b0b89e7

The travis shows an error in gaia_ui_test which is not related to this patch, it's related to clock.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
blocking+ for regression
blocking-b2g: 1.3? → 1.3+
You need to log in before you can comment on or make changes to this bug.