Too small Videoplayer (or to huge Video) on the "Get Add-ons"-Page.

VERIFIED FIXED in Firefox 27

Status

()

Core
Graphics
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: senden9, Assigned: mattwoodrow)

Tracking

(Blocks: 1 bug, {regression})

27 Branch
mozilla28
x86_64
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27+ verified, firefox28+ verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 827000 [details]
screencast.webm

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131104213955

Steps to reproduce:

1. Start Firefox (Nightly).
2. Open the "Add-ons" Tab.
3. Click "Watch the Video".

If switch to fullscreen the size is OK.


Actual results:

The Video is too large for the Player.


Expected results:

The Video should resize to the Player.
(Reporter)

Comment 1

4 years ago
Created attachment 827001 [details]
about_support_Troubleshooting_Information.txt

The output from "about:support".
I'm not seeing this on Mac 10.8.5 or on Win7.
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit

Comment 3

4 years ago
WFM with FF28 and Win 7.
Could you test FF28 with a clean profile, please.
Flags: needinfo?(senden9)
(In reply to Liz Henry :lizzard from comment #2)
> I'm not seeing this on Mac 10.8.5 or on Win7.

(In reply to Loic from comment #3)
> WFM with FF28 and Win 7.
> Could you test FF28 with a clean profile, please.

This is related only for Ubuntu platform. I can easy reproduce this issue on Ubuntu 13.04 and Ubuntu 13.10 x86 and x86_64.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

4 years ago
It's probably a regression, could you run mozregression to find a regression range, please?
Flags: needinfo?(senden9)
Keywords: regressionwindow-wanted
Version: Trunk → 28 Branch
This is not related to the Add-ons Manager as long it is a video issue not an Addon. More related to Graphics.
Component: Add-ons Manager → Graphics
Product: Toolkit → Core

Comment 7

4 years ago
Regression wndow(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/e3c84e9f2490
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131002030201
Bad:
http://hg.mozilla.org/mozilla-central/rev/aca286bc0013
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131002084414
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e3c84e9f2490&tochange=aca286bc0013



Regression wndow(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/32c6282f3a29
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131002004849
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7689530c9fc6
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131002024050
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=32c6282f3a29&tochange=7689530c9fc6

Regressed by:
2f189d31161d	Matt Woodrow — Bug 916034 - Enable azure content for gtk2. r=jrmuizel


setting gfx.content.azure.enabled = false fixes the problem
Blocks: 916034
tracking-firefox27: --- → ?
tracking-firefox28: --- → ?
Keywords: regressionwindow-wanted → regression
Version: 28 Branch → 27 Branch

Comment 8

4 years ago
Created attachment 827521 [details]
screenshot with disabled HWA

The problem happens on windows7 too, if disabled HWA.

http://hg.mozilla.org/mozilla-central/rev/770de5942471
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131105030206

Updated

4 years ago
OS: Linux → All

Comment 9

4 years ago
(In reply to Alice0775 White from comment #8)
> Created attachment 827521 [details]
> screenshot with disabled HWA
> 
> The problem happens on windows7 too, if disabled HWA.
> 
> http://hg.mozilla.org/mozilla-central/rev/770de5942471
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
> ID:20131105030206

I've filed separate Bug 935110 for windows.
OS: All → Linux
(Reporter)

Comment 10

4 years ago
Created attachment 827564 [details]
xpcshell-test.txt

Test from changeset 48dbd532a004.
Run with ./mach xpcshell-test --sequential
Tests failed: 8
(Reporter)

Comment 11

4 years ago
(In reply to Loic from comment #3)
> WFM with FF28 and Win 7.
> Could you test FF28 with a clean profile, please.
I test it with a new/clean profile and a fresh comilat (changeset 48dbd532a004) , it's the same.

(In reply to Mihai Morar, QA (:MihaiMorar) from comment #4)
>´[.....]
> This is related only for Ubuntu platform. I can easy reproduce this issue on
> Ubuntu 13.04 and Ubuntu 13.10 x86 and x86_64.
I'm use Arch Linux,

(In reply to Loic from comment #5)
> It's probably a regression, could you run mozregression to find a regression
> range, please?
I will try it in a the next hours.
(Reporter)

Comment 12

4 years ago
(In reply to Alice0775 White from comment #7)
> [....]
> setting gfx.content.azure.enabled = false fixes the problem

OK, you have already tested it with mozregression. So I will not do it. And yes, set gfx.content.azure.enabled to false helps.
(Assignee)

Updated

4 years ago
Assignee: nobody → matt.woodrow
Spoke offline with Matt and he is going to look at these fallout's from enabling azure.

Updated

4 years ago
status-firefox26: --- → unaffected
status-firefox27: --- → affected
status-firefox28: --- → affected
tracking-firefox27: ? → +
tracking-firefox28: ? → +
(Assignee)

Comment 14

4 years ago
Created attachment 828432 [details] [diff] [review]
Use the right pattern transform
Attachment #828432 - Flags: review?(bas)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 935110
Attachment #828432 - Flags: review?(bas) → review+
(Assignee)

Comment 16

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/cea7b9a8ab99
https://hg.mozilla.org/mozilla-central/rev/cea7b9a8ab99
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox28: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
(Assignee)

Comment 18

4 years ago
Comment on attachment 828432 [details] [diff] [review]
Use the right pattern transform

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 907926
User impact if declined: Video (and potentially other content) drawn in the wrong place if it has rounded corners.
Testing completed (on m-c, etc.): Been on m-c for a while
Risk to taking this patch (and alternatives if risky): Very low risk.
String or IDL/UUID changes made by this patch: None
Attachment #828432 - Flags: approval-mozilla-aurora?

Updated

4 years ago
Keywords: verifyme

Updated

4 years ago
Attachment #828432 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/818be0367b1d
status-firefox27: affected → fixed
Verified as fixed on Ubuntu 13.04 64-bit, with both latest Nightly & Aurora builds.
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
status-firefox28: fixed → verified
QA Contact: manuela.muntean

Updated

4 years ago
Keywords: verifyme

Updated

4 years ago
Depends on: 952235

Updated

4 years ago
Depends on: 953085
You need to log in before you can comment on or make changes to this bug.