Don't CollectWhite JS in the cycle collector

RESOLVED DUPLICATE of bug 1087799

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 1087799
4 years ago
3 years ago

People

(Reporter: mccr8, Assigned: mccr8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

4 years ago
Created attachment 827099 [details] [diff] [review]
Don't collect white JS objects, WIP

JS objects don't do anything in their Root, Unlink, or Unroot callbacks, and we are already detecting them by looking at their refcounts, so we should just skip them entirely.  I should also assert that they are using either the JS or JSCompartment participant.  It would also be nice to figure this out earlier in the process, so we don't need to allocate quite so large of a white nodes buffer.
(Assignee)

Comment 2

4 years ago
This probably isn't a big deal until I make CollectWhite incremental, which will requiring the set of white nodes on the heap rather than the stack.
Blocks: 926533
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1087799
You need to log in before you can comment on or make changes to this bug.