[Fugu]the specific video files(h264+aac) do not play smoothly,almost stuck in the end

RESOLVED DUPLICATE of bug 934106

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 934106
4 years ago
4 years ago

People

(Reporter: cheng.luo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 827222 [details]
video_play_err.log

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/11.04 Chromium/18.0.1025.168 Chrome/18.0.1025.168 Safari/535.19

Steps to reproduce:

1、lunch video app;
2、select the one video file;


Actual results:

do not play smoothly, after 2 seccond, almost stuck.


Expected results:

play smoothly
(Reporter)

Comment 1

4 years ago
the specific video files played normally in stagefright player(the same gonk version with FFOS).
I try extract the video file to video track and auido track. The both tracks could play normally in video app and music app(FFOS).Maybe it is not as good as Android on A/V sync.
(Reporter)

Comment 2

4 years ago
remove A/V sync in MediaDecoderStateMachine::AdvanceFrame temporarily,it could played very fast,so codec is OK。
(Reporter)

Comment 3

4 years ago
Maybe relate to Bug 883814 ,but the patch in Bug 883814 don't work better
From the log, hw video codec became buffer starvation.

> [OMX.sprd.h264.decoder] Timed out waiting for output buffers: 0/4
cheng.luo, can we have the video file? And can you answer the following quesitons?
- Can you try a patch in Bug 934106?
- Can the video file be played on v1.1?
- Is Bug 864230 already applied to your environment?
Flags: needinfo?(cheng.luo)
(Reporter)

Comment 6

4 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #5)
> cheng.luo, can we have the video file? And can you answer the following quesitons?
> - Can you try a patch in Bug 934106?
    Excellent! Work well.

> - Can the video file be played on v1.1?
    Yes, it's OK on v1.1.

> - Is Bug 864230 already applied to your environment?
    Yes,already apply.

Thanks.I am sorry that had not uploaded video file,since the file is larger.
Is it necessary now?
Flags: needinfo?(cheng.luo)
(In reply to cheng.luo from comment #6)
> Thanks.I am sorry that had not uploaded video file,since the file is larger.
> Is it necessary now?

The problem was already fixed on your side by the patch. It is not necessary now. Thanks for the confirmation.

Updated

4 years ago
Depends on: 934106

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 934106
Resolution: --- → DUPLICATE
Duplicate of bug: 934106
peipei, please help to reproduce it.
Flags: needinfo?(pcheng)
(In reply to Steven Yang [:styang] from comment #9)
> peipei, please help to reproduce it.

This is not reproducible any more with buri V1.2.
Flags: needinfo?(pcheng)
You need to log in before you can comment on or make changes to this bug.