When you want to change the Wallpaper second times, it doesn't work

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: atsai, Assigned: alive)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
You cannot select wallpaper after the first time you changed it.

STR:
1. Long tap on the homescreen
2. Select Wallpaper
3. Choose any wallpaper
4. Long tap on the homescreen
5. Select Wallpaper

Expected Result:
*. I can change the wallpaper

Actual Result:
*. I cannot change the wallpaper.

** The case is by the testing on Flatfish devices. It might not be able to reproduce on other mobile devices **

Gaia:     ac7cf6a73231b3e30fb065c2f38f69c4f5926caa
Gecko:    facaf2461856789476876566b60b5af461a59b79
BuildID   20131105111940
Version   28.0a1

Updated

5 years ago
Whiteboard: [Flatfish] → [Flatfish][developer+]
(Reporter)

Comment 1

5 years ago
Still reproducible in the daily build.

Gaia:     e95ab38f3c7ea2834e92f4ff37143432f0312a71
Gecko:    7a9d20c22caf534b027f69ffd5e4a274be8c66b7
BuildID   20131106064537
Version   28.0a1
I can reproduce it on mobile, too. The second pick activity seems to fail very quickly, event we have select any picture.
Assignee: nobody → johu
I can reproduce it on mobile, too. Seems not a Flatfish only issue
When I check the Wallpaper instance, I found a that the second activity message is sent to the previous Wallpaper instance.

The following is the first activity message, syntax is instance: {id} @: {time}:
E/GeckoConsole( 6005): Content JS LOG at app://wallpaper.gaiamobile.org/js/pick.js:7 in wallpaper_init: init, instance:  1383798804039  @: 1383798804227
E/GeckoConsole( 6005): Content JS LOG at app://wallpaper.gaiamobile.org/js/pick.js:46 in wallpaper_startPick: startPick, instance:  1383798804039  @: 1383798804312

The following is the second activity message
E/GeckoConsole( 6005): Content JS LOG at app://wallpaper.gaiamobile.org/js/pick.js:46 in wallpaper_startPick: startPick, instance:  1383798804039  @: 1383798820928
E/GeckoConsole( 6005): Content JS LOG at app://wallpaper.gaiamobile.org/js/pick.js:7 in wallpaper_init: init, instance:  1383798821226  @: 1383798821292

We can find the sequence of startPick and init is reversed and the second startPick is dispatched to the first instance.

The same symptom is also happened to Camera app and Gallery app.
put qawanted to find out the regression window
Keywords: regression, regressionwindow-wanted
Summary: [Flatfish] When you want to change the Wallpaper second times, it doesn't work → When you want to change the Wallpaper second times, it doesn't work
Note:
1. Add bookmark in browser seems work even launched second time.
2. It seems the failure occurs once activity is succeeded once in homescreen......?
Yes, right.

I also tested pick activity from UI tests app. They works correctly multiple times, but only failed in homescreen.

Unassign myself to find someone who is capable to solve it.
Assignee: johu → nobody
Changed to general temporarily since it looks like a gecko issue.
I don't get any activitydone event when the second activity does postError/postResult.
Component: Gaia::System → General
Alive,

From the view of wallpaper app, we found the second pick activity is dispatched to the first instance of wall perp. But the UI shows the second instance of wallpaper. When UI shows up and no pick activity, no event is hooked to the UI of second instance and no more postError or postResult sent. See the log in comment 4.

I feel this may be caused by that the activity close procedure doesn't free the first activity window.
Removing flatfish flags as this is a general regression, not specific to flatfish.
No longer blocks: 903304
Whiteboard: [Flatfish][developer+]
(In reply to John Hu [:johnhu] from comment #9)
> Alive,
> 
> From the view of wallpaper app, we found the second pick activity is
> dispatched to the first instance of wall perp. But the UI shows the second
> instance of wallpaper. When UI shows up and no pick activity, no event is
> hooked to the UI of second instance and no more postError or postResult
> sent. See the log in comment 4.
> 
> I feel this may be caused by that the activity close procedure doesn't free
> the first activity window.

Looks like the first frame is not removed correctly. But I don't know why now...
Thanks!
Assignee: nobody → alive
Created attachment 828790 [details] [review]
Fix homescreen as activity caller

Fix homescreen reference problem as an activity caller.
Attachment #828790 - Flags: review?(timdream)
Depends on: 911053
blocking-b2g: koi? → ---
Talked w/Alive in person - this bug only applies to 1.3 & is caused by bug 911053, so we know the regressing bug in this case.
blocking-b2g: --- → 1.3?
Component: General → Gaia::System::Window Mgmt
Keywords: regressionwindow-wanted
Attachment #828790 - Flags: review?(timdream) → review+
Merging because I don't think test failed is caused by this -- but ready to backout if so.
https://github.com/mozilla-b2g/gaia/commit/b753e2666986710baaf91c1bec41fd70c49f9f92
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
blocking-b2g: 1.3? → 1.3+
You need to log in before you can comment on or make changes to this bug.