Closed Bug 934911 Opened 7 years ago Closed 7 years ago

addstream event is not fired when one media is RECVONLY

Categories

(Core :: WebRTC, defect)

25 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 917980

People

(Reporter: sangyumin, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

(need camera and microphone)
1. Deploy the attached file firefox_recvonly_issue.html.
2. Visit it by Firefox .
3. Click button "Start".
4. Click "Share Selected Device" on the popup media access windows.


Actual results:

The left one can get video of the right one. But the right  one cannot get video of the left one.

The pc1 (the left one) fires event addstream, but the pc2 (the right one) does not.


Expected results:

Both the left one and the right one can see video of another peer since the video media are all SENDRECV.

Both pc1 and pc2 need fire event addstream even though the offer sent from pc1 to pc2 has RECVONLY audio media.
I've verified that this is a duplicate of Bug 881236.

Workaround:

Remove line 61 and it works:

  var cAV11 = {
    'mandatory' : {
-     'OfferToReceiveAudio' : true,
      'OfferToReceiveVideo' : true
    }
  };
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881236
(In reply to Jan-Ivar Bruaroey [:jib] from comment #1)
> I've verified that this is a duplicate of Bug 881236.

Sorry, I meant Bug 917980 (though they may turn out to be the same).
Duplicate of bug: 917980
You need to log in before you can comment on or make changes to this bug.