[Costcontrol] SMS counter shows 'null' after sending a message with a VIVO SIM Card

VERIFIED FIXED in Firefox OS v1.2

Status

Firefox OS
Gaia::Cost Control
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: isabelrios, Assigned: salva)

Tracking

({regression})

unspecified
1.2 C5(Nov22)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: burirun3, qaregressexclude)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 827294 [details]
IMG_0028.jpg

1.2 buri testrun3 build:
Gecko-9150851
Gaia-606517c

STR
Use a VIVO SIM Card
1. Open Usage app in order to configure it
2. Send a message

EXPECTED
Both in the utility tray and in the telephony part of the application it appears the number of SMS sent

ACTUAL
After sending a message, it appears 'Null' instead of the number of messages.

Please see picture attached
(Reporter)

Updated

4 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
(Reporter)

Comment 1

4 years ago
Created attachment 827296 [details]
IMG_0029.jpg

Updated

4 years ago
Keywords: regressionwindow-wanted
blocking-b2g: koi? → koi+

Updated

4 years ago
Whiteboard: burirun3 → burirun3, qaregressexclude
SIM dependent, so regression window is going to be difficult to get here.
Keywords: regressionwindow-wanted
Assignee: nobody → salva
This is a regression caused by bug 903403. Converting the function `getSegmentInfoForText()` into an asynchronous function has broken the Cost Control functionality.

Working on a patch.
Created attachment 829868 [details]
pr13551.html
Attachment #829868 - Flags: review?(francisco.jordano)

Updated

4 years ago
Blocks: 903403

Updated

4 years ago
Target Milestone: --- → 1.2 C5(Nov22)
Comment on attachment 829868 [details]
pr13551.html

Left some comments on github, but don't affect to the correct way of working.

Thanks Salva!
Attachment #829868 - Flags: review?(francisco.jordano) → review+
Master: b9755c73c7faaf949d74c14f2a58dd542b5da543
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Uplifted b9755c73c7faaf949d74c14f2a58dd542b5da543 to:
v1.2: 8e9f8c69e13ad4a3fb3c3a23a8e73788a3570209
status-b2g-v1.2: --- → fixed
(Reporter)

Comment 8

4 years ago
Verified on 11/19 v1.2 build:
Gecko-fab26c3
Gaia-9439907
Now the number of messages sent is shown
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.