If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Browser] Intermittent Marionette JS failure for "share url from browser share button should put url in email body": JavaScriptError: (17) Element has not been seen before. Id given was undefined

RESOLVED DUPLICATE of bug 932331

Status

Firefox OS
Gaia::Browser
RESOLVED DUPLICATE of bug 932331
4 years ago
4 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
1) share url from browser share button should put url in email body:

JavaScriptError: (17) Element has not been seen before. Id given was undefined

Remote Stack:

<none>

at Error.MarionetteError (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)

at Object.Client._handleCallback (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:472:19)

at /home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:506:21

at TcpSync.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:94:10)

at Object.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:453:36)

at Object.Client._sendCommand (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:499:19)

at Object.Element._sendCommand (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/element.js:49:21)

at Object.text (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/element.js:186:19)

at Object.client.waitFor.timeout (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-helper/index.js:109:12)

at modifiedTest (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:642:22)

at Object.Client.waitForSync (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:667:9)

at Object.Client.waitFor (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:646:60)

at Object.MarionetteHelper.waitForAlert (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-helper/index.js:106:17)

at Object.Email.confirmWantAccount (/home/travis/build/mozilla-b2g/gaia/apps/email/test/marionette/lib/email.js:115:24)

at Context.<anonymous> (/home/travis/build/mozilla-b2g/gaia/apps/browser/test/marionette/share_url_test.js:89:11)

at Test.Runnable.run (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:211:32)

at Runner.runTest (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:355:10)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:401:12

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:281:14)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:290:7

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:234:23)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:253:7

at done (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:185:5)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:197:9

at /home/travis/build/mozilla-b2g/gaia/apps/browser/test/marionette/share_url_test.js:76:7

at ChildProcess.<anonymous> (/home/travis/build/mozilla-b2g/gaia/apps/browser/test/marionette/lib/server.js:38:7)

at ChildProcess.EventEmitter.emit (events.js:98:17)

at handlessage (child_process.js:318:10)

at Pipe.channel.onread (child_process.js:345:11)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 932331
You need to log in before you can comment on or make changes to this bug.