Closed Bug 935014 Opened 6 years ago Closed 6 years ago

Merge the Simulator and b2g-desktop

Categories

(DevTools :: WebIDE, defect)

defect
Not set

Tracking

(firefox30 fixed, firefox31 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
Firefox 31
Tracking Status
firefox30 --- fixed
firefox31 --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

(Depends on 1 open bug, )

Details

Attachments

(1 file)

We have various ways to run Gaia on desktop, with various subtle differences.
We should aim to merge all experiences on desktop to one environment.
We can easily start by merging b2g desktop and the simulator.
It will be about merging "prosthesis", the b2g desktop addon that simulator uses
to fix various stuff being broken in b2g desktop, but also to add various features without introducing risk to the product.
It will be also about ensuring that the simulator and b2g desktop uses the same gaia profile, built with the same configuration.

Then, it should be easy to also move the simulator addon itself to mozilla-central. This addon is mainly a build script that package b2g desktop and gaia profile into a xpi. This addon then just register to the firefox app manager in order to run b2g desktop with the gaia profile on demand.
Once we will have done that, we can build the addon when building b2g target
so that we get simulator builds for free when we build b2g desktop.
Depends on: 891882
Depends on: 942756
Depends on: 944443
Blocks: 944451
Depends on: 945235
This simple patch is meant to replace bug 942756 on 1.4 branch.
I wish we could uplift the UI patches I recently landed in bug 944443, and this patch,
so that we could spawn 1.4 simulator builds out of mozilla-central!
Bug 920198 is going to turn on FXOS_SIMULATOR build variable,
so that b2g desktop UI tweaks for phones will be on our builds.
It will also ensure building simulator xpis during b2g desktop builds.

My plan is to land this patch and bug 920198 shortly,
then let this bake on master and uplift.
Attachment #8395670 - Flags: review?(fabrice)
Attachment #8395670 - Flags: review?(fabrice) → review+
Assignee: nobody → poirot.alex
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/8b1a3307065a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Blocks: 976773
Comment on attachment 8395670 [details] [diff] [review]
Allows to specify the devtool debuggger port via the command line.

See bug 976773 comment 30.
We would like to build 1.4 simulators and need to uplift mostly desktop-specific patches.

This patch modify only desktop codepath.
Attachment #8395670 - Flags: approval-mozilla-aurora?
Attachment #8395670 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This doesn't apply to Aurora in ways that scream other dependencies.
Flags: needinfo?(poirot.alex)
Yes, it depends on another patch that is a+. You may have seen a bunch of patches from me to land in 1.4.
I drafted an order list of these patches in bug 976773 comment 30.
Before asking for a? I didn't knew I could have merged all patches into a single one... tell me if I should do that now to help the uplift.
Otherwise you should be able to checkin all these patches correctly with the given order. There is only one patch that requires a 1.4-specific version, it is bug 990057, specific in comment 31. There is a specific patch in the bug.
Flags: needinfo?(poirot.alex)
Ah, the problem is that the other bugs weren't showing up in the bug query I used. Makes more sense now :)
QA Whiteboard: [qa-]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.