[User Story] Notify users about contacts / friends birthday

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: jmcf, Unassigned)

Tracking

({feature, foxfood})

unspecified
ARM
Gonk (Firefox OS)
feature, foxfood

Firefox Tracking Flags

(tracking-b2g:backlog, ux-b2g:2.2)

Details

(Reporter)

Description

5 years ago
As a user I would like to see on my Calendar when my friend's / contacts birthday is and to be notified in advance. 

As per an initial talk to Ayman the idea is that the Calendar app should take care of showing birthday's information as an entry in the calendar. Thus, it will be needed some kind of "integration" between Contacts App and Calendar App, but let's not try in this meta bug to describe an specific solution. First, we will need some UX input and then we can discuss possible technical solutions.
(Reporter)

Comment 1

5 years ago
It would be a nice feature for v1.3 but it is not my job to prioritize. So let's leave that to our PMs
(Reporter)

Updated

5 years ago
Depends on: 935045
(Reporter)

Updated

5 years ago
No longer depends on: 935045
See Also: → bug 935045

Updated

5 years ago
blocking-b2g: --- → 1.4?

Updated

5 years ago
Component: Gaia → Gaia::Calendar
Not on the radar for 1.4, tagging with feature keyword to get it into PM queue for consideration.
blocking-b2g: 1.4? → ---
Keywords: feature
FWIW- Google does this automatically for you and your calendar ( I know because I fixed some invalid ical bugs they had ;p).

Updated

5 years ago
blocking-b2g: --- → backlog

Updated

5 years ago
blocking-b2g: backlog → 1.5?
from discussion with TEF, this is for 1.5 targeted. Wilfred is aware of this
Flags: needinfo?(cserran)
Since this would be a new feature, changing flag to backlog so that will get properly reviewed for planning/scoping etc.
blocking-b2g: 1.5? → backlog
Flags: needinfo?(cserran)
(Reporter)

Comment 6

4 years ago
Should be rescue this for 2.2?
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(francisco)
Something that Wilfred need to clarify :)
Flags: needinfo?(francisco)
this should go into productivity as well - so there are two parts to this - 

1. store birthday details in contacts
2. display birthday in calendar + calendar notification

storing birthdays in contact is present already - i think Dylan commented above that this is not on radar for productivity at the moment.

Candice  - can we set this to the product owner for productivity ?
Flags: needinfo?(wmathanaraj) → needinfo?(cserran)
FYI,

we already store fields birthday and anniversary in contacts.
Flags: needinfo?(cserran) → needinfo?(swilkes)

Comment 10

4 years ago
We can consider this for 2.2, but it's not high priority for that release.
ux-b2g: --- → 2.2
Flags: needinfo?(swilkes)

Comment 11

4 years ago
I would like to see this feature, too.

Alternatively I can imagine opening the calendar to third party apps, so other devs could play around with ideas.
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog

Updated

3 years ago
Keywords: foxfood

Updated

3 years ago
Duplicate of this bug: 1178109

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.