[Download Manager] Download list view skeleton

RESOLVED DUPLICATE of bug 935088

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 935088
4 years ago
4 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

unspecified
1.3 Sprint 4 - 11/8
All
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Implement the skeleton for our app or settings card (header, main container,...)
(Assignee)

Updated

4 years ago
Blocks: 935082
(Assignee)

Updated

4 years ago
Duplicate of this bug: 935090
(Assignee)

Updated

4 years ago
Summary: [Download Manager] Download list app skeleton → [Download Manager] Download list view skeleton
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 827657 [details]
Patch v1

Hi Kaze, this patch includes a new item in the main list to see the downloads. This is just a skeleton including the item in the main list and a new empty card. Are you comfortable with this code? It is the first time I touch in this app. Thanks a lot my mate
Attachment #827657 - Flags: review?(francisco.jordano)
Attachment #827657 - Flags: feedback?(kaze)
Comment on attachment 827657 [details]
Patch v1

Looks good to me.
Attachment #827657 - Flags: feedback?(kaze) → feedback+
Comment on attachment 827657 [details]
Patch v1

Asking Kaze, as owner to review it.

Accidentally didn't see that you already attached a patch for this, and I came with the excatly same solution.

So if I could do it, I would do a r+, but let ask Kaze for it :)

Also we will need to modify the css to select the correct icon, but first we need that icon (I saw another task for it)

Thanks!
Attachment #827657 - Flags: review?(francisco.jordano) → review?(kaze)
Comment on attachment 827657 [details]
Patch v1

Still looks good to me. :-)
Attachment #827657 - Flags: review?(kaze) → review+
(Assignee)

Comment 6

4 years ago
Thanks a lot guys!!!

https://github.com/mozilla-b2g/gaia/commit/2c61fbabc936f1477e3b5649e400af8d52ea8bcc
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Target Milestone: --- → 1.3 Sprint 4 - 11/8

Comment 7

4 years ago
Backouted since we don't want to leave a empty page without implementation, that confuses people.
https://github.com/mozilla-b2g/gaia/commit/b824c4ca99bb3e6921dae627cd5ecd6f94cafedf

Another note: please add bug number in your commit message next time. Thanks.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

4 years ago
(In reply to Evelyn Hung [:evelyn] from comment #7)
> Backouted since we don't want to leave a empty page without implementation,
> that confuses people.

bug 935082 seems to be the implementation of this page, I suggest to close this bug and move/merge this patch there.
(Assignee)

Comment 9

4 years ago
Sorry I forgot the number although I don't understand what you did here, we were in the middle of the spring thought and it was landed on master (AFAIK the development branch). Who people are confused in master?

Comment 10

4 years ago
(In reply to Cristian Rodriguez (:crdlc) from comment #9)
> Sorry I forgot the number although I don't understand what you did here, we
> were in the middle of the spring thought and it was landed on master (AFAIK
> the development branch). Who people are confused in master?

Some complains on dev-gaia caught my attention on this bug. Usually, when we close to FC date, landing partial work may be risky because if the feature can't be implemented in time, we have to push back the schedule and backed out all merged commits before branching out. Maybe this is not that dangerous case (we have one month to reach v1.3 FC date, 12/8), but I still hope we can keep Settings app in a functional stable state.
(In reply to Evelyn Hung [:evelyn] from comment #10) 
> Some complains on dev-gaia caught my attention on this bug. Usually, when we
> close to FC date, landing partial work may be risky because if the feature
> can't be implemented in time, we have to push back the schedule and backed
> out all merged commits before branching out. Maybe this is not that
> dangerous case (we have one month to reach v1.3 FC date, 12/8), but I still
> hope we can keep Settings app in a functional stable state.

Hi Evelyn,

thanks for your comments and support with settings app.

We landed that part cause we were following the pattern of landing small pieces of code that are functional. Right now this commit was adding a new panel, functional, yes just the panel, but not breaking the app.

As well reviewed by the owner of the module, but as you commented, and following your suggestions will land more bugs in a row to provide more functionality there.

Thanks a lot!
Whiteboard: [systemsfe]
This work is included in bug 935088.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 935088
No longer blocks: 935082
You need to log in before you can comment on or make changes to this bug.