Double touch on the slide would make Lockscreen can't unlock

VERIFIED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::System::Lockscreen
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: marcia, Assigned: snowmantw)

Tracking

({regression})

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

Attachments

(4 attachments)

Created attachment 827555 [details]
Video of trying to unlock the phone running 1.3

Buri, while using:

Gaia   5c2929cd15ac020f85026030387aed9eb322362d
SourceStamp 770de5942471
BuildID 20131105040208
Version 28.0a1

STR:
1. Performed an e.me search. Clicked on the official website link.
2. The throbber spun at the top for some time and nothing ever loaded
3. I pushed down the power button on the top of the device and then tried to open the phone.

Expected: I could unlock the phone
Actual: See video for my numerous attempts to unlock the phone. I finally had to restart the phone in order to open it.
Created attachment 827568 [details]
Logcat while trying to load official website in e.me

Here is the logcat I captured while trying to reproduce this. Note that I get a hang situation while the official website is loading, and when I hit the home button and got the lockscreen the logcat of course disconnects, but the same behavior of not being able to open the phone occurs - the slider simply won't open the phone. This is 100% reproducible using today's build.
Does this reproduce on 1.2?
blocking-b2g: --- → 1.3?
Keywords: qawanted
Not able to reproduce using Buri and the latest 1.2 build: 

Gaia   be4ea00a50236b10eb0a03232a28ffd0048e0cb8
SourceStamp 3ba912717904
BuildID 20131105004003
Version 26.0

The official website in question loads in this case, http://www.danicaracing.com/#4 - and I don't get the same hang I do using 1.3.
Keywords: qawanted
QA Wanted - does this reproduce on today's build?
Component: Gaia::Homescreen → Gaia::System::Lockscreen
Keywords: qawanted

Comment 5

4 years ago
I'm able to reproduce this issue with today's 1.3 build.

It took several presses of the home button while the e.me site mentioned in comment 3 was loading. I tapped the home button about 3 times before the issue reproduced, but then saw results exactly like the initial description.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131119040204
Gaia: 4ecbc106a3fcf72cbd6dd8a43c46de7bacbedf20
Gecko: ba9ecdea3a90
Version: 28.0a1
Base Image: V1.2_20131115
Keywords: qawanted
QA Contact: jzimbrick

Updated

4 years ago
Keywords: regression, regressionwindow-wanted

Comment 6

4 years ago
Regression window:

Last Working Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131031040201
Gaia: 412fd463bcb81f0e8bebf6d32500d0c02712748d
Gecko: f0d363d72753
Version: 28.0a1
Base Image: V1.2_20131115

First Broken  Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131101040203
Gaia: ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
Gecko: abe6790a5dd8
Version: 28.0a1
Base Image: V1.2_20131115
Keywords: regressionwindow-wanted
Triage: serious UI breakage.

Greg, I am not sure if this bug still reproduces on the new canvas impl. Could you verify that manually and/or check the regression range?
Assignee: nobody → gweng
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(gweng)
Summary: [Homescreen] [Buri] Lockscreen sometimes gets in a state where I cannot open the phone → Lockscreen sometimes gets in a state where I cannot open the phone
(Assignee)

Comment 8

4 years ago
I can't get any useful information on Buri's adb output, but I was aware of this issue. One thing need to be checked is that the Gaia I flashed to the Buri is the same master with the one which make Unagi boot hanging, and this must be solved with reflashing the device with newest Gecko. I don't know why, but on Unagi, with the new Gecko the broken Gaia would be works. So I'll try this on Buri, too.
Flags: needinfo?(gweng)
(Assignee)

Comment 9

4 years ago
I've tested this on the newest Buri PVT build:

Gaia      1d45d1dc3201059d5c8f2efdeb92c04576d8e161
Gecko     http://hg.mozilla.org/mozilla-central/rev/9f12a9fab080
BuildID   20131209053402
Version   28.0a1

And the lockscreen works fine now. I may need a check from the reporter.
Flags: needinfo?(mozillamarcia.knous)
Greg: I can actually still reproduce this on Buri using:

Gaia   c952e2756c03eceb4de6a3eba15651741a62f9e8
SourceStamp df82be9d89a5
BuildID 20131210040206
Version 29.0a1

Here is the exact search I did in e.me to trigger it:

1. Type "danica patrick" in the search field
2. Select "Official website" once the results are loaded (I think it tries to load http://danicaracing.com/)

Eventually I get in the same state as in the video, where I cannot open the phone and I have to reboot the device.
Flags: needinfo?(mozillamarcia.knous)

Comment 11

4 years ago
Hi, all,

I also can 100% reproduce this bug.
Please contact me if you want to know the detailed.
Thanks!

Attach the reproduction step (video).

* Test Build:
 - Gaia:     c952e2756c03eceb4de6a3eba15651741a62f9e8
 - Gecko:    http://hg.mozilla.org/mozilla-central/rev/df82be9d89a5
 - BuildID   20131210040206
 - Version   29.0a1

Comment 12

4 years ago
The attachment is more than 10240 KB.
So, please click the following hyperlink to know the reproduction steps.
- https://dc1.beta.safesync.com/LMsJysyJ/Cannot%20unlock%20lockscreen.mp4?a=qZZf0JF62p4
(Assignee)

Comment 13

4 years ago
It still can't reproduce on Unagi even I followed the instructions given by William:

Gaia      34c8e31c0d406486a46479a2700b4ac58581ea3b
Gecko     http://hg.mozilla.org/mozilla-central/rev/1ad9af3a2ab8
BuildID   20131212040203
Version   29.0a1

But I notice if I search another keyword and open the 'official website' the phone got lagged and finally crashed to reboot. I need to check if this is a Buri only bug, and whether it's actually a lockscreen bug or not.
(Assignee)

Comment 14

4 years ago
These lines seems related:

E/GeckoConsole(  140): [JavaScript Error: "TypeError: runningApps[displayedApp] is undefined" {file: "app://system.gaiamobile.org/js/window_manager.js" line: 1050}]
E/GeckoConsole(  140): [JavaScript Error: "TypeError: runningApps[displayedApp] is undefined" {file: "app://system.gaiamobile.org/js/window_manager.js" line: 1097}]

In my experience, errors like this would cause lockscreen cannot unlock. But we still need to find out what's the root cause of these erros.
(Assignee)

Comment 15

4 years ago
On Nexus4 this error is unable to reporduce, too:

Gaia      8952898bbc98dd31e25b647203791cf129867ff1
Gecko     http://hg.mozilla.org/mozilla-central/rev/1ad9af3a2ab8
BuildID   20131212040203
Version   29.0a1

And Buri, too:

Gaia      8952898bbc98dd31e25b647203791cf129867ff1
Gecko     http://hg.mozilla.org/mozilla-central/rev/1ad9af3a2ab8
BuildID   20131212040203
Version   29.0a1

Three things I've discoveryed: 

1. Performance issue: when I follow the instructions given by William, I noticed that the system lagged awefully, and the lockscreen is still unlock-able, even though it would unlocked very slow (wait 1~2 secs and then the screen fade out). I suspect this problem concerns NOT only lockscreen, but other components according to the logged errors and the system status.

2. I still can't reproduce this on Unagi, Nexus4 and even on Buri... William tried several times on the Buri I listed above, but we both can't reproduce this.

3. There seems something not cleared even after reboot: lagged still very serious even after rebooting.
(Assignee)

Comment 16

4 years ago
Can Marcia check this again?
Flags: needinfo?(mozillamarcia.knous)

Comment 17

4 years ago
(In reply to Greg Weng [:snowmantw] from comment #15)
> On Nexus4 this error is unable to reproduce, too:
> 
> Gaia      8952898bbc98dd31e25b647203791cf129867ff1
> Gecko     http://hg.mozilla.org/mozilla-central/rev/1ad9af3a2ab8
> BuildID   20131212040203
> Version   29.0a1
> 
> And Buri, too:
> 
> Gaia      8952898bbc98dd31e25b647203791cf129867ff1
> Gecko     http://hg.mozilla.org/mozilla-central/rev/1ad9af3a2ab8
> BuildID   20131212040203
> Version   29.0a1
> 
> Three things I've discoveryed: 
> 
> 1. Performance issue: when I follow the instructions given by William, I
> noticed that the system lagged awefully, and the lockscreen is still
> unlock-able, even though it would unlocked very slow (wait 1~2 secs and then
> the screen fade out). I suspect this problem concerns NOT only lockscreen,
> but other components according to the logged errors and the system status.
> 
> 2. I still can't reproduce this on Unagi, Nexus4 and even on Buri... William
> tried several times on the Buri I listed above, but we both can't reproduce
> this.

Update the information
I cannot reproduce this bug on latest V1.3 build.
Maybe some patch have fixed this bug or it became a potential issue.
Thanks!

* Test Build:
 - Gaia:     588a3e02c4ace3b3341ba1f6bb7274120b53b2b3
 - Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/031270be3702
 - BuildID   20131212004003
 - Version   28.0a2
 => Cannot reproduce.


> 3. There seems something not cleared even after reboot: lagged still very
> serious even after rebooting.
I cannot reproduce this consistently, but I still have seen it on Buri using today's build:

Gaia   1752e9e8f2b84b9db5d96ae5940596957fc8ed6c
SourceStamp 2ec5a40f544e
BuildID 20131216004002
Version 28.0a2

I am testing on Mozilla Guest wifi so it is not a very strong wifi network.
Flags: needinfo?(mozillamarcia.knous)
(Assignee)

Comment 19

4 years ago
I think that before we can stably reproduce this bug or confirm it's disappeared, I can't do any thing except try again to reproduce it. However, according to my previous tries, I don't believe I would get it successfully, or at least not to easy.

Comment 20

4 years ago
Hi, Greg and all,

I found a easy way to reproduce this bug.
While the blue bar covers the unlock icon, trying to use the other finger to tap blank part of the unlock bar.
You will see the lock screen hang there.
Attaching the video.
Thanks!

* Build Information:
 - Gaia      5de94a2be6ab8d33434294d70c1de330f55d8f2d
 - Gecko     http://hg.mozilla.org/mozilla-central/rev/c8d5a871ae32
 - BuildID   20140101040201
 - Version   29.0a1

* Result:
  Can reproduce

Comment 21

4 years ago
Created attachment 8355151 [details]
WP_20140102_003.mp4
(Assignee)

Comment 22

4 years ago
(In reply to William Hsu [:whsu] from comment #20)
> Hi, Greg and all,
> 
> I found a easy way to reproduce this bug.
> While the blue bar covers the unlock icon, trying to use the other finger to
> tap blank part of the unlock bar.
> You will see the lock screen hang there.
> Attaching the video.
> Thanks!
> 
> * Build Information:
>  - Gaia      5de94a2be6ab8d33434294d70c1de330f55d8f2d
>  - Gecko     http://hg.mozilla.org/mozilla-central/rev/c8d5a871ae32
>  - BuildID   20140101040201
>  - Version   29.0a1
> 
> * Result:
>   Can reproduce

So this bug seems unrelated to e.me anymore. I would at least consider to change the title...
And, I don't think this symptom is the same with the original one. Would it better to open another bug?
(Assignee)

Comment 23

4 years ago
William and I would try to solve this bug according to the last symptom, but I'm not sure that these are the same bug (because of the different STR). If this bug got patched and the symptom still occurs, I think we should open another bug and close this one.
(Assignee)

Updated

4 years ago
Summary: Lockscreen sometimes gets in a state where I cannot open the phone → Double touch on the slide would make Lockscreen can't unlock
Greg, any update on this issue?
Flags: needinfo?(gweng)
(Assignee)

Comment 25

4 years ago
I would study this bug tomorrow. Today I spent lots of time to identify the problem of Bug 945082, including to implement a demo app, and try every possible ticks I can use in Gaia.
Flags: needinfo?(gweng)
(Assignee)

Comment 26

4 years ago
I've found that I need to handle some problems occur while there're multiple touch events. Especially on Unagi, sometime it would report 2 touch events when it obviously should report only 1.
(Assignee)

Comment 27

4 years ago
Created attachment 8357063 [details] [review]
Patch

Despite the strange touchevents on Unagi, this bug seems be solved by only handling the first touched one. I got stuck before because some strange detection and flag, but now they're all gone.

And William and I have found there is bug in another edge case (touching near the circle would unlocking the phone). But I need to figure out it because the STR is still unknown now.
(Assignee)

Comment 28

4 years ago
Comment on attachment 8357063 [details] [review]
Patch

Forgot to set reviewer, and Travis failed due to timeout issue.
Attachment #8357063 - Flags: review?(timdream)
Comment on attachment 8357063 [details] [review]
Patch

Thanks!
Attachment #8357063 - Flags: review?(timdream) → review+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x -m1 8b8c8a5565f012760984dc85d61cff9fcd485af5
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(gweng)
(Assignee)

Comment 32

4 years ago
This is because the Bug 945601 was not checked in v1.3, which is not a 1.3+ bug.
I would mark it as 1.3? to let it be checked in.
Flags: needinfo?(gweng)
(Assignee)

Comment 33

4 years ago
Tim approved me to check in the Bug 945601, and I would check in this as well.
(Assignee)

Comment 34

4 years ago
I've merged and pushed the bug in v1.3:

https://github.com/mozilla-b2g/gaia/commit/b19cb791af2485cbb1fbf45b7b689b98d79c00a4
status-b2g-v1.3: --- → fixed

Comment 35

4 years ago
Thanks for all your help!
I cannot reproduce this bug on latest V1.3 by using test steps of comment 12 and comment 20. :)

Build information:
 * Gaia      26e8a950f3ac703310ee8efcb741ff2418e9d190
 * Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/ecdc275e9741
 * BuildID   20140217004003
 * Version   28.0

Test Result:
 * Cannot reproduce.
Status: RESOLVED → VERIFIED
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
You need to log in before you can comment on or make changes to this bug.