Loading joyent.com hangs/freezes Firefox nightly on desktop UI for a long time

VERIFIED FIXED in Firefox 27

Status

()

Core
Layout
--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: stephend, Assigned: roc)

Tracking

({hang, regression})

27 Branch
mozilla28
x86
All
hang, regression
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27+ verified, firefox28+ verified)

Details

(URL)

(Reporter)

Description

4 years ago
STR:

1. Using a Windows nightly of desktop Firefox (Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0), load http://www.joyent.com
2. Wait

Actual Results:

The UI becomes unresponsive almost immediately, and it takes a very long time to be able to interact with the page/tab

(I've confirmed this doesn't happen with Firefox 25 -- sorry, no time right now to find a regression range.)

Comment 1

4 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/855da6d8a327
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017044622
Bad:
http://hg.mozilla.org/mozilla-central/rev/2def80d5a106
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131018023712
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=855da6d8a327&tochange=2def80d5a106


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9c8ab7e9ae41
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017025216
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/45d9e6cd3473
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131017030414
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9c8ab7e9ae41&tochange=45d9e6cd3473

In local build
last good: 9c8ab7e9ae41
first bad: a417424f9213

Regressed by:
a417424f9213	Robert O'Callahan — Bug 923193. Make transform-origin on SVG elements use the SVG bbox as the reference rectangle. r=heycam

Keywords: regression
Blocks: 923193
status-firefox26: --- → unaffected
tracking-firefox27: --- → ?
tracking-firefox28: --- → ?
Keywords: regressionwindow-wanted → hang, regression
Version: unspecified → 27 Branch

Comment 2

4 years ago
I can reproduce the hang on Linux too.

http://hg.mozilla.org/mozilla-central/rev/770de5942471
Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131105030206
OS: Windows 7 → All

Updated

4 years ago
status-firefox27: --- → affected
status-firefox28: --- → affected
tracking-firefox27: ? → +
tracking-firefox28: ? → +
Bug 923193 has been backed out on trunk, did it fix this problem?
Flags: needinfo?(stephen.donner)

Comment 4

4 years ago
I cannot reproduce the problem in latest Aurora27.0a2 and Nightly28.0a1.

http://hg.mozilla.org/releases/mozilla-aurora/rev/b353e78ee8e7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131117004001
http://hg.mozilla.org/mozilla-central/rev/a475f94bb1b1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131117030203
The Aurora result is strange, because bug 923193 hasn't been backed out on Aurora yet, AFAICT.

Comment 6

4 years ago
Progression window(aurora)
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/571b5e7bf31f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131108004000
Works again:
http://hg.mozilla.org/releases/mozilla-aurora/rev/eeec8acdb32c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131108065242

Progression Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=571b5e7bf31f&tochange=eeec8acdb32c

Seems to be fiexed by Bug 933354
OK, that makes sense.  We need to test this again after the backout on Aurora since
bug 933354 is one of the fixes that got backed out.
(the changesets in bug 923193 comment 35 for reference)
Flags: needinfo?(stephen.donner)
added qawanted to help verify that the backout of 923193 helped this bug by testing the latest aurora build.
Keywords: qawanted
QA Contact: twalker
I can not reproduce any hang with latest Aurora build on Windows 7


Benjiman, please don't assign others to the QA Contact field.   It is meant as an "I'll take this." sort of thing that one signs themselves up to own the QA for the bug.
QA Contact: twalker
Leaving qawanted to be cleared by either Alice0775 White or stephend as they had been able to reliably reproduce previously.

Comment 11

4 years ago
I cannot reproduce the problem in latest Aurora27.0a2 and Nightly28.0a1 on Windows7 and Ubunto12.04
(In reply to Alice0775 White from comment #11)
> I cannot reproduce the problem in latest Aurora27.0a2 and Nightly28.0a1 on
> Windows7 and Ubunto12.04

Excellent, thank you!
Keywords: qawanted
Thanks for testing.  Resolving as fixed by the backout of bug 923193 and related patches.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Assignee: nobody → roc
status-firefox27: affected → fixed
status-firefox28: affected → fixed
Target Milestone: --- → mozilla28
Verified fixed based on comment 11.
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
status-firefox28: fixed → verified
You need to log in before you can comment on or make changes to this bug.