Opening a tel: link without the dialer running in the background opens the dialer app without a phone number present

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build: 11/5/2013 Buri 1.3

STR

1. Open the browser
2. In the URL bar, type tel:123 & hit enter

Expected

The dialer app should open with the number 123 shown.

Actual

The dialer app opens, but without the 123 number shown.

Additional Notes

This only happens when the dialer app isn't running in the background. If the dialer app is active in the background, then this will work.
(Reporter)

Comment 1

5 years ago
This was working on 1.1 when Naoki checked on his 11/4 base image 1.1 build.

We should get a regression window & find out if this reproduces on 1.2.
blocking-b2g: --- → 1.3?
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
QA Contact: sparsons

Comment 2

5 years ago
I was unable to reproduce this issue on the Buri 1.3 Build ID: 20131106040203

Gaia   3b5fe429f2414f2a9d7241b311b399033bb10612
SourceStamp 9ba3faa35c96
BuildID 20131106040203
Version 28.0a1

I checked multiple builds and the only one I could repro the issue on was Buri 1.3 Build ID: 20131101040203

Gaia   ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
SourceStamp abe6790a5dd8
BuildID 20131101040203
Version 28.0a1

Removing the Regression-Window Wanted, and Regression tags since this no longer reproduces on the current build.
Keywords: regression, regressionwindow-wanted
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.