Cannot use browser to launch URL from Dreamweaver

RESOLVED INVALID

Status

()

Core
Networking: HTTP
--
major
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Peter English, Assigned: neeti)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

Macromedia Dreamweaver UltraDev allows you to register a browser as a secondary
or primary browser.

I registered build 0.92 in Macromedia Dreamweaver and used their JavaScript API
to launch a URL from within a Macromedia extension.  

With version 0.92 of mozilla, I was able to do it.  With version 0.93, the
browser launches, but the URL was not diplayed in the address bar and the page I
wanted was not displayed.

The URL I was launching was:

http://localhost:8080/Store/Admin

Reproducible: Always
Steps to Reproduce:
1.Have Madromedia DreamWeaver UltraDev installed and mozilla 0.93 registered as
the secondary browser.

2.Edit one of their extensions command files to execute:

dw.browseDocument('http://localhost:8080/Store/Admin', 'secondary');


Actual Results:  http://localhost:8080   in address bar 

Not Found (404)
Original request: /

Not found request: /

Expected Results:  http://localhost:8080/Store/Admin      in address bar 

and the admin web page is displayed

See Extending Dreamweaver and UltraDev in the help menu of Macromedia
Dreamweaver Ultradev to see the API for viewing a web page by executing a
command in their JavaScript API.

I was able to successfully launch pages using the API in Dreamweaver with
Mozilla 0.92, but was not able to do it with Mozilla 0.93.
-> XP APPS
Component: Browser-General → XP Apps
(Reporter)

Comment 2

17 years ago
Seems that having the port number in the URL causes the error.

I also notice a bunch of funky stuff happening with the URL as it is initially 
loaded into browser from the API call.

You can temporarily see the slashes in the URL change from "\" to "/".

Whoever changed the code from version 0.92 to 0.93 really messed things up.  I 
reccommend that a diff be done between the to with regard to launching the 
browser from an API on Windows platform.

Updated

17 years ago
Assignee: asa → neeti
Component: XP Apps → Networking: HTTP
QA Contact: doronr → tever

Comment 3

17 years ago
networking / evangelism?

Comment 4

17 years ago
How does this work, do they send javascript to us, or just call the OS w/ a URL?

(Reporter)

Comment 5

17 years ago
Looks like this bug may be a Macromedia bug.  I was able to reproduce it with 
Internet Explorer 5.5.

Looks like Mozilla 0.92 has some code to correct the syntax of the URL passed 
to it so Mozilla 0.92 masked the effect of the bug.

Comment 6

17 years ago
I have used DW since 2.0, and currently own DW UltraDev 4. This is indeed a DW
bug. Worse, it's an intermittent bug at that. It doesn't ALWAYS happen, due to
stuff that goes on under the hood in DW. DW is a lot like Moz in that it's not
all compiled code. Lots of interpreted code. And, like Moz, it's not all perfect
yet. But UNLIKE Moz, they put it out as a final product.

Anyway, I've seen this for a long time. It's an internal bug that I first
noticed in DW3. I've reported it for 3, 4, adn UltraDev 4, but nothing has ever
been done about it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.