Closed Bug 935277 Opened 6 years ago Closed 6 years ago

Fix and reenable browser_webconsole_bug_632347_iterators_generators.js

Categories

(DevTools :: Console, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 28

People

(Reporter: KWierso, Assigned: msucan)

Details

Attachments

(1 file)

This test has been timing out frequently since the fix for bug 932322 landed, even with the increased timeout limit.
https://tbpl.mozilla.org/php/getParsedLog.php?id=30167998&tree=Mozilla-Inbound

I'm disabling it not for Linux, and it needs to be fixed and reenabled.
(In reply to Wes Kocher (:KWierso) from comment #0)
> This test has been timing out frequently since the fix for bug 932322
> landed, even with the increased timeout limit.
> https://tbpl.mozilla.org/php/getParsedLog.php?id=30167998&tree=Mozilla-
> Inbound
> 
> I'm disabling it not for Linux, and it needs to be fixed and reenabled.

s/not/now/

Disabled in https://hg.mozilla.org/integration/mozilla-inbound/rev/737384156314
(In reply to Wes Kocher (:KWierso) from comment #1)
> (In reply to Wes Kocher (:KWierso) from comment #0)
> > This test has been timing out frequently since the fix for bug 932322
> > landed, even with the increased timeout limit.
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=30167998&tree=Mozilla-
> > Inbound
> > 
> > I'm disabling it not for Linux, and it needs to be fixed and reenabled.
> 
> s/not/now/
> 
> Disabled in
> https://hg.mozilla.org/integration/mozilla-inbound/rev/737384156314

https://hg.mozilla.org/integration/mozilla-inbound/rev/dbf7a53eeff5
Now with actually disabling the correct test!
msucan: this is the test I pinged you about before. It's timing out because window has many more properties now, we tried upping the timeout but it keeps timing out. The test should really be rewritten so that it doesn't keep getting slower when we add properties to window.
https://hg.mozilla.org/mozilla-central/rev/737384156314
https://hg.mozilla.org/mozilla-central/rev/dbf7a53eeff5
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
(In reply to Carsten Book [:Tomcat] from comment #4)
> https://hg.mozilla.org/mozilla-central/rev/737384156314
> https://hg.mozilla.org/mozilla-central/rev/dbf7a53eeff5

reopen, since the disabling landed on m-c not the fix and enabling
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Wes Kocher (:KWierso) from comment #2)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/dbf7a53eeff5
> Now with actually disabling the correct test!

Don't forget [leave open] when disabling tests :-)
Peter, is there any chance that the perf regressions caused by bug 932322 are ultimately what made this test so much slower too?
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #7)
> Peter, is there any chance that the perf regressions caused by bug 932322
> are ultimately what made this test so much slower too?

It's unlikely, the regression is related to 1 specific property, window.document. We added about 100 properties.
The timeout was caused by variables view taking a lot of time to show the |window| properties on linux in debug builds.

I changed the iterators and generators test file to put the new properties on a container object of their own, so we don't have to open vview for |window|. Hopefully this will avoid timeouts.

No try push yet, due to TREE CLOSED.
Assignee: nobody → mihai.sucan
Status: REOPENED → ASSIGNED
Attachment #8338825 - Flags: review?(past)
Comment on attachment 8338825 [details] [diff] [review]
bug-935277-1-fx-team.diff

Review of attachment 8338825 [details] [diff] [review]:
-----------------------------------------------------------------

Good idea.
Attachment #8338825 - Flags: review?(past) → review+
Thanks for the review!

Landed: https://hg.mozilla.org/integration/fx-team/rev/921670f4c865
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/921670f4c865
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.