Word offsets broken if the next word is an embedded object

RESOLVED FIXED in Firefox 28

Status

()

Core
Disability Access APIs
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jamie, Assigned: surkov)

Tracking

(Blocks: 1 bug, {regression})

Trunk
mozilla29
x86_64
Windows 7
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox28 fixed, firefox29 fixed)

Details

(Whiteboard: [qa-])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Str:
1. Use the following code:
<body>
a <a href="#">b</a>
</body>
2. Get the offsets for the word at offset 0; e.g. via IAccessibleText::textAtOffset with IA2_TEXT_BOUNDARY_WORD.
Expected: (0, 2)
Actual: (2, 2)
Same for offset 1.

Impact: Among other things, brokenness for screen reader users when using control+backspace in these situations.

Symptom originally reported by an NVDA user here: http://community.nvda-project.org/ticket/3621
(Assignee)

Updated

5 years ago
Blocks: 613857
(Assignee)

Comment 1

5 years ago
I get (0, 2) on Nightly. Jamie, can you retest it please and if it doesn't work then provide a test case (simple "data:text/html,a <a href="www">b</a>" works as expected for me)
(Reporter)

Comment 2

5 years ago
Wow! I didn't know about data: URLs. You learn something new every day. :)

Just tested with latest nightly and I get the same result using an html file. I even pasted:
data:text/html,a <a href="www">b</a>
into the Address bar and tested with that. I get the same result.
(Reporter)

Comment 3

5 years ago
To clarify (since i wasn't clear in my str), I'm doing this on the document accessible.
(Assignee)

Comment 4

5 years ago
you're right, I just figured out I tested wrong version. I can reproduce a problem now

(In reply to James Teh [:Jamie] from comment #2)
> Wow! I didn't know about data: URLs. You learn something new every day. :)

yep, it's a nice feature, I just get used to forget it syntax occasionally :)
(Assignee)

Comment 5

5 years ago
Created attachment 8341692 [details] [diff] [review]
patch
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #8341692 - Flags: review?(trev.saunders)
Attachment #8341692 - Flags: review?(trev.saunders) → review+
https://hg.mozilla.org/mozilla-central/rev/aa29a685d835
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
(Assignee)

Updated

5 years ago
Keywords: regression
(Assignee)

Comment 8

5 years ago
Created attachment 8349050 [details] [diff] [review]
aurora patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): something from recent text works, bug getText*a11y
User impact if declined: text navigation problem in firefox/thunderbird for AT users
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): small risk (should be ok for early cycle)
String or IDL/UUID changes made by this patch: no
Attachment #8349050 - Flags: approval-mozilla-aurora?
Attachment #8349050 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/7a42668c79b0
status-firefox28: --- → fixed
status-firefox29: --- → fixed
Keywords: checkin-needed
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.