[B2G][Helix][Settings][WangChao]Settings is not listen to the change of 'icc.applications'.

RESOLVED DUPLICATE of bug 907628

Status

P2
normal
RESOLVED DUPLICATE of bug 907628
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 827852 [details]
no_stk_first_but_show_up_after_reopen.txt

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

Repro step:
1.when device boot, open the Settings, to see if the STK menu is exist.

Expected:
1.there is STK Menu.

Actual:
1.STK Menu is missing and will not show up. 
2.But only if kill the Settings and reopen it, can see the STK menu.

My opinion:
1.the first time i open Settings, 'icc.applications' is not cached yet, it can not get the STK Menu.
2.After the Settings is opened, 'icc.applications' is cached, but Settings is not listen to the change and do nothing, so STK Menu can not show up.
3.Only kill Settings and reopen it, it read the 'icc.applications', then STK Menu shows up. 

I think Settings should listen to the change of 'icc.applications' if Settings is already opened.

Thanks!
(Reporter)

Updated

5 years ago
Component: General → Gaia::Settings
Priority: -- → P2
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907628
You need to log in before you can comment on or make changes to this bug.