[Single Variant] apps configured in the screen 0 aren't installed if we insert the SIM after complete the FTE

VERIFIED WONTFIX

Status

Firefox OS
Gaia::Homescreen
VERIFIED WONTFIX
4 years ago
4 years ago

People

(Reporter: rafael.marquez, Unassigned)

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

4 years ago
****Steps
1. Installing a v1.2 build on device
2. Clone the tests repository for sigle variant: https://github.com/telefonicaid/firefoxos-gaia-testsbuild.git
3. Configuring the file firefoxos-gaia-testsbuild/variant.json
4. Clone Gaia repository and select the v1.2 branch.
5. Executing the command "GAIA_DISTRIBUTION_DIR=/home/tel056/firefoxos-gaia-testsbuild  PRODUCTION=1 make reset-gaia" to install gaia with single variant in the device
6. Complete FTE  without SIM card inserted in the device
7. Insert a movistar sim (in this case is the mcc/mnc configured in variant.json file)

****Expected Result
Operator apps are installed after insert the sim

****Actual Result
Operator apps configured in the screen 0 aren't installed if we insert the SIM after complete the FTE


Variant.json file:
{
  "apps": {
    "Twitter":
      {
        "origin": "https://mobile.twitter.com",
        "manifestURL": "https://mobile.twitter.com/cache/twitter.webapp",
        "installOrigin": "https://marketplace.firefox.com"
      },
    "Facebook":
      {
        "origin": "http://m.facebook.com",
        "manifestURL": "http://m.facebook.com/openwebapp/manifest.webapp",
        "installOrigin": "https://marketplace.firefox.com"
      },
    "Wikipedia":
      {
        "origin": "https://bits.wikimedia.org",
        "manifestURL": "https://bits.wikimedia.org/WikipediaMobileFirefoxOS/manifest.webapp",
        "installOrigin": "https://marketplace.firefox.com"
      },
    "Accuweather":
      {
        "origin": "http://m.accuweather.com",
        "manifestURL": "http://m.accuweather.com/mozilla.webapp",
        "installOrigin": "https://marketplace.firefox.com"
      },
    "Calculator":
      {
        "origin": "app://calculator",
        "installOrigin": "https://marketplace.firefox.com",
        "manifestURL": "https://marketplace.firefox.com/app/9f96ce77-5b2d-42ca-a0d9-10a933dd84c4/manifest.webapp"
      },
    "Poppit":
      {
        "origin": "app://poppit",
        "installOrigin": "https://marketplace.firefox.com",
        "manifestURL": "https://marketplace.firefox.com/app/d37cb5ed-525a-408e-a7cf-ec848064e041/manifest.webapp"
      }
  },
  "operators": [
    {
      "id": "movistar",
      "mcc-mnc": [
        "214-001",
        "214-002",
        "214-005",
        "214-007"
      ],
      "apps": [
        {
          "id": "Calculator",
          "screen": 0,
          "location": 1
        },
        {
          "id": "Poppit",
          "screen": 1,
          "location": 1
        },
	{
          "id": "Facebook",
          "screen": 1,
          "location": 2
        },
	{
          "id": "Accuweather",
          "screen": 0,
          "location": 3
        },
	{
          "id": "Twitter",
          "screen": 2,
          "location": 0
        },
        {
          "id": "Wikipedia",
          "screen": 2,
          "location": 1
        }
      ],
      "support_contacts": "resources/support_contacts_movistar.json",
      "default_contacts": "resources/contacts_movistar.json",
      "ringtone": "resources/Movistar_Mid_ABR_128kbps.ogg",
      "wallpaper": "resources/customize.jpg"
    },
    {
      "id": "venezuela",
      "mcc-mnc": [
        "734-004"
      ],
      "apps": [
        {
          "id": "Twitter",
          "screen": 1,
          "location": 2
        },
        {
          "id": "Facebook",
          "screen": 1,
          "location": 3
        },
        {
          "id": "Accuweather",
          "screen": 2,
          "location": 3
        },
        {
          "id": "Wikipedia",
          "screen": 2,
          "location": 2
        }
      ],
      "ringtone": "resources/ringer_dream_theme.ogg",
      "wallpaper": "resources/customize2.png"
    }
  ]
}

For this variant.json using movistar sim. Accuweather and Calculator apps are not installed



Devide: Unagi
Branch: v1.2
Gecko: 1303dc0
Gaia: 2140c98
(Reporter)

Comment 1

4 years ago
An important annotation: The bug only is reproduced when you insert the SIM after completing the FTE. If we complete the FTE with a sim inserted, the apps are installed correctly
Blocks: 893807
blocking-b2g: --- → koi?
Whiteboard: [systemsfe]
I believe this is expected behavior. Screen 0 on a 1.2 build is defined as the e.me search UI that doesn't support homescreen icons on that screen. So when we try to install apps on that screen, we fail to install, because screen 0 doesn't support homescreen grid icons.

However - this use case should work for 1.3, as 1.3 does allow homescreen app icons on screen 0.

I need to double check this however - will look at this more when I get into the office.
Flags: needinfo?(jsmith)
(In reply to rafael.marquez from comment #1)
> An important annotation: The bug only is reproduced when you insert the SIM
> after completing the FTE. If we complete the FTE with a sim inserted, the
> apps are installed correctly

Although this statement is a bit strange - I wouldn't expect this use case to work on 1.2.
Flags: needinfo?(jsmith)

Updated

4 years ago
Flags: needinfo?(jsmith)
(Reporter)

Comment 4

4 years ago
I know that in v1.2 can not install apps on the screen 0, but it was defined that the apps configured in the screen 0 are installed  in the first free slot.

Anyway the behavior is wrong as you can see in the comment 1, the behavior is different if you complete the FTE with SIM inserted and if inserts a sim card after completing the FTE without sim.
(In reply to rafael.marquez from comment #4)
> I know that in v1.2 can not install apps on the screen 0, but it was defined
> that the apps configured in the screen 0 are installed  in the first free
> slot.
> 
> Anyway the behavior is wrong as you can see in the comment 1, the behavior
> is different if you complete the FTE with SIM inserted and if inserts a sim
> card after completing the FTE without sim.

Agreed - we should be consistent in what we should do here, whether that means allowing apps to be installed on screen 0 or not allowing it at all.

Updated

4 years ago
Flags: needinfo?(jsmith)
Minus - right now there is no app on Screen 0. But there are apps starting screen 1, so this should not block a release. Please re-nom if deemed necessary.
blocking-b2g: koi? → -
(In reply to Preeti Raghunath(:Preeti) from comment #6)
> Minus - right now there is no app on Screen 0. But there are apps starting
> screen 1, so this should not block a release. Please re-nom if deemed
> necessary.

To clarify - the target grids we ship with always put apps on screen 1 & screen 2, so we don't need to block on issues where apps aren't working on screen 0. If this bug impacts screen 1 & 2, renom.
This only happens on 1.2 and only if the grid is incorrectly configured.
I think the best way forward would be to close this bug and just add in the uplift to 1.2 of bug 929572 a validation so setting at screen 0 for an app raises an error.
In any case if you consider that this is worthwhile I can write a 1.2 only patch for this
(In reply to Carmen Jimenez Cabezas from comment #8)
> This only happens on 1.2 and only if the grid is incorrectly configured.
> I think the best way forward would be to close this bug and just add in the
> uplift to 1.2 of bug 929572 a validation so setting at screen 0 for an app
> raises an error.
> In any case if you consider that this is worthwhile I can write a 1.2 only
> patch for this

That sounds fine to me, although I don't think we'll get an approval request on bug 929572 at this point. I'll wait for Rafael to comment to indicate if he's okay with the resolution path. If he's okay with it, then we can close this bug out.
Flags: needinfo?(rafael.marquez)
(Reporter)

Comment 10

4 years ago
I keep this bug.
The bug "929572" is developed for v1.3 and I think I don't have control of the apps configured on the screen 0. 
In other words. The bug "929572" allows you to install apps on the screen 0, which in 1.2 is a bug.
Flags: needinfo?(rafael.marquez)
(In reply to rafael.marquez from comment #10)
> I keep this bug.
> The bug "929572" is developed for v1.3 and I think I don't have control of
> the apps configured on the screen 0. 
> In other words. The bug "929572" allows you to install apps on the screen 0,
> which in 1.2 is a bug.

Right - But if we're not blocking this & this only reproduces on 1.2, then technically would this be a Won't Fix, right?
(Reporter)

Comment 12

4 years ago
I think we have a strange case. The bug must be solved, but the patch should be applied only in 1.2 and not in master branch.
I dont know what would be the process.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.