Closed Bug 935460 Opened 6 years ago Closed 6 years ago

Mouse wheel blocked when a doorhanger (url bar popup) is active

Categories

(Core :: Widget: Gtk, defect)

25 Branch
x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 849544

People

(Reporter: wolfgang, Assigned: enndeakin)

References

Details

(Whiteboard: [bugday-20131106][doorhanger])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

On a linux system:
1. Cause Firefox to pop up one of those url bar popups (e.g. »Flash plugin is missing«, »Do you want to save the password you just entered?«) on a page that is long enough to have a scrollbar

2. Move mouse cursor over page and use mouse wheel to scroll


Actual results:

Page doesn't scroll. This is probably OK in with windows, where only active controls scroll, but it's not ok on Linux, where every control scrolls as soon as it the mouse wheel is actuated with the mouse cursor over it.


Expected results:

Page should scroll.
WFM on Win 7, I can use the mouse wheel to scroll when a dialog bof of the location bar is open, see http://i.imgur.com/MoNv9iH.jpg

Can you test with a clean profile, please:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(wolfgang)
Summary: Mouse wheel blocked when an url bar popup is active → Mouse wheel blocked when a doorhanger (url bar popup) is active
Whiteboard: [bugday-20131106]
Whiteboard: [bugday-20131106] → [bugday-20131106][doorhanger]
Tried it on a new profile, made Firefox window small enough for a scrollbar, went to facebook, entered wrong password, the »save password« door hanger turned up, no scrolling of the page using the mouse wheel possible until the doorhanger goes away.

@Loic: I don't know about the windows version, but I think the behaviour I described would be deemed correct on a windows system. I explicitly stated it was about linux systems.

I have also reproduced the bug on a second system now
1. Debian testing, KDE, original 32bit Firefox package from the Firefox website
2. Arch Linux, KDE, Arch Linux Firefox package (64 bit)
Flags: needinfo?(wolfgang)
(In reply to wolfgang from comment #2)
> @Loic: I don't know about the windows version, but I think the behaviour I
> described would be deemed correct on a windows system. I explicitly stated
> it was about linux systems.

I don't know, but bug 597723 might be related at least to that.
Component: Untriaged → General
Reproducible on the latest Nightly, Aurora and Firefox 26.0b5 on Ubuntu 13.04 32bit.

I think this is by design though: when the popup is displayed the focus is switched to it, so when you are trying to scroll, you are trying to scroll the popup, not the window content.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 935874
Component: General → Widget: Gtk
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 849544
Attached patch mousewheelgtkSplinter Review
Assignee: nobody → enndeakin
Attachment #8339364 - Flags: review?(karlt)
I'll move this patch to 849544.
Comment on attachment 8339364 [details] [diff] [review]
mousewheelgtk

I hadn't considered processing mouse wheel events on other windows even when leaving the pointer grab on the popup.
Attachment #8339364 - Flags: review?(karlt) → review+
You need to log in before you can comment on or make changes to this bug.